none
Enable PME Group Policy Windows 7

    Question

  • Good evening,

    We have about 800 computers in our environement.  We are using system mangement software that applies power management policies.  This includes a shutdown policy at the end of the day and a remote wakeup policy for the morning.  I have found that in Windows 7 Power Mangement Event PME is disabled by default.  I need to enable it on my workstations so I can use WOL.  Is there a way to do it through group policy?  If not is there a registry key I can change and apply through group policy.  Any help would be appreciated.  Thank you.

    Dan


    Daniel Cumming
    Tuesday, September 06, 2011 3:20 AM

Answers

  • Hi,

    You can open the below registry key and do the changes manually in one PC and check which value is changing. It will help you to track the registry value. The key is mentioned below

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007

     

    • Marked as answer by Daniel Cumming Wednesday, September 14, 2011 3:13 PM
    Tuesday, September 06, 2011 1:29 PM
  • I think I found the key. Below is the one that changes the setting.  I am going to try and apply the registry change through group policy.

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0023


    Daniel Cumming
    • Marked as answer by Daniel Cumming Wednesday, September 14, 2011 3:13 PM
    Tuesday, September 06, 2011 3:36 PM

All replies

  • Check out group policy preferences.  It can do just about anything you want it to do.  It might even be enough for you to get rid of your 3rd-party PME software.
    If you found this post helpful, please "Vote as Helpful". If it answered your question, remember to "Mark as Answer".

    Rich Prescott | MCITP, MCTS, MCP

    [Blog] Engineering Efficiency | [Twitter] @Rich_Prescott | [Powershell GUI] Client System Administration toolkit
    Tuesday, September 06, 2011 3:42 AM
  • Hi Daniel.

    You can enable or disable a  service  with group policy.

    More info:

    How To Configure Group Policies to Set Security for System Services
    support.microsoft.com/kb/256345


    If you found this post helpful, please give it a "Helpful" vote. If it answered your question, remember to mark it as an "Answer". This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!
    Tuesday, September 06, 2011 3:50 AM
  • Hi,

    Need a small clarification on the above.

    How did you find that PME is disabled in Windows 7

    How do you want the computers to WOL in morning.

    Is it working on Windows XP

    What is the Domain Controller OS version

    Tuesday, September 06, 2011 5:32 AM
  • I found it was disabled as I went into the network adapter settings, clicked the advanced tab, and the PME setting was disabled.

    The system management software I have uses WOL to start the computers in the morning.  I do this because we now have a lot of workstations running MultiPoint Server 2011 which takes a few minutes to boot.

    I haven't checked in Windows XP.

    The domain controller is running Server 2003.  I installed group policy management on a Windows 7 workstataion so I could edit Windows 7 policies.


    Daniel Cumming
    Tuesday, September 06, 2011 11:54 AM
  • Hi,

    You can open the below registry key and do the changes manually in one PC and check which value is changing. It will help you to track the registry value. The key is mentioned below

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007

     

    • Marked as answer by Daniel Cumming Wednesday, September 14, 2011 3:13 PM
    Tuesday, September 06, 2011 1:29 PM
  • That key does point to an Enable PME value but changing it does not effect the setting on the network adapter.
    Daniel Cumming
    Tuesday, September 06, 2011 3:16 PM
  • I think I found the key. Below is the one that changes the setting.  I am going to try and apply the registry change through group policy.

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0023


    Daniel Cumming
    • Marked as answer by Daniel Cumming Wednesday, September 14, 2011 3:13 PM
    Tuesday, September 06, 2011 3:36 PM
  • Hi,

    Please let me knopw if testing is successful and if you need any other help.

    Wednesday, September 07, 2011 5:49 AM
  • You can't easily apply this setting through group policy because the ID of the network adapter will vary from machine to machine.

    I recently wrote up a web article on this issue, alone with an EnablePME.vbs script. Check it out here:

    http://www.elvtechnology.com.au/2012/02/19/all-about-enablepme-and-wake-on-lan-issues-on-computers-with-intel-nics/

    Hope this helps others!

    Sunday, February 19, 2012 8:15 PM