none
Windows Server Foundation 2008 R2 - Error 1450 on Windows Modules Installer

    Question

  • I am unable to start the service - Windows Modules Installer. I keep getting error 1450: Insufficient system resources exist to complete the requested service.

    Does anybody know how I can fix this please? Thanks.


    --- Sam

    Thursday, January 03, 2013 1:49 PM

Answers

  • Seems like the registry is corrupt. Either restore from a backup or consider a fresh install.

    Also have a look at this (http://support.microsoft.com/kb/124594 - Understanding and configuring Registry Size Limit RSL):

    "By default, RSL is 25 percent of the size of paged pool. Setting up the size of paged pool (see PagedPoolSize value of the Registry key HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management) also affects the size of RSL.

    You can also manually set the RSL:

    Run the Registry Editor (REGEDT32.EXE).

    1. Locate the key HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control.
    2. Modify the value RegistrySizeLimit (create it first it if it does not   already exist) to reflect the desired size, in terms of bytes.

         NOTE: RegistrySizeLimit must have a type of REG_DWORD, and a data length   of 4 bytes, or it is ignored. If you set the value RegistrySizeLimit to   less than 4 megabytes (MB), it is forced up to 4 MB. If you set it to   greater than about 80 percent of the size of paged pool, it is set down   to 80 percent of the size of paged pool (it is assumed that paged pool   is always more than 5 MB). If you set it to 0xffffffff the maximum size   allowable (or 80 percent of paged pool, up to 102 MB) is set.
    3. Shut down and restart Windows NT for changes in RSL to take effect.
    Note A system restart is required after the RSL has been increased either through the graphical user interface (GUI) or the registry, because this change does not happen dynamically."

    ...

    Thursday, January 03, 2013 6:16 PM

All replies

  • Hello Sam, 

    Please see this thread once. 

    May be OS version is different try this once and check for the difference.

    Note:Better take a backup copy of registry before editing it.


    Regards, Ravikumar P

    Thursday, January 03, 2013 2:07 PM
  • Thanks. In the second response in that thread the key RegistrySizeLimit does not exist in my version of Windows. Can I just create the key anyway and reboot?


    --- Sam

    Thursday, January 03, 2013 2:10 PM
  • Something else weird. I have done a registry backup and it is 9.65GB?! On my other Windows 2008 server - same software - it is about 2GB. Is there anyway to compact the registry - why is it so huge?

    --- Sam

    Thursday, January 03, 2013 5:34 PM
  • Seems like the registry is corrupt. Either restore from a backup or consider a fresh install.

    Also have a look at this (http://support.microsoft.com/kb/124594 - Understanding and configuring Registry Size Limit RSL):

    "By default, RSL is 25 percent of the size of paged pool. Setting up the size of paged pool (see PagedPoolSize value of the Registry key HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management) also affects the size of RSL.

    You can also manually set the RSL:

    Run the Registry Editor (REGEDT32.EXE).

    1. Locate the key HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control.
    2. Modify the value RegistrySizeLimit (create it first it if it does not   already exist) to reflect the desired size, in terms of bytes.

         NOTE: RegistrySizeLimit must have a type of REG_DWORD, and a data length   of 4 bytes, or it is ignored. If you set the value RegistrySizeLimit to   less than 4 megabytes (MB), it is forced up to 4 MB. If you set it to   greater than about 80 percent of the size of paged pool, it is set down   to 80 percent of the size of paged pool (it is assumed that paged pool   is always more than 5 MB). If you set it to 0xffffffff the maximum size   allowable (or 80 percent of paged pool, up to 102 MB) is set.
    3. Shut down and restart Windows NT for changes in RSL to take effect.
    Note A system restart is required after the RSL has been increased either through the graphical user interface (GUI) or the registry, because this change does not happen dynamically."

    ...

    Thursday, January 03, 2013 6:16 PM