none
redirected "documents" not showing in 2008r2 "documents" shortcut

    Question

  • I have recently moved from a 2008 SP2 to a 2008R2 TS (RDS)

    Group policy had redirected "My Docs" (or "Documents") to  network location. However the TS start menu "Documents" shortcut does not link to the redirected documents. We also have WinXP machines so the group policy is set to work with older systems, and it works fine with older OS.

    If I manually set a link to the network location the docs are there, there is not a permission issue.

    The registry at HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders gives the correct value for "personal". The event logs have no obvious group policy processing issues.

    For a variety of reasons "caching" is not enabled on the server share, and if I try to manually add the network location to the 2008r2 "libraries" I get not possible due to no local files. Is this the root of the problem?

    BTW this does seem a change in behaviour with 2008R2


    Wednesday, January 09, 2013 11:30 AM

Answers

  • OK it looks like in this case there was an inconsistency with the group policy updating.

    It turns out that the GP had moved the files from "\\NetworkLocation\my documents" to "\\NetworkLocation\documents" although the path as displayed in explorer still read "my documents" - I ended up doing a dir from a command line to get the accurate directory names

    By changing the value of HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders "personal" to exclude the "My " all now works as expected.

    • Marked as answer by rogajones Wednesday, January 09, 2013 1:31 PM
    Wednesday, January 09, 2013 1:31 PM