none
Windows 2008 Server with SP2 Remote Control

    Question

  •  Whenever I try to remote control client I get the following error. Access Denied and then the client is disconnected. 

    The following is logged in the event log.

    The RDP protocol component "DATA ENCRYPTION" detected an error in the protocol stream and has disconnected the client

    Friday, May 27, 2011 12:10 PM

Answers

All replies

  • Hi,

     

    Make sure you have installed the latest updates in your Windows server 2008 SP2 Terminal server.

     

    Whether you are using Windows 7 for you Terminal client and you have installed the SP1 in your Windows 7. If so ,you can refer to the following post, there is a bug we are aware of.

    can't remote control rdp session from windows 7

    http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/725d11a4-7bd9-46d4-97a5-01b6a5668c74/

     


    Technology changes life……
    Tuesday, May 31, 2011 3:10 PM

  • I am having the same problem and it has been driving me crazy for over a month now.

    30% of the clients connecting to our server (server running Windows Server 2008 R2) get disconnected after only few minutes with the same event ID in the server's event viewer (Event ID: 50
    The RDP protocol component "DATA ENCRYPTION" detected an error in the protocol stream and has disconnected the client).

    A common point between these 'failing' clients is that they are running Windows 7 SP1.

    I have stumbled upon KB 2523307, which I believe is the solution of the problem, but only provides hotfixes for Vista?? What about Windows Server 2008 R2? Is there a fix I can apply on the Terminal Server (on the Windows server 2008 R2) as opposed to the client side (Windows 7 Sp1) which I don't really have control over.

    Any help would be appreciated,

    Thank you,


    Monday, March 12, 2012 4:08 PM
  • I was never able to correct the problem I had. I eventually replaced the server with R2 and have not had an issue yet.
    Granted, my clients are not all up to Win7 SP1 yet.
    Monday, March 12, 2012 4:12 PM
  • Thanks for your reply Ronald,

    What do you mean by "replaced the server with R2". My TSE server is currently running on Windows Server 2008 R2 Standard - Service Pack1.

    And, each and every time a client connect to it (RDP) from a Windows 7 SP1 box, I get the 'famous' error after couple of minutes. Is there a way, to fix this problem from a server point of view? A fix for my Windows Server 2008 R2? Or ,more drastically, move into another OS for the server (but then, which one?)

    BTW: During some 'internal' unit testing, I tried downloading the fix (http://support.microsoft.com/kb/2523307/en-Us)  to apply it to the Windows 7 SP1 client, only to find that available fixes are only valid for Vista ??? Please tell me I am dreaming...and the link for 7 is somewhere there I did not see.




    • Edited by Elextra Tuesday, March 13, 2012 3:26 PM
    Tuesday, March 13, 2012 3:20 PM
  • Orginally I was on Windows 2008 server and had the error you were getting. Once I replaced my server and moved to W2k8 R2, I was able to remote control my Windows 7 SP1 clients without a problem.

    These two items have been given as solutions.

    1.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters
    After exporting this for safekeeping, I deleted the Certificate keys. I restarted the target PC and was able to successfully connect.

    2.

    Try deleting the string value for the machine you are trying to connect to under:

    HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default

    Wednesday, March 14, 2012 1:58 PM
  • Hi,

    Thanks for the reply. As I mentioned in my posting, I am running Windows 2008 R2 SP1.

    I came across that registry trick in several post (here for instance: http://support.microsoft.com/kb/323497) , but I don't have those entries. They are simply not there.

    I think my problem is slightly different then the one you had as the clients manage to connect, but they actually get disconnected after 2-3 minutes ( sometimes more). I will keep looking and will definitely post back anything I find in here.

    Thanks again for your help.

    Any other suggestion is welcome

    Wednesday, March 14, 2012 2:36 PM