none
Folder Redirection and DFS issues

    Question

  • I have a Windows Server 2008 network, one domain and three sites.

    I activated GPO to redirect Desktop and Documents folders over a DFS share (i.e. \\mydomain.local\users) and I correctly applied right share and ntfs pemissions to that folder
    I don't use roaming profiles.
    My problem is that users connected to the network can correctly read and write to that folders, but as soon as they disconnect the network cable the desktop disappear and they cannot anymore create or view files over it. The same behaviour on documents folder.
    Other DFS shares mapped as network drives, instead, don't seems to be affected by this symptom. User can view and operate on offline files correctly cached.

    I verified on the "cache" proprety on the network share (\\mydomain.local\users) and it's correctly selected the option to allow all files and programs in cached mode.

    I found this article on kb http://support.microsoft.com/kb/893231/en-us but I cannot apply patches 'cause I've already the latest sp.

    This symptom is on my Windows XP clients (sp2 and sp3), on Windows Vista I have many other issues about conflicts between files modified offline and online (even if the file is modified ONLY offline).

    With Windows Server 2003 I never had this kind of problems...

    Any help will be appreciated!

    Thanks in advance,
    Riccardo Saracchi
    Wednesday, June 10, 2009 7:47 PM

Answers

  • Hello Riccardo,

     

    Thank you for posting here.

     

    You mentioned that you checked the "cache" proprety on the network share (\\mydomain.local\users)

     

    Please logon to the client and check whether the redirected folder is configured to be available offline on clients.

     

    1. Logon client, open My computer, click Tools -> synchronize


    2. Please make sure there are no item listed in "items to synchronize" list.

     

    If not, these folders will be unavailable while offline. By default, redirected folder will be available offline automatically.

     

    However, if the following group policy is enabled, the client users must manually select the files they wish to be made available offline.

     

    To troubleshoot the issue, please configure the following GPO setting as "Not Configured" or disable it.

     

    User Configuration\Administrative Templates\Network\Offline Files\Do not automatically make redirected folders available offline

     

    Meanwhile, I suggest that you download the hotfix there and apply it onto the problematic computer to see if it helps.

     

    Error message after you try to access a mapped network drive when you work offline on a Windows XP-based computer: "Drive_Letter:\ is not accessible"

    http://support.microsoft.com/kb/937357

     

    Hope this can be helpful.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by David Shen Friday, June 26, 2009 3:34 AM
    Thursday, June 11, 2009 11:46 AM
  • Hi Riccardo,

     

    Thank you for sending us the gp.txt log file.

     

    I am not sure what other error messages exactly mean, because I am not familiar with Italian language.

     

    For test purpose, you may consider disabling all the GPO, which configured with Offline file, and check if the issue still exist.

     

    As this forum is mainly provided for English version of product, to troubleshoot this problem efficiently, I'd like suggest that you post this problem to localized forum or contact Microsoft Customer Service and Support (CSS) for this. You can speak directly with a Microsoft Support Professional to analyze the problem.

     

    For a complete list of Microsoft Product Support Services phone numbers, please go to the following address on the World Wide Web, to find the local number:

     

    http://support.microsoft.com/directory/overview.asp

     

    Hope the issue will be resolved soon.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by David Shen Friday, June 26, 2009 3:34 AM
    Monday, June 22, 2009 7:53 AM

All replies

  • Hello Riccardo,

     

    Thank you for posting here.

     

    You mentioned that you checked the "cache" proprety on the network share (\\mydomain.local\users)

     

    Please logon to the client and check whether the redirected folder is configured to be available offline on clients.

     

    1. Logon client, open My computer, click Tools -> synchronize


    2. Please make sure there are no item listed in "items to synchronize" list.

     

    If not, these folders will be unavailable while offline. By default, redirected folder will be available offline automatically.

     

    However, if the following group policy is enabled, the client users must manually select the files they wish to be made available offline.

     

    To troubleshoot the issue, please configure the following GPO setting as "Not Configured" or disable it.

     

    User Configuration\Administrative Templates\Network\Offline Files\Do not automatically make redirected folders available offline

     

    Meanwhile, I suggest that you download the hotfix there and apply it onto the problematic computer to see if it helps.

     

    Error message after you try to access a mapped network drive when you work offline on a Windows XP-based computer: "Drive_Letter:\ is not accessible"

    http://support.microsoft.com/kb/937357

     

    Hope this can be helpful.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by David Shen Friday, June 26, 2009 3:34 AM
    Thursday, June 11, 2009 11:46 AM
  • Hi Riccardo,

    I want to see if the information provided was helpful. Please keep us posted on your progress and let us know if you have any additional questions or concerns.


    We are looking forward to your response. 


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, June 15, 2009 2:55 AM
  • Hi David,

    I use GPMC from WS2008 and The “Do not automatically make redirected folders available offline policy” doesn't show up in Server 2008.

    I cannot apply the hotfix you suggested me 'cause I have a more recent sp installed on my clients.

    If I run gpresult /v every lines about offline files configuration is:

    Software\Policies\Microsoft\Windows\NetCache
    enabled

    this shows up at least 10 times

    Other ideas?

    Thanks,
    Riccardo Saracchi
    Monday, June 15, 2009 9:46 AM
  • Hi Riccardo,

     

    Thank you for the reply.

     


    For test purpose, please log on to a problematic client and perform the following steps:

    1. Click Start -> Run, type \\mydomain.local\Users in the text box, and click OK.

    2. Right click the share folder of a particular user.

    Is the "Make available offline" option enabled? If not, please check this option and synchronize offline file to test this problem again. If this option is grayed out, it indicates that some group policies have enabled or disabled this option.

    As you mentioned that the "gpresult /v" shows that offline files cache is enabled, you can re-run the "gpresult /v" to check which GPO has been configured with enabled this setting, If there is a Windows Server 2003 based-DC in the system environment, you may configure to disable the group policy settings on that DC.

     

    If you cannot configure this setting through GPO, you may try modifying the following registry key on the client, which act the same result of disable that policy setting.

     

    1. Open Regedit

     

    2. Find and locate to

     

    HKCU\Software\Policies\Microsoft\Windows\NetCache\DisableFRAdminPin

     

    3. Edit the value of DisableFRAdminPin to 0

    Afterwards, please check if the issue can be fixed on the domain clients. If the issue still continues, please collect the group policy result by running "gpresult /v > D:\gp.txt", and then send to tfwst@microsoft.com

     

    Thanks for the co-operation, and hope the issue will be resolved soon.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Edited by David Shen Tuesday, June 16, 2009 10:44 AM
    Tuesday, June 16, 2009 7:03 AM
  • Hi Riccardo,

    We wanted to see if the information provided was helpful. Please keep us posted on your progress and let us know if you have any additional questions or concerns.

    We are looking forward to your response. 


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, June 19, 2009 6:16 AM
  • Hi David,
    many strange things...


    I haven't the key HKCU\Software\Policies\Microsoft\Windows\NetCache\DisableFRAdminPin
    and I cannot create it.

    I enabled the option to make my \\mydomain.local\users\user-a available offline but, for instance, if I syncronyze the folder and after disconnect the network cable and press F5 all my desktop disappear and I cannot create anything over it.

    the error message is something like "unable to read configuration informations frm domain controller"

    I send you my gp.txt

    Thanks,
    Riccardo Saracchi
    Friday, June 19, 2009 6:08 PM
  • Hi Riccardo,

     

    Thank you for sending us the gp.txt log file.

     

    I am not sure what other error messages exactly mean, because I am not familiar with Italian language.

     

    For test purpose, you may consider disabling all the GPO, which configured with Offline file, and check if the issue still exist.

     

    As this forum is mainly provided for English version of product, to troubleshoot this problem efficiently, I'd like suggest that you post this problem to localized forum or contact Microsoft Customer Service and Support (CSS) for this. You can speak directly with a Microsoft Support Professional to analyze the problem.

     

    For a complete list of Microsoft Product Support Services phone numbers, please go to the following address on the World Wide Web, to find the local number:

     

    http://support.microsoft.com/directory/overview.asp

     

    Hope the issue will be resolved soon.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by David Shen Friday, June 26, 2009 3:34 AM
    Monday, June 22, 2009 7:53 AM