none
The directory service was unable to allocate a relative identifier

    Question

  • Hi All,

    We are getting the following error message on our Small Business Server 2003 running Active Directory

    "Windows cannot create the new object because:
    the directory service was unable to allocate a relative identifier"

    This happens when I try to create a new username for the domain.

    I am able to delete or disable users but am unable to create new ones.

    I have already used netdom query fsmo. The results of this command are that the server for all items is the server I am trying to add the user on.

    The same thing happens when I try to create a user without an exchange mailbox.

    We are running exchange server 2003 on the same server.

    Please advise.

    Regards,

    Callum Stanford
    Thursday, November 05, 2009 6:20 AM

Answers

All replies

  • Hi Callum,

    Please try the below KB's steps to see whether it fixs this issue.

    http://support.microsoft.com/kb/822053

    Also
    http://support.microsoft.com/kb/839879

    Best Regards,
    Wilson Jia
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by Wilson Jia Thursday, November 05, 2009 8:43 AM
    • Marked as answer by Wilson Jia Monday, November 09, 2009 2:04 AM
    Thursday, November 05, 2009 6:47 AM
  • Hello,

    if the articles posted from Wilson didn't help please give some more info about your environment, total amount of DCs in the domain and how they are located. Also describe if you have done a restore from backup or image after a crash?
    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties, and confers no rights.
    Saturday, November 07, 2009 8:39 PM
  • We had this issue today.

    It had to do with AD Sites and Services with the P2V conversion of SBS 2008. The DC was put into a new subnet and AD S&S was not updated for the site. Once we did that everything resumed as usual.

    Friday, July 26, 2013 9:33 AM
  • may i know how u solve the problem in detail?

    cause i face the same problem also.

    Thanks,

    JWWH

    Thursday, August 01, 2013 6:31 AM
  • may i know how u solve the problem in detail?

    cause i face the same problem also.

    Thanks,

    JWWH

    Hello,this thread is from 2009.

    please create your own and descirbe your problem in details with OS versions and SP/patch level, complete error messages and what happened before(restore because of crash etc. and how the restore was done exact).


    Best regards

    Meinolf Weber
    MVP, MCP, MCTS
    Microsoft MVP - Directory Services
    My Blog: http://msmvps.com/blogs/mweber/

    Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.

    Thursday, August 01, 2013 8:12 AM
  • we're having the similar issues now, how AD sites and Services affect P2V DC? can you explain more detail? thanks.
    Sunday, October 13, 2013 9:20 PM