none
Windows Clock Runs slow Loses 30 seconds every minute

    Question

  • This is unbelievable.

    We have 4 Vmware VM's running on a HOST machine in a branch office.

    The VM's are Windows 2003 R2 SP2 X64.

    Host machine is keeping time fine, so no physical fault with clock.

    All guests on that host are running slow, you can literally watch the clock second hand and compare it to your watch and see that it loses 30 seconds every minute, like each second takes 2 seconds.

    The same setup exist in 3 other Branch offices and no such problem exists.

    All Branch offices are set up to sync to the domain.

    Even if I stop the w32time service and stop sync the clock just goes slow.

    You can run the w32tm /stripchart command and see the difference change by 2 seconds every iteration.

    This command on other servers in other branch offices shows stable differences in times in the order of a few 10ths of a second.

    Heres an example from the faulty clock/machine comparing it the the PDC FSMO role domain controller

    C:\Documents and Settings\Admin>w32tm /stripchart /computer:172.20.40.7 /dataonly
    Tracking 172.20.40.7 [172.20.40.7].
    The current time is 12/12/2012 1:42:04 PM (local time).
    13:42:04, +936.9287371s
    13:42:06, +938.9054562s
    13:42:08, +941.1868718s
    13:42:10, +943.3510963s
    13:42:13, +945.7184554s
    13:42:15, +947.9061210s
    13:42:17, +950.2656688s
    13:42:19, +952.6799071s
    13:42:21, +954.9535156s
    13:42:23, +957.3990063s
    13:42:26, +959.6648029s
    13:42:28, +962.1493591s
    13:42:30, +964.1573312s
    13:42:32, +966.3996831s
    13:42:34, +968.7748547s
    13:42:36, +971.2828484s
    13:42:39, +973.6814665s
    13:42:41, +976.2363412s
    13:42:43, +978.2990038s
    13:42:45, +980.5101045s
    13:42:47, +982.6587034s
    13:42:49, +984.8854303s
    13:42:51, +986.9715262s
    13:42:53, +989.2216906s
    13:42:55, +991.3624758s
    13:42:57, +993.6517051s
    ^C
    C:\Documents and Settings\Admin>

    Any help appreciated.

    Wednesday, December 12, 2012 6:03 AM

Answers

  • Hi, Thanks for your responses.

    I dont know what corrected the problem but all the servers are now keeping correct time.

    I tried various different combinations of time synchronisation , disabled it, used NTP used NT5DS etc without change.

    I set the time service back to its original settings and shut down all VM's on the Physical server.

    I rebooted the Physical server several times, then started up each VM one at a time.

    As far as I can make out I have really changed nothing , all settings back to original. The  /usepmtimer switch is not in the boot.ini file.

    The physical server is a Dell T605 with Intel processors.

    Its working now but I wish I kew why.

    Thanks again.

    • Marked as answer by c_mario Wednesday, December 12, 2012 10:52 PM
    Wednesday, December 12, 2012 10:51 PM

All replies

  • I suggest you run below command to set server time same as PDC time /Time Source.

    C:\>net time ----> it will show the time of PDC

    Current time at \\DC1.abc.com is 12/12/2012 1:05:02 PM
    The command completed successfully.

    C:\>net time /DOMAIN:abc.com /set ----->To set server time same PDC/Time Source
    Current time at \\DC1.abc.com is 12/12/2012 1:07:21 PM
    The current local clock is 12/12/2012 1:07:21 PM
    Do you want to set the local computer's time to match the
    time at \\DC1.abc.com? (Y/N) [Y]: Y --->(press Y) to set server time same as PDC
    The command completed successfully.

    Note: Sometimes around 200 ms of time delay can be acceptable for authentication in a client.


    Regards, Ravikumar P

    Wednesday, December 12, 2012 7:47 AM
  • HI,

    I have done what you suggested many times and I completes successfully and it will set the server time the same as the PDC, but immediatly after that I run the same command as before C:\Documents and Settings\Admin>w32tm /stripchart /computer:172.20.40.7 /dataonly

    And the difference simply starts from 2 seconds and increases on every iteration.

    Thanks.

    Wednesday, December 12, 2012 8:41 AM
  • this sounds like a known issue.

    add the usepmtimer switch in the boot.ini

    http://support.microsoft.com/kb/938448


    http://support.microsoft.com/kb/895980
    Wednesday, December 12, 2012 7:02 PM
  • Hi, Thanks for your responses.

    I dont know what corrected the problem but all the servers are now keeping correct time.

    I tried various different combinations of time synchronisation , disabled it, used NTP used NT5DS etc without change.

    I set the time service back to its original settings and shut down all VM's on the Physical server.

    I rebooted the Physical server several times, then started up each VM one at a time.

    As far as I can make out I have really changed nothing , all settings back to original. The  /usepmtimer switch is not in the boot.ini file.

    The physical server is a Dell T605 with Intel processors.

    Its working now but I wish I kew why.

    Thanks again.

    • Marked as answer by c_mario Wednesday, December 12, 2012 10:52 PM
    Wednesday, December 12, 2012 10:51 PM