none
This computer can't connect to the remote computer

    Question

  • Recently, I switched from AT&T to TWC Road Runner for my ISP. When I had AT&T my remote desktop worked fine and I was able to remote into work. since I got Road Runner, I can VPN into the network,but when I get to Remote Desktop it gives me "This computer can't connect to the remote computer. Try connecting again If this promblem continues please contact....... The IP Addresss that the router is "getting assigned" is the same as a computer on my network. This that the problem? Since I have tried disconnecting the router, release and renewing....I don't know what else to do. Can any one offer any experience on this matter. Thank You

    Sunday, April 27, 2008 2:48 AM

Answers

  • This is what I found on another website:

     

     

    If you are using the new Remote Desktop Connection 6.0 Client, the error you get is:


     

    Remote Desktop Disconnected
    ----------------------------------------------
    This computer can't connect to the remote computer.

    Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator.

     

     

    You checked that Remote Desktop is enabled and you have rights to connect, but it fails every time. What the #$% is going on???

    Well, you may have a binding problem with the RDP-Tcp connector. This typically happens with servers with two or more NICs (as is usual with an ISA server). To fix the problem follow these steps:

    1. Logon to the server locally
    2. Click Start, Run, type "tscc.msc /s" (without quotation marks) and click OK
    3. In the Terminal Services Configuration snap-in double-click Connections, then RDP-Tcp in the right pane
    4. Click the Network Adapter tab, select the correct network adapter and click OK
    5. Make sure that you can establish an RDP connection to the server
    The change takes effect immediately. No need for a restart.
    Tuesday, April 29, 2008 7:24 AM

All replies

  • This is what I found on another website:

     

     

    If you are using the new Remote Desktop Connection 6.0 Client, the error you get is:


     

    Remote Desktop Disconnected
    ----------------------------------------------
    This computer can't connect to the remote computer.

    Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator.

     

     

    You checked that Remote Desktop is enabled and you have rights to connect, but it fails every time. What the #$% is going on???

    Well, you may have a binding problem with the RDP-Tcp connector. This typically happens with servers with two or more NICs (as is usual with an ISA server). To fix the problem follow these steps:

    1. Logon to the server locally
    2. Click Start, Run, type "tscc.msc /s" (without quotation marks) and click OK
    3. In the Terminal Services Configuration snap-in double-click Connections, then RDP-Tcp in the right pane
    4. Click the Network Adapter tab, select the correct network adapter and click OK
    5. Make sure that you can establish an RDP connection to the server
    The change takes effect immediately. No need for a restart.
    Tuesday, April 29, 2008 7:24 AM

  • Hi Yuri,

    I have the same problem and have also installed XP SP3 which should have solved the problem but it didn't.
    Have tried your solution also with no success.

    Sten Einar
    Wednesday, May 21, 2008 1:15 PM
  • That's why I love the internet.

    Thanks a mil for the solution. We still don't know why it happened as it has been working for over 3 years and suddently it stopped and it was exactly the problem you stated and the solution you provided. We had 2 network cards (internal + external) and somehow the internal card was selected when in fact it was disabled.

    Thanks again.

    T.
    Friday, January 16, 2009 11:04 AM
  • Thank you Yuri!

    Same thing, litterally stopped working after a remote reboot. Was working fine just before that for over two years.

    I'm not sure what the setting was before it stopped working, but when I checked it on the local terminal it was set to "All network adapters configured with this protocal."

    Changed it to my NIC and it worked.

    Monday, August 24, 2009 4:34 PM
  • I have the same issue but my server is a VM server. I too did a remote reboot and now I have to same error. I have tried the changes in tscc.msc but I still get the same error. I am lucky I can still use the VM console.

    Anyone know of another resolution?

    Just found this in the event log:

    The name ""Domain Name"             :1d" could not be registered on the Interface with IP address "Server in Question". The machine with the IP address "DHCP Server" did not allow the name to be claimed by this machine.
    Monday, September 07, 2009 4:18 PM
  • thanks for the solution
    Tuesday, September 08, 2009 10:05 AM
  • Thanks....it wasn't exactly what I needed, but it lead to discover that there was NO connections on the server in question.  Right-click Connections, Create New -> Added the connection, reconfigured it to match another server.

    Problem Solved!

    • Proposed as answer by Amit Khatri Tuesday, April 12, 2011 2:59 PM
    Tuesday, September 22, 2009 4:23 PM
  • Yuri,

    Your solution looks promising. The server I'm trying to connect to does have 2 network adapters. The network adapter is currently set to "All network adapters configured with this protocol". There are 2 listed in the drop-down: "HP NC324i PCIe Dual Port Gigabit Server Adapter" and "HP NC324i PCIe Dual Port Gigabit Server Adapter #2".

    The first one is listed as "iSCSI" (Control Panel --> Network Connections) and #2 is called "Public".

    In step 4, you say to select the correct network adapter. How can I tell which is the correct network adapter?

    Thanks,
    Jon

    ***UPDATE***
    I selected the "Public" adapter and it didn't make any difference.
    • Edited by BrazilNut2000 Wednesday, December 30, 2009 8:10 PM more info
    Wednesday, December 30, 2009 7:55 PM
  • Hi there,
    Same thing happen with me, I tried Yuri's Method with excitement , unfortunatelt it did not work for me. Guess  what happened after I update the windows 2003 with windows update?.  TSUserenabled Registry Entry Changed from 1 to 0. so for any one the above mentioned solution did not worked, give this a try.

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server find that entry and change it from 0 to 1

    BTW: I love the Internet too :)

    Wednesday, February 10, 2010 9:07 PM
  • Actually, it is typically "TSenabled" that should be set to 1. Not sure about the "TSUserenabled" setting - on all of mine, I see that set to zero, and I don't have any issues.

    What I did notice is that mine also is a VM and, after this recent "patch Sunday" (production patches following Patch Tuesday), upon reboot, the Terminal Services service failed to start (Event 7000) due to a timeout issue. Looks like VM guest timing on the reboot, trying to start the service - may have been VM load and/or multiple guests restarting near the same time - haven't delved into it that far.

    But, sure enough - I checked and the Terminal Services service was stopped, I started it and voila! Now, the next test will be, upon the next reboot, to see if the TS service starts like it's supposed to. This also could be a flaky patch/interference issue - some of Microsoft's patches appear to cause or bring out some "service startup timing" issues. Additionally, as most of us probably have seen, some automatic reboots after MS patches are loaded, well, they don't seem to "fully and cleanly" reboot. Some of this may be from patch interdependencies, where one patch is best applied by itself, then a reboot, then some other specific patch. This makes sense, since quite a number of patches are modifying not just surface apps, but portions of the o/s kernel as well. It's almost funny that, if you apply 12 or more patches, you're almost guaranteed to have at least one issue among 2% to 3% of your systems (that was a RANDOM guess; those figures of 12 or more and 2% to 3% are just the general feel from having done this for 20+ years).

    Tuesday, April 20, 2010 1:14 PM
  • Hi,

     

    My Problem is,

    1. The RDP for the server is accessible from other pcs in the network. Only when I try to connect from my laptop, I get the error.

    2. when I disable symantec Endpoint protection, I have no issues in connecting to the RDP.

    3. The version of Symantec endpoint protection is :- 11.0.5002.333

    Need your Help ASAP.

     

    Sunday, July 18, 2010 9:55 AM
  • I just experienced the same problem and the reason - I had an entry in my hosts file for the remote server apparently with a wrong IP address. Either delete the entry or make sure it is correct.
    philip
    Thursday, January 13, 2011 9:32 PM
  • I restarted my server/remote pc and all started to work fine again... Looks like updates were pushed to my PC at work and when it restarts on its own it's not doing it correctly.

    Friday, July 01, 2011 1:47 PM
  • Hi there,
    Same thing happen with me, I tried Yuri's Method with excitement , unfortunatelt it did not work for me. Guess  what happened after I update the windows 2003 with windows update?.  TSUserenabled Registry Entry Changed from 1 to 0. so for any one the above mentioned solution did not worked, give this a try.

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server find that entry and change it from 0 to 1

    BTW: I love the Internet too :)


    thanks for this ; this key did not solve my issue (on a Windows XP client), and as said above mine is set to 0 and it's ok with that.

    But the key to change was in the same place : fDenyTSConnections was set on 1, I set it to 0 and now it's good

    • Proposed as answer by Nishadp1 Monday, June 11, 2012 9:07 PM
    Friday, September 23, 2011 3:58 PM
  • Recently, I switched from AT&T to TWC Road Runner for my ISP. When I had AT&T my remote desktop worked fine and I was able to remote into work. since I got Road Runner, I can VPN into the network,but when I get to Remote Desktop it gives me "This computer can't connect to the remote computer. Try connecting again If this promblem continues please contact....... The IP Addresss that the router is "getting assigned" is the same as a computer on my network. This that the problem? Since I have tried disconnecting the router, release and renewing....I don't know what else to do. Can any one offer any experience on this matter. Thank You

    Start TS Service in Win 2003 Server. Then remote desktop will work.
    Wednesday, February 15, 2012 1:27 PM
  • Hi all!

    See i got experienced the same issue...Only solution for the above mentioned issue is just reboot the host machine once,after proper shutdown...Now the catch/Buffer related things got reseted automatically..Now u try to connect.U Can able to take Remote..Try this and plz do reply me..

    Thanks & Regards

    SHALEEM.S.A

    Friday, May 04, 2012 10:30 AM
  • Hi all!

    See i got experienced the same issue...Only solution for the above mentioned issue is just reboot the host machine once,after proper shutdown...Now the catch/Buffer related things got reseted automatically..Now u try to connect.U Can able to take Remote..Try this and plz do reply me..

    Thanks & Regards

    SHALEEM.S.A

    Friday, May 04, 2012 10:32 AM
  • Hi,

    Hence I got it right through your suggestion that too remotely modifying registry. after setting fDenyTSConnections from 1 to 0 in HKLM\System\CurrentControlSet\Control\Terminal Server I could access remote system by RDC in domain environment.

    Thanks.

    Monday, June 11, 2012 9:17 PM
  • hello sirs.. i have the same problem with remote connection. i did all the suggestions here but still i have no luck in RDP it still says cannot connect to the remote computer. btw our server is windows server 2008 r2. please help.
    Tuesday, July 24, 2012 9:16 AM
  • Hi Kashif

     The solution you provided worked a treat am using VM Exsi with Application Servers installed as host.  The HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server find that entry and change it from 0 to 1 adjustment really works thanks a million.

    You are a G.......

    Wednesday, January 02, 2013 2:24 PM