none
RDP-Tcp Properties: Color Depth under Client Settings grayed out

    Question

  • Hi there,

    I have a server here where the Color Depth on the RDP-Tcp properties has been grayed out and it has set to 8 bits.

    Have tried the following:

    1. Have change the registry keys 

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\ColorDepth = 4

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\fInheritColorDepth = 1

    2. group policy changes to Administrative Templates -> Windows Component -> Terminal Services -> Terminal Server -> Remote Session Environment -> Limit maximum color depth -> Enabled -> 32 bit.

     

    This box is actually a Windows 2008 Server Standard Edition 32bit running on VMWare. (Service Pack 1). Any help at all would be appreciated as I really need to get the limit to go higher.

    Wednesday, July 07, 2010 8:53 AM

Answers

  • Hello,

    When the options to change these settings are greyed out this useally means they are set by GPO. Please check you AD and Local GPO's for these settings so you are able to adjust to the correct settings.

    I don't think that running this machine on VMWare is the problem although the graphic settings will be less....

    Robert

    • Marked as answer by Invensys Rail Tuesday, August 10, 2010 11:24 PM
    Wednesday, July 07, 2010 5:17 PM
  • Hi,

    Did you run rsop.msc on the problem server?  What results do you see? Resultant Set of Policy will show which policies are in effect and the source GPO.

    If you open the local group policy editor on the server (gpedit.msc), are you able to change the option or is it disabled?  If it is disabled then that is another sign that it is being set by a gpo on the domain.

    You should not have to edit the colordepth setting in the registry, but just so you know 32-bit would equal a value of 5.  Also fInheritColorDepth would be set to 0 indicating that you do not want to Inherit the setting, in other words use the value specified by ColorDepth.  A GPO will override the registry setting.

    Thanks.

    -TP

    • Edited by TP []MVP, Moderator Monday, July 12, 2010 4:58 AM Add fInheritColorDepth text
    • Marked as answer by Wilson Jia Monday, July 26, 2010 9:25 AM
    Monday, July 12, 2010 4:47 AM

All replies

  • Hello,

    When the options to change these settings are greyed out this useally means they are set by GPO. Please check you AD and Local GPO's for these settings so you are able to adjust to the correct settings.

    I don't think that running this machine on VMWare is the problem although the graphic settings will be less....

    Robert

    • Marked as answer by Invensys Rail Tuesday, August 10, 2010 11:24 PM
    Wednesday, July 07, 2010 5:17 PM
  • Hi Robert,

    Yeah I've checked with the group policy and it was not enabled or configured. Just to make sure it is not the group policy, I have actually enabled it and enforce it to accept 32 bit. Reboot and the setting is still grayed out.

     

    Any other options I can try with? Thanks in advance.

    Monday, July 12, 2010 4:36 AM
  • Hi,

    Did you run rsop.msc on the problem server?  What results do you see? Resultant Set of Policy will show which policies are in effect and the source GPO.

    If you open the local group policy editor on the server (gpedit.msc), are you able to change the option or is it disabled?  If it is disabled then that is another sign that it is being set by a gpo on the domain.

    You should not have to edit the colordepth setting in the registry, but just so you know 32-bit would equal a value of 5.  Also fInheritColorDepth would be set to 0 indicating that you do not want to Inherit the setting, in other words use the value specified by ColorDepth.  A GPO will override the registry setting.

    Thanks.

    -TP

    • Edited by TP []MVP, Moderator Monday, July 12, 2010 4:58 AM Add fInheritColorDepth text
    • Marked as answer by Wilson Jia Monday, July 26, 2010 9:25 AM
    Monday, July 12, 2010 4:47 AM
  • Hi TP,

    I have ran rsop.msc on the problem server and the result has "Limit maximum color dept Properties" set to Enabled with 8-bit.

    When I open the local group policy editor (gpedit.msc), I am able to edit it. I have tried in the past enabling it to 32-bit but that does not seem to help. I am trying it now again.

    Robert mentioned checking the AD, do you know where in AD should I investigate?

     

    Thanks.

    Tuesday, August 10, 2010 11:11 PM
  • Thanks Robert, TP,

    Found the settings. It is in the AD that has set it to 8-bit. It looks like AD takes precedence over Local GPO. Next question will be is there any way of swapping the precedence around.

    Great help, appreciate it heaps. Thanks guys.

    Tuesday, August 10, 2010 11:26 PM
  • Hi,

    Please edit the domain GPO and change the setting to Not Configured.  If you want you can change the local policy to Not Configured as well, and then set the color depth using Terminal Services Configuration (tsconfig.msc).

    Thanks.

    -TP

    Tuesday, August 10, 2010 11:51 PM
  • I have almost same kind of problem but little different Scenario with my Windows 7 Client (Virtual Machine) connected to Microsoft Windows Server 2008 R2.

    1- I have scenario that all the Window 7 client Virtual Machines allocated on Xen server and joined with Window server AD,
    2- I have RDP based HP Zero client devices, When i get connected using RDP and get login using AD account. Everything is working fine
    even the Screen Resolution etc but It was 16bit Color Depth which cause jerking in explorer and MS office even SVGA is installed on VM. I tried the VMware Virtual Machine client (Window 7) then it has the same problem on RDP session on client end. I face problem that it is not getting connect even if i login on virtual machine machine locally, it is running on 32bit with good resolution but on RDP session it is showing Default RDDP and 16bit with the Zero client Device resolution. It is fine with Resolution but the movies, Solatire game, Internet explorer. all the contents are jerking badly.

    I find out the solution over google that I should create an OU for the users and VM's and implement a Group Policy for them. In which i configured,

    Computer Configuration/Administrative Templates/Remote Desktop/Remote Desktop Environment/ Color Depth and also other settings for Users for RDP session.

    I properly apply the GPO by using gpupdate /Force. It successfully applied but when i get login using this user on RDP Session, there is no any impact of this policy. I did the same using local policy but the result is same.

    Then for test purpose, I apply User Configuration/Administrative Templates/ (Some of the policy for test). When i get login on RDP session then these policies were perfectly working.

    All the things are fine with User Configuration of GPO but Computer Configuration is not applying.

    Kindly help me in this problem please and let me know where i am doing mistake.

    My email is Arsalanh2000@hotmail.com


    Wednesday, March 21, 2012 3:53 PM