none
Home folder and folder redirection

    General discussion

  • Hi,
    I'm doing some tests with Active Directory and folder redirection (my goal is to migrate my peer-to-peer network into a domain network).

    My test environment consists of two Domain controllers with Windows Server 2008 , a File Server with Windows Server 2003 (not R2) and a workstation with windows 7.

    The file server should be operating as soon as possible (before the domain network is completed) so that users could save their files and backups are done regularly.

    Because of this i do my test with home folders and folder redirection.

    On the domain controller i setup the home folder path for the test user in this way :

    - open User properties > Profile tab >Home folder section
    - insert the \\servername\FileServer\Home\%username% path in the Connection option

    This works fine. the test user can connect to his home folder and create subfolders and/or files within it.


    Problems arise when i try to set the redirection for the "Documents" folder.

    Because i have already created the home folder, i configure the GPO in order to redirect documents into the user home folder.

    The whole old %username% home folder is now the "Documents" folders and folders previously created into the original home folder (before the GPO was applied) are now subfolders of the Documents one.

    I tried to remove the folder redirection by setting the folder redirection to "Not configured" and forcing the policy by "gpupdate /force" but still the "Documents" folder
    for the test user points to the folder on the server.

    My questions are:
    1) which is the right way to remove folder redirection having the "Documents" folder point again to the local folder (C:\Users\%username%\Documents)
    2) I wish to redirect Documents folder on the server but as a subfolder of the &username% home folder, is it possible with GPO ? If yes, How?

    I apologize for my english and I hope i was clear.

    Thanks.

    Tuesday, July 10, 2012 2:17 PM

All replies

  • Hi,

    Before moving on, I would like to confirm if the Home Folder is actually renamed as Documents, or as you descripted, it changed to Documents folder (which means the files users created in Documents exist as files in the folder)?

    I asked this because there is a known issue which meets your current situation:

    When you redirect the Documents folder on a Windows Vista-based computer to a network share, the folder name unexpectedly changes back to Documents
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;947222


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Thursday, July 12, 2012 11:15 AM
  • Hi,

    No, the Home Folder is not renamed, what i meant is that the procedure does not create a Documents subfolder inside the Home, but the Home itself became the redirected Documents folder.

    I made some other test with redirection option and i found the solution to implemenmt redirection as i wish.

    Unfortunately the site is in italian so i don't post the link, but anyway it seems that part of the problem was that the user was not the owner of the folder on the server. He had the full control permission but that was not enough.

    This is what i've done:

    1) create a shared folder on the server (HomeDir) setting the share permission to Domain admins and Domain users with Full Control. Then i set special  NTFS permission for the Domain Users applied only to this Folder and Files.

    2) On the Domain Server i set the HomeFolder path for the user to \\ServerName\HomeDir\%username% (which create the user subfolder within the HomeDir)

    3) Back on the File Server i set the user as Owner of the just created folder (the full control permission is set automatically)

    4) Create the Redirection policy for the Documents folder with this options: Settings : Basic; Target folder localtion : Create a folder for each user under the root path; Root path : \\ServerName\Homedir

    That's it. In this way i have the Documents subfolder under the home folder, as i wanted.

    Thanks

    Friday, July 13, 2012 7:12 AM