none
Computer Name Settings vs Advanced TCP/IP Settings for DNS

    Question

  • Hello,

    I am in an environment with multiple domains (mydomain.com, na.mydomain.com, eu.mydomain.com), and I need to understand how to properly configure servers in this environment.


    Current Computer Name Configuration

    NetBIOS computer name:  webserver1
    Primary DNS suffix of this computer:  na.mydomain.com
    Full computer name:  webserver1.na.mydomain.com

    Change primary DNS suffix when domain membership changes:  Checked


    DNS Configuration

    Static IP

    Primary record:  webserver1.na.mydomain.com
    Alias:  webserver1.mydomain.com



    Given the settings above, I'm not exactly sure what the DNS settings should be (for Advanced TCP/IP on the Local Area Connection).  The current settings are listed below, with my specific questions highlighted.



    Current Advanced TCP/IP DNS Settings

    DNS server adddresses, in order of use:  Populated with DNS server IPs

    Append these DNS suffixes (in order):  (Selected with the following domain order)
    mydomain.com
    na.mydomain.com
    eu.mydomain.com

    Since this machine is configured to 'na.mydomain.com' in the System Properties, should 'na.mydomain.com' be at the top of this list?



    DNS suffix for this connection:  mydomain.com

    What should this be?  'na.mydomain.com'?  Nothing? 


    Register this connection's addresses in DNS:  Not checked

    Should this be checked?


    Use this connection's DNS suffix in DNS registration:  Greyed out.  Not checked.



    I asked a resource here about these highlighted settings, and the answer I got was that he didn't think (wasn't totally sure) these were used unless the machine is using DHCP, and since this machine is using a Static IP, they could be ignored.   Is this true?


    Any help would be very much appreciated.

    Thanks!








    Tuesday, February 17, 2009 10:14 PM

All replies

  • Hi JSR,
    Your configuration is almost correct for this environment, with multiple domains...

    In the 'Append these DNS suffixes (in order):'
    Put the 'na.mydomain.com' at the top.

    in the 'DNS suffix for this connection:'
    put the 'na.mydomain.com' again.

    the 'Register this connection's addresses in DNS:' should be checked.

    It will works well.

    Good luck.

    Cheers,
    Marcelo.
    Marcelo Braga -- Um discipulo de Jesus -- MCT/ MCSA/ MCITP/ MCTS Exchange 2007.
    Wednesday, February 18, 2009 2:38 PM