none
(Win2008R2) unable to save permission changes on gpsvc. Access is denied.

    Question

  • Dear all,

    I need to authorize gpsvc for administrators. Having logged on as "Administrator" account on win2008R2 it's still prompting for the following message:

    "unable to save permission changes on gpsvc. Access is denied."

    Please suggest how to save changes to gpsvc, have tried the advanced option also... any change made to permissions end up to above message.

    Regards.


    • Edited by rmsali Sunday, November 11, 2012 6:43 AM
    Sunday, November 11, 2012 6:40 AM

Answers

  • Hello,

    Are you looking for the steps to disable Group Policy Client service ?

    If so, here is the way

    • Start>Run>REGEDIT
    • Browse to the "HKLM\SYSTEM\CurrentControlSet\services\gpsvc" subkey in the registry.
    • Right-click on the "gpsrv" subkey and click on "Permissions." Open the "Advanced" tab, click on "Owner," select your user account from the list and then click on the "OK" button. Click on the "Administrators" group, click "Full Control" and then click "OK."
    • Double-click on the "Start" key in the right-hand pane and change its value to "4." Close the Registry Editor and reboot the computer. Upon rebooting, the Group Policy Client service is disabled.


    Regards, Ravikumar P

    • Marked as answer by rmsali Tuesday, November 13, 2012 10:57 AM
    Sunday, November 11, 2012 6:39 PM

All replies

  • Hello,

    Are you looking for the steps to disable Group Policy Client service ?

    If so, here is the way

    • Start>Run>REGEDIT
    • Browse to the "HKLM\SYSTEM\CurrentControlSet\services\gpsvc" subkey in the registry.
    • Right-click on the "gpsrv" subkey and click on "Permissions." Open the "Advanced" tab, click on "Owner," select your user account from the list and then click on the "OK" button. Click on the "Administrators" group, click "Full Control" and then click "OK."
    • Double-click on the "Start" key in the right-hand pane and change its value to "4." Close the Registry Editor and reboot the computer. Upon rebooting, the Group Policy Client service is disabled.


    Regards, Ravikumar P

    • Marked as answer by rmsali Tuesday, November 13, 2012 10:57 AM
    Sunday, November 11, 2012 6:39 PM
  • Hi,

    If you go to the service properties you can see that even a local administrator cannot stop or disable the service.

    For more details,please refer to the below link:

    Preventing Domain Group Policies from Applying

    http://www.remkoweijnen.nl/blog/2009/02/25/preventing-domain-group-policies-from-applying/

    http://windowsvc.com/bbs/board.php?bo_table=windowsvc&wr_id=138&page=4519

    Hope this helps.

    Regards,

    Yan Li


    Yan Li

    TechNet Community Support

    Monday, November 12, 2012 3:23 AM
  • Thanks Ravi,

    Issue resolved.

    Tuesday, November 13, 2012 10:57 AM