none
USB Drive Read Only

    Question

  • I'm running Windows 7 Home Premium SP1 64 bit on an Intel HP Pavilion dv6.  I have a PNY 16 GB USB drive that is now useless because it has somehow become "read only".  Did this happen with bitlocker?  I did not knowingly run bitlocker, and when I type it in the serch bar it doesn't find it, so my version may not even have bitlocker? 

    I've read all the other similar questions and tried what they said.  So far I have added: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies registry key and the DWORD WriteProtect  with a value of 0 and rebooted. I have set permissions to full control for this disk, I have used DISKPART to Clear the readonly Attribute, then rebooted but nothing has worked.  When I use DISKPART to list the attributes for this disk, it says:

    Current Read-Only State : YES

    Read-Only : NO

    So I guess the Read-Only attribute was cleared, but it is still in a read-only state.  How do I change the state? How do I prevent this from happening again?

    Someone said they took the disk offline and then back online and that cleared the read-only state, but when I tried to take it offline, I get a virtual disk service error: "The operation is not supported on removble media."

    Any help would be greatly appreciated.

    Thursday, May 03, 2012 5:05 AM

Answers

All replies

  • USB disk cannot be OFFLINED.

    Do the following

    diskpart> sel disk <usb-disk>

    diskpart> attrib disk clear Readonly

    diskpart> attrib disk

    Now try to write a file to this disk and let me know if it works

    Regards

    Satish

    Thursday, May 03, 2012 6:05 AM
  • I have the same issue with a 4GB dos bootable key.

    I've run:

    diskpart > sel disk <usb-key>
    diskpart > attrib disk clear readonly
    diskpart > attrib disk

    Disk attributes cleared successfully.

    DISKPART> attrib dis
    Current Read-only State : Yes
    Read-only  : No
    Boot Disk  : No
    Pagefile Disk  : No
    Hibernation File Disk  : No
    Crashdump Disk  : No
    Clustered Disk  : No

    So the read-only state is yes, but read-only is set to No. Is there a way to change the current read-only state?

    Wednesday, May 23, 2012 7:31 PM
  • I fixed it. This USB key has a lock switch on the side of it, which somehow got flipped into the ON position.
    Wednesday, May 23, 2012 7:41 PM
  • I don't know if Satish is still following this post but if he is...

    I have a pny Metal Attaché with the same issue as above but I do not have awrite protection switch, oh to be so simple I remember the good old floppy disks.

    As above I have found this in several places on the web along with many others like setting

    HKEY_Local_Machine/system/CurrentControlSet/Control/StorageDevicePolicie
    and go to right side and click on writeprotect and change the value to 1 if u have 0 or if u have 0 then change value to 1.

    formating with apacer Repair v2.9.1.1 I get (USB Flash Drive Not Found)

    Pny lowlevel format can't run on window 7, windows XP

    HDD LLF Low Level Format Tool gives readonly errors on all files.

    McAfee and PCTool Spyware Doc take forever to run. Can copy all files off the disk and no virues of spyware copied. Can not change any files on flash drive or delete

    diskpart > sel disk <usb-key>
    diskpart > attrib disk clear readonly
    diskpart > attrib disk

    Disk attributes cleared successfully.

    DISKPART> attrib dis
    Current Read-only State : Yes This should change but does not
    Read-only  : No
    Boot Disk  : No
    Pagefile Disk  : No
    Hibernation File Disk  : No
    Crashdump Disk  : No
    Clustered Disk  : No

    So the read-only state is yes, but read-only is set to No. Is there a way to change the current read-only state?

    This is the question I would like to know. "Is there a way to change the current read-only state?"

    Called PNY no help never returned my call. Don't mind junking it but I hate when I can't figure things out.

    Tuesday, November 27, 2012 4:10 AM
  • Hi Gary,

    "The disk will be in a read-only state if its read-only attribute is set. However, a disk can be in a read-only state even if its read-only attribute is not set, if the underlying hardware is read-only. For example, if the LUN is in read-only state, or if the disk is a virtual hard disk that resides on a volume that is read-only, the underlying hardware is read-only, and therefore the disk is in a read-only state."

    You cannot change the state of disk using diskpart or, windows tools. Like in case of USB disk if it is locked nothing can be done.

    You need to contact PNY for this help. We cannot help you here.

    Regards

    Satish

    Tuesday, November 27, 2012 4:37 PM
  • Not sure if this helps but maybe it mught jog someones mind for an answer.

    This happened to mewhile using a USB SD card reader.

    I created a kubuntu install stick with Universal USB Installer 1.9.2.1 all went well Win 8
    When I went to add more files  Ubuntu 12.10 to my 8 gig class 10 sd card it came up read only.
    Went back to Win 8 same thing read only. Looked for regedit lines from on solution my reg had no entry.
    Checked my lock switch and moved it from the position it was allways in to the other position and TADA.
    Added files went to Ubuntu 12.10 and added files. 
    Here is where it gets stranger. I decide to install Kubuntu 12.4.1 so I go to format drive to recreate a install stick with Kubuntu 12.4.1. I try Universal USB Installer 1.9.2.1 with erase disk checked. No go read only again. Try to format Win 8 and no go. Try to format gpart no go. Back to Win 8  change advanced sharing and add my user and select full access for it and the everyone user. Try to format and TADA ! It wipes and I create a Kubuntu 12.4.1 install stick. I install Kubuntu and decide I need a few more files from Win 7 Laptop and no go READ ONLY ! Try everything above again and no go.  Frustrated ~~
    I removed the SD card and plugged it in the Win 7 Laptop card reader slot and it was a normal working normal and has ever since. If I put it in the USB unit it still comes up Read only.  

    Hope this Helps 

    Arntech1331

    Blue Marble 
    It's where we Live !
    Sunday, January 06, 2013 7:52 AM
  • Arntech1331,

    Your comment helped me out a lot! I had tried just about everything with an SD card I've kept inside a USB stick that worked fine then magically went read only. The switch was still in the unlocked position. I'd toggled it back and forth but not actually tried to write to it with the switch in the "locked" postion.

    After reading your post I decided "what the heck..." Bam. Formatted perfectly with the switch set to "locked". Somehow the card is now operating exactly opposite to what the switch is set to.

    Thursday, December 26, 2013 8:20 AM
  • I had this problem too on a drive that does not have a write protection switch

    I tried many things (RegEdit, DiskPart, using GParted under Linux etc...) without any luck.

    The next thing I tried was re-flashing the USB drive firmware and that worked.

    It is quite involved, as you need to figure out the vendor ID and Product ID of the drive

    This software allows to detect all USB devices and find ID:

    http://www.nirsoft.net/utils/usb_devices_view.html

    the download is all the way at the bottom or here: http://www.nirsoft.net/utils/usbdeview.zip

    Then you need to go find the Mass Production tool software (the program manufacturers use to flash and test the USB drives)

    The best place seems to be here: 

    http://flashboot.ru/iflash/

    Enter the VID (Vendor ID) and PID (Product ID) and if you're lucky there is a tool for you!

    Look for the CHIP vendor (not the flash vendor). Mine was Phison. And then the Flash MODEL

    Then go look in the tools section: http://flashboot.ru/files/

    and find the flash vendor tools: look for the tool that supports your Flash model.

    Once you have that, you may need to look up info on the web on what to do because all tools are different.

    One thing seems to be common: you can load the current config and save the data to disk: DO THAT FIRST! 

    You generally then need to edit some paramters: make sure they match what you currently have.

    In my case with the Phison tool, the tool version itself and some DLL version were wrong, and not available. I 'downgraded' the version numbers in the program to match the flash tool I had, and it went through.

    TADAAA!!! Now I have a brand new flash drive unlocked... but obviously EMPTY... So if you have important files on there, you should really back them up first (as usual!)

    Good luck!

    Thursday, January 23, 2014 2:25 AM
  • This worked perfectly for me. My thumb drive had no write-protection switch, and no read-only mode options in device properties. I had already tried using DISKPART to no avail.

    An additional step for me was to figure out the Chip Vendor. I used ChipGenius (screenshot below), and the assumed the Controller Vendor was the Chip Vendor (in my case also Phison). The suggested tool was "Silicon Power Low Level Formatter v2.11.3.0", and I couldn't find it at http://flashboot.ru/files, but found it easily enough with a Google search.

    ChipGenius



    • Edited by john12321 Saturday, May 17, 2014 3:23 AM
    Saturday, May 17, 2014 3:21 AM
  • The above is well and good, I think, but for someone like me who has had to endure Windows 8/8.1 for a year now the above is programmer language!  How does one do it if you know nothing about how to program/reprogram this mess called Windows 8/8.1?
    Thursday, July 31, 2014 2:48 PM
  • Dear friends, I had the same issue with an "Emtec USB2.0 L105 8GB LT Daffy Duck" (That was the full name finally). It was write protected etc... I did everything I found in the forum's including diskpart and regedit but unfortunately had no improvement! Finally I turned to the EMTEC official site, to the FAQ section. 

    They advice to download their "restore" program and act as follows:

    1) Plug the flash drive (certify that only the EMTEC flash drive is plugged)

    2) launch restore.exe

    3) Press the button RESTORE

    4) A warning message is displayed about erasing data. Press RESTORE to continue.

    5) A confirmation message is displayed, then press the YES

    6) A message RESTORING DEVICE ... appears. Do not unplug the flash drive and wait for the restoration (1 to 2 minutes).

    You can find the "Restore" program to the official EMTEC site (www.emtec-international.com)

    It worked for my usb drive, when nothing else helped!

    I hope everyone find his/her solution to the problem!  Greets!

    • Proposed as answer by BryanPM Wednesday, August 20, 2014 4:21 PM
    Tuesday, August 05, 2014 11:32 AM