none
NPS Server 2012 not listening on ports

    Question

  • I used to have NPS Configured as a Radius Server to authenticate my wireless client in my windows 2008R2.

    I decided to repeat the configuration on windows server 2012 standard.

    Installed NPS added the radius clients configures to secure wireless connections with valid certificate from a external ca.

    all good.

    The NPS itself configures the rules to allow port 1812 and so on to be open.

    However the server does not listen on that port.

    I'm thinking it has to do something with Remote Access feature on server 2012 blocking NPS service to listen its ports.

    I'm having to install all back in server 2008 r2.

    btw I managed once to work but after windows update and boot the thing stop listening on port 1812 again.

    no av even telnet localhost cannot connect to the port.

    fresh new server 2012 installation.

    Wednesday, May 01, 2013 8:00 AM

Answers

All replies

  • Hi,

    Thank you for the post.

    By default, NPS uses UDP ports 1812 and 1645 for RADIUS authentication messages and UDP ports 1813 and 1646 for RADIUS accounting messages. It is recommended that you do not change the default RADIUS UDP ports settings. Please also check if there is any error message in the event viewer.

    Regards,


    Nick Gu - MSFT

    Monday, May 06, 2013 4:29 AM
    Moderator
  • I know this is a really old thread, but I just wanted to bump it to explain the solution, as the one below does not really explain anything.

    For myself at least, the answer to get it to start listening on those ports was to start the "Network Access Protection Agent" service.  After that it began listening on port 1812 and 1813.  Also do not forget to set it to automatic so it does on the next reboot.

    Tuesday, January 28, 2014 9:30 PM
  • Thanks a bunch for coming back to post this - just what I needed!
    Wednesday, June 18, 2014 7:24 PM