none
Server 2008 R2 Server Manager refresh fails with RPC failure

    Question

  • Thsi is a newly built server, last action was to apply updates, but server hung on an update.  Server rebooted (is the DC and holds all of the FSMOs at this poing  (new test lab).  would like to salvage this work.

    Error message: shows - the Remote Procedure call failed. (Exception from HRESULT: 0x800706BE)

    I have seen other related errors but no fix without a special download.  Will that work in this case or is more information required?

    From Event Log:

    Log Name:      Application
    Source:        Application Error
    Date:          4/15/2010 5:36:01 PM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      SERVER01.mftest.local
    Description:
    Faulting application name: TrustedInstaller.exe, version: 6.1.7600.16385, time stamp: 0x4a5bc4b0
    Faulting module name: ntdll.dll, version: 6.1.7600.16385, time stamp: 0x4a5be02b
    Exception code: 0xc00000fd
    Fault offset: 0x000000000005395f
    Faulting process id: 0x430
    Faulting application start time: 0x01cadce390f3b12f
    Faulting application path: C:\Windows\servicing\TrustedInstaller.exe
    Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
    Report Id: e270d077-48d6-11df-abc1-001676a6a6c3
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-04-15T21:36:01.000000000Z" />
        <EventRecordID>713</EventRecordID>
        <Channel>Application</Channel>
        <Computer>SERVER01.mftest.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>TrustedInstaller.exe</Data>
        <Data>6.1.7600.16385</Data>
        <Data>4a5bc4b0</Data>
        <Data>ntdll.dll</Data>
        <Data>6.1.7600.16385</Data>
        <Data>4a5be02b</Data>
        <Data>c00000fd</Data>
        <Data>000000000005395f</Data>
        <Data>430</Data>
        <Data>01cadce390f3b12f</Data>
        <Data>C:\Windows\servicing\TrustedInstaller.exe</Data>
        <Data>C:\Windows\SYSTEM32\ntdll.dll</Data>
        <Data>e270d077-48d6-11df-abc1-001676a6a6c3</Data>
      </EventData>
    </Event>

    Thanks!

    Thursday, April 15, 2010 9:36 PM

Answers

  • Go to

    http://www.itsolutionskb.com/2009/04/roles-error-when-viewing-roles-in-windows-server-2008-server-manager/

    I installed the recommended tool. Afterwards the role manager is working.

     

    • Marked as answer by Karen Ji Thursday, May 06, 2010 7:19 AM
    Tuesday, May 04, 2010 1:11 PM

All replies

  • Thsi is a newly built server, last action was to apply updates, but server hung on an update.  Server rebooted (is the DC and holds all of the FSMOs at this poing  (new test lab).  would like to salvage this work.

    Error message: shows - the Remote Procedure call failed. (Exception from HRESULT: 0x800706BE)

    I have seen other related errors but no fix without a special download.  Will that work in this case or is more information required?

    From Event Log:

    Log Name:      Application
    Source:        Application Error
    Date:          4/15/2010 5:36:01 PM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      SERVER01.mftest.local
    Description:
    Faulting application name: TrustedInstaller.exe, version: 6.1.7600.16385, time stamp: 0x4a5bc4b0
    Faulting module name: ntdll.dll, version: 6.1.7600.16385, time stamp: 0x4a5be02b
    Exception code: 0xc00000fd
    Fault offset: 0x000000000005395f
    Faulting process id: 0x430
    Faulting application start time: 0x01cadce390f3b12f
    Faulting application path: C:\Windows\servicing\TrustedInstaller.exe
    Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
    Report Id: e270d077-48d6-11df-abc1-001676a6a6c3
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-04-15T21:36:01.000000000Z" />
        <EventRecordID>713</EventRecordID>
        <Channel>Application</Channel>
        <Computer>SERVER01.mftest.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>TrustedInstaller.exe</Data>
        <Data>6.1.7600.16385</Data>
        <Data>4a5bc4b0</Data>
        <Data>ntdll.dll</Data>
        <Data>6.1.7600.16385</Data>
        <Data>4a5be02b</Data>
        <Data>c00000fd</Data>
        <Data>000000000005395f</Data>
        <Data>430</Data>
        <Data>01cadce390f3b12f</Data>
        <Data>C:\Windows\servicing\TrustedInstaller.exe</Data>
        <Data>C:\Windows\SYSTEM32\ntdll.dll</Data>
        <Data>e270d077-48d6-11df-abc1-001676a6a6c3</Data>
      </EventData>
    </Event>

    Thanks!


    I'm seeing the exact same error on a production server here after the latest batch of hotfixes went on.  Server 2008 x64 running Exchange 2010 Edge Transport.
    Friday, April 16, 2010 6:07 PM
  • I see the exact error too on a production server  2008 R2 x 64 runnig only hyper-V. It was after the latest batch hotfixes. It was instaled only three of them :

    Update for Rights Management Services Client for Windows Server 2008 R2 x64 Edition (KB979099)

    Security Update for Windows Server 2008 R2 x64 Edition (KB975467)

    Security Update for Windows Server 2008 R2 x64 Edition (KB981332)

    Now I could not view the roles and features . When I was trying it i saw this error :

    Faulting application name: TrustedInstaller.exe, version: 6.1.7600.16385, time stamp: 0x4a5bc4b0

    Faulting module name: ntdll.dll, version: 6.1.7600.16385, time stamp: 0x4a5be02b

    Exception code: 0xc00000fd

    Fault offset: 0x000000000005381c

    Faulting process id: 0x1450

    Faulting application start time: 0x01cae4ad906b443c

    Faulting application path: C:\Windows\servicing\TrustedInstaller.exe

    Faulting module path: C:\Windows\SYSTEM32\ntdll.dll

    Report Id: d2da9d23-50a0-11df-bcb3-00155d01a101

    Now I cannot install new updates too. Is there somebody who can help me with this problem ?

     

    Sunday, April 25, 2010 7:48 PM
  • Go to

    http://www.itsolutionskb.com/2009/04/roles-error-when-viewing-roles-in-windows-server-2008-server-manager/

    I installed the recommended tool. Afterwards the role manager is working.

     

    • Marked as answer by Karen Ji Thursday, May 06, 2010 7:19 AM
    Tuesday, May 04, 2010 1:11 PM
  • In conjunction with server manager not loading any roles or features I can not install any updates. They all either hang or never download from windows update.

    This install of 2K8 R2 is only two days old.

    Anyone have any ideas?

     

    Faulting application name: TrustedInstaller.exe, version: 6.1.7600.16385, time stamp: 0x4a5bc4b0

    Faulting module name: ntdll.dll, version: 6.1.7600.16559, time stamp: 0x4ba9b802

    Exception code: 0xc00000fd

    Fault offset: 0x00000000000537ef

    Faulting process id: 0x124

    Faulting application start time: 0x01cb6d904e01090d

    Faulting application path: C:\Windows\servicing\TrustedInstaller.exe

    Faulting module path: C:\Windows\SYSTEM32\ntdll.dll

    Report Id: a24cfbcb-d983-11df-9d60-0014225a11a6

     

    Sunday, October 17, 2010 12:41 AM
  •  Hi,
     
    Please run the SUR tool and post the resulting
    %systemroot%\Logs\CBS\CheckSUR.log (usually
    C:\Windows\Logs\CBS\CheckSUR.log) log,
     

    -- Mike Burr
    Sunday, October 17, 2010 4:54 AM
  • Same problem here, same event log with the same exception code for trustedinstaller.exe.  I tried to run the SUR but it just sits at Searching for updates on this computer.  I tried to let it run overnight without success.  

     

    Here is what is in the cbs.log file when starting SUR.  I did try a reboot right before running this to make sure the line about "or else a reboot is pending" wasn't the case. 

     

    2010-10-19 09:56:02, Info                  CBS    TrustedInstaller terminated unexpectedly with pending operations the last time around; will skip core startup processing.

    2010-10-19 09:56:02, Info                  CBS    Starting TrustedInstaller initialization.

    2010-10-19 09:56:02, Info                  CBS    Loaded Servicing Stack v6.1.7600.16385 with Core: C:\Windows\winsxs\amd64_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7600.16385_none_655452efe0fb810b\cbscore.dll

    2010-10-19 09:56:02, Info                  CSI    00000001@2010/10/19:14:56:02.646 WcpInitialize (wcp.dll version 0.0.0.6) called (stack @0x7fee6bfe9a1 @0x7fef2d38755 @0x7fef2d02ac7 @0xff11e94c @0xff11d769 @0xff11daff)

    2010-10-19 09:56:02, Info                  CBS    Could not load SrClient DLL from path: SrClient.dll.  Continuing without system restore points.

    2010-10-19 09:56:02, Info                  CSI    00000002@2010/10/19:14:56:02.646 WcpInitialize (wcp.dll version 0.0.0.6) called (stack @0x7fee6bfe9a1 @0x7fef2d8500e @0x7fef2d51504 @0x7fef2d02b9d @0xff11e94c @0xff11d769)

    2010-10-19 09:56:02, Info                  CSI    00000003@2010/10/19:14:56:02.646 WcpInitialize (wcp.dll version 0.0.0.6) called (stack @0x7fee6bfe9a1 @0x7fef2c98728 @0x7fef2c98856 @0xff11e444 @0xff11d7ae @0xff11daff)

    2010-10-19 09:56:02, Info                  CBS    Ending TrustedInstaller initialization.

    2010-10-19 09:56:02, Info                  CBS    Starting the TrustedInstaller main loop.

    2010-10-19 09:56:02, Info                  CBS    TrustedInstaller service starts successfully.

    2010-10-19 09:56:02, Info                  CBS    SQM: Initializing online with Windows opt-in: False

    2010-10-19 09:56:02, Info                  CBS    SQM: Cleaning up report files older than 10 days.

    2010-10-19 09:56:02, Info                  CBS    SQM: Requesting upload of all unsent reports.

    2010-10-19 09:56:02, Info                  CBS    SQM: Failed to start upload with file pattern: C:\Windows\servicing\sqm\*_std.sqm, flags: 0x2 [HRESULT = 0x80004005 - E_FAIL]

    2010-10-19 09:56:02, Info                  CBS    SQM: Failed to start standard sample upload. [HRESULT = 0x80004005 - E_FAIL]

    2010-10-19 09:56:02, Info                  CBS    SQM: Queued 0 file(s) for upload with pattern: C:\Windows\servicing\sqm\*_all.sqm, flags: 0x6

    2010-10-19 09:56:02, Info                  CBS    SQM: Warning: Failed to upload all unsent reports. [HRESULT = 0x80004005 - E_FAIL]

    2010-10-19 09:56:02, Info                  CBS    No startup processing required, TrustedInstaller service was not set as autostart, or else a reboot is still pending.

    2010-10-19 09:56:02, Info                  CBS    NonStart: Checking to ensure startup processing was not required.

    2010-10-19 09:56:02, Info                  CSI    00000004 IAdvancedInstallerAwareStore_ResolvePendingTransactions (call 1) (flags = 00000004, progress = NULL, phase = 0, pdwDisposition = @0x117fa80

    2010-10-19 09:56:02, Info                  CSI    00000005 Creating NT transaction (seq 1), objectname [6]"(null)"

    2010-10-19 09:56:02, Info                  CSI    00000006 Created NT transaction (seq 1) result 0x00000000, handle @0x1e0

    2010-10-19 09:56:02, Info                  CSI    00000007@2010/10/19:14:56:02.662 CSI perf trace:

    CSIPERF:TXCOMMIT;448

    2010-10-19 09:56:02, Info                  CBS    NonStart: Success, startup processing not required as expected.

    2010-10-19 09:56:02, Info                  CBS    Startup processing thread terminated normally

    2010-10-19 09:56:02, Info                  CSI    00000008 CSI Store 4274816 (0x0000000000413a80) initialized

    2010-10-19 09:56:02, Info                  CBS    Session: 30109597_3216040624 initialized by client WinMgmt.


    Tuesday, October 19, 2010 2:58 PM
  • I have the same problem with my Windows 2008 R2 x64 server. Has anybody found a solution yet?
    Friday, November 05, 2010 10:33 PM
  • A few notes that might help some folks get this working and a big question at the end:

     

    My symptoms were same here; freshly built server W2K8R2x64 Enterprise, no roles installed just doing updates. No 3rd party software. After a few post-update reboots the server started to give an error when listing roles; TrustedInstaller.exe now fails, installed updates under uninstall in control panel list nothing (even though windows update lists them, but can't actually install any new ones) and when listing roles the server reports an error (i.e. no roles can be installed).




    Following (http://www.itsolutionskb.com/2009/04/roles-error-when-viewing-roles-in-windows-server-2008-server-manager/) as recommended above looks like the problem is:

    =================================
    Checking System Update Readiness.
    Binary Version 6.1.7600.20751
    Package Version 9.0
    2010-11-18 15:17

    Checking Windows Servicing Packages

    Checking Package Manifests and Catalogs
    (f)    CBS MUM Corrupt    0x00000000    servicing\Packages\Package_for_KB980232_RTM~31bf3856ad364e35~amd64~~6.1.1.0.mum        Expected file name Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~6.1.7600.16385.mum does not match the actual file name
    (fix)    CBS MUM Corrupt    CBS File Replaced    Package_for_KB980232_RTM~31bf3856ad364e35~amd64~~6.1.1.0.mum from Cabinet: C:\Windows\CheckSur\v1.0\windows6.1-servicing-x64-aug10.cab.
    (fix)    CBS Paired File    CBS File also Replaced    Package_for_KB980232_RTM~31bf3856ad364e35~amd64~~6.1.1.0.cat from Cabinet: C:\Windows\CheckSur\v1.0\windows6.1-servicing-x64-aug10.cab.

    Checking Package Watchlist

    Checking Component Watchlist

    Checking Packages

    Checking Component Store


    The update that failed permanently (others failed and then installed

    somehow) is Windows6.1-KB980232-x64, so it looks correct but before I realized that the log actually goes in .persist after I ran the tool a few times.
    The walkthrough on that page is pretty good with a few caveats:

    1. turn off your auto updates and shutdown a few times to make sure nothing is still trying to install (it looks like the broken updates keep trying for a while)
    2. check in CheckSUR.persist.log if you're not getting a good read from the CheckSUR.log file; the .log file looked like this for me even though windows was still broken:


    =================================
    Checking System Update Readiness.
    Binary Version 6.1.7600.20751
    Package Version 9.0
    2010-11-18 16:00

    Checking Windows Servicing Packages

    Checking Package Manifests and Catalogs

    Checking Package Watchlist

    Checking Component Watchlist

    Checking Packages

    Checking Component Store

    Summary:
    Seconds executed: 115
     No errors detected


    3. don't try to rename the files in the cab, just copy them as is (even though the message states that the file from the cab exists and it wants it named a specific way)

    Copying the files out into the c:\windows\servicing\packages did the trick and after another reboot I get roles listed, etc.

    In any case I see this problem posted all over different forums and no good explanation to why this happens is actually given; the error messages given by windows itself in this case (excluding the KB947821 tool which is a separate download that most don't know about) are absolutely useless. Also we still need to know what causes this as windows update is supposed to keep your servers in good working condition, not break them randomly when it feels like it. If anyone from MS is reading this, whats going on here?

    Thursday, November 18, 2010 9:24 PM
  • Hi iloman,

    Since you seem to be stuck at checking for updates, you may want to try my procedure here for manually kicking off the SUR tool,

    http://social.technet.microsoft.com/Forums/en-US/winservermanager/thread/0ca90e27-251f-4ddb-9cc9-0484d9bace84

    If you are not using 2008 R2, please let me know and I can verify that the steps are the same for 2008 (non R2)


    -- Mike Burr
    Friday, November 19, 2010 4:33 PM
  • hi,

    i have the exact same issue with a server 3 weeks ago witch was running TS gatreway for 3 months. Just now i installed a new server and as soon as i install the windows update from our wsus server the servermanager stops responding. This server is fresh installed server 2008R2 STD without any roles or software yet installed.

    This looks like a mayor bug to me, is there known witch update is causing this problem?

    regards martijn 

    Wednesday, December 29, 2010 12:49 PM
  •  From everything I've seen, they haven't identified a root cause of the
    issue (or at least one that they'll publish), but the resolution is
    fairly straightforward using the SUR tool. Have you been able to get the
    issue resolved on your servers?
     

    -- Mike Burr
    MS Technologies - Development - *nix
    Friday, December 31, 2010 10:17 PM
  • I've been on this for HOURS tonight on a 2 day old 2008R2 Dell.  I'm on with ProSupport now too.  My issue is all the same, but I can't solve it.  Here's the details.

    1. Added DC Role.
    2. Joined 10 Workstations
    3. Added Backup Role
    4. Ran Updates
    5. Update Service stalled after 12th update
    6. Canceled Updates and Rebooted Server
    7. Found Roles and Features wiith Error described here
    8. Found this and other articles pointint to update issues
    9. Downloaded SUR tool and found corrupt files related to KB2510531
    10. Downloaded the Update Package
    11. Extracted the .MUM and .CAT and replaced them in \Servicing\packages
    12. Rebooted and Updates started to install. Server rebooted again automatically
    13. Logged in and still found Roles and Features Error. Updates needing install included KB2510531 and IE9
    14. Installing Updates Failed again
    15. Reran SUR Tool and found same corrupt files for KB2510531
    16. Recopied the .MUM and .CAT to the specified folder
    17. Rebooted
    18. STILL NO ROLES & FEATURES. Available Updates KB2510351 and IE9 and now 2008R2 SP1 FAIL every time
    19. UNinstalled a previously installed .NET 3.5 update
    20. Can't reinstall this update

    I don't know where to go next.  Reinstalling this DC would waist the 20 hours of work.

    Monday, April 25, 2011 6:13 AM
  • Nevermind.

    I decided to keep running SUR Tool and I noticed that it was identifying different corrupt or missing files for the update.  I had to replace 4 files and now EVERYTHING WORKS!

    Monday, April 25, 2011 7:15 AM
  • In My case.. it's not easy to Install SUR Tools

    First, I rebooted the server, and Try to install SUR. I finished to install on Second Reboot time. Damn...

    Then I can check the CheckSUR.log file.

    It said as below

    Unavailable repair files:
     servicing\packages\Package_for_KB2476490_RTM~31bf3856ad364e35~amd64~~6.1.1.0.mum
     servicing\packages\Package_for_KB2476490_RTM~31bf3856ad364e35~amd64~~6.1.1.0.cat

    I just move to another folders the two files, and copioed same file from another server(I am not sure that it's correct process.

    Then Tryed to Windows Update After rebooting computer(So far, I don't know how many times rebooted the server)
    Now the server is working .

    I hope that this will help you..

    Thanx.

     

    Tuesday, August 16, 2011 9:13 AM