none
.NET Runtime Event ID 1021 after patch Tuesday updates

    Question

  • I've searched Google/TechNet for the following and have come up empty.  I performed all the updates that came out this week (01/10/2013) and now I'm receiving the following error on all my 2008R2 SP1 servers:

    Log Name:      Application
    Source:        .NET Runtime
    Date:          1/10/2013 4:23:06 AM
    Event ID:      1021
    Task Category: None
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      ServerName.domain.local
    Description:
    .NET Runtime version 2.0.50727.5466 - Executable "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\mscorsvw.exe" AppDomain "DefaultDomain" deleted obsolete native image "C:\Windows\assembly\NativeImages_v2.0.50727_64\mscorlib\74a5f0c2bc0d0e6e3c4ec4886b9be891\mscorlib.ni.dll"
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name=".NET Runtime" />
        <EventID Qualifiers="0">1021</EventID>
        <Level>3</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2013-01-10T12:23:06.000000000Z" />
        <EventRecordID>421817</EventRecordID>
        <Channel>Application</Channel>
        <Computer>ServerName.domain.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>.NET Runtime version 2.0.50727.5466 - Executable "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\mscorsvw.exe" AppDomain "DefaultDomain" deleted obsolete native image "C:\Windows\assembly\NativeImages_v2.0.50727_64\mscorlib\74a5f0c2bc0d0e6e3c4ec4886b9be891\mscorlib.ni.dll"</Data>
      </EventData>
    </Event>

    Any thoughts as to whether or not this is an ignorable warning or is there something that needs fixed?

    thanks!

    Thursday, January 10, 2013 6:22 PM

Answers

All replies

  • Hello,

    I work for a small IT Firm, and we are having the same problem with all our client sites on the following Operating Systems after patching Tuesday night:

    Vista

    7

    2008

    2008 R2

    These warnings are repeated numerous times every hour it seems. 

    Friday, January 11, 2013 2:01 AM
  • After further review, it appears the error only happened twice in a row on each machine, even Win7 machines, after the updates were installed.  I've not seen them since.
    Friday, January 11, 2013 3:40 PM
  • I also had this issue yesterday after updating an offine Windows 2008R2 server. After the updates were applied, the reboot hung. I powered it off manually. Restarted and tried the reboot cycle again. It hung again. I backed out all of the patches that were applied and attempted the reboot again. Same thing. It hung, but this time after 20 minutes, it finally rebooting itself with no intervention.

    After reviewing the logs, it seemed that this event came up during each reboot. I'm wondering if this event is what's stalling the servers shutdown process.

    Friday, January 11, 2013 3:53 PM
  • Hi guys;

    Is this issue solved? I did those updates today (on windows server 2008 R2) after the reboot gets a few warning of event id 1021. After a second reboot get for now (after 15 minutes) nothing yet.

    Is there a hotfix of this available by microsoft himself?

    Please let me know.

    greets Lieslot

    Saturday, February 09, 2013 1:17 PM
  • Lieslot,

    Please see my above post showing that it never comes back after the initial reboot.  At least for me and others it doesn't come back.

    Monday, February 11, 2013 3:16 PM