none
Hyper-V Virtual Switch and VLAN Tagging Not Working?

    Question

  • Hi All,

    We're currently in the process of testing server 2012 Hyper-V before we upgrade our production cluster this summer.  We seem to be having an issue with VLANs when being tagged through the Hyper-V virtual switch.  The test switch is a HP Procurve 2810 and i've triple checked all the vlan settings on the physical ports to make sure they are correct.

    I create a new virtual switch and allow management OS access with no vlan identifier.  The management interface works fine and the traffic is going out untagged on the physical NIC as expected and has connectivity.  If I add a vlan identifier on the management OS then we no longer get any external connectivity.  I have tried multiple vlans with the same effect.  I believe we also had the same problem the last time we tried tagging vm traffic as well but I can't yet test this.

    If I create a team instead of a virtual switch on the physical interface, I can create multiple virtual adapters for all the vlans that are tagged on the switches physical port and each virtual adapter gets connectivity.

    We have tried this on 3 different physical network cards (broadcom, intel and realtek) with the same results.  

    Any suggestions? Hot fixes?  

    I'm running all the windows updates on the box right now to see if anything changes.

    Monday, March 25, 2013 9:19 AM

Answers

  • Hi Lawrence

    Thanks for the update info, I can confirm that the update is already installed on the server.  Additionally although simalar to our problem, in our case VM's and the management vEthernet adapters do not get any network connectivity at any point when using vlans.

    I have however managed to get things working on the broadcom cards.  It would appear that each physical network card has to have certain settings configured in order for it to correctly pass vlan tags from the virtual switch.  (even though it will pass vlan traffic tagged via virtual interface on a team which is odd!) 

    Quoted from the following article: http://social.msdn.microsoft.com/Forums/de-DE/winserverhyperv/thread/cb771a3a-870d-4771-8658-97f0dcc47672 the post by MikeLascha - 

    "The "real" issue was that 802.1Q tagging was not enabled on the host NIC drivers.  Having "VLAN and Priority" set to "ENABLED" IS NOT ENOUGH!
     
    In my case I was unlucky in that the NIC's I use (Broadcom BCM5708C NetXtreme II GigE, and Intel(R) PRO/1000 PT Dual Port Server Adapter) both have what I would call "non standard" names for this setting. 
     
    For the Broadcom's, changing the VLAN ID property from 0 to 1 enables VLAN tagging and everything works as expected.  Thanks for the help on that setting.
     
    The Intel's were a tougher nut to crack as the settting is not exposed through the NIC's Advanced Properties, but only through the registry .  Changing the HKLM\SYSTEM\CurrentControlSet\Control\Class\{GUID}\XXXX\VlanFiltering registry key (where {GUID} is the GUID containing the network adapter configuration and XXXX is the NIC to be confgured) from 1 to 0 and rebooting corrects the issue.  The easiest way to find the proper key in your system is to use the find command in regedit with enough of the network adapter name (i.e. for the Intel's, find "1000 PT")."


    It's a shame this isn't better documented as it took a lot of searching around to find the answer, i'm sure a lot of other people will be falling foul of this.  All the hyper-V documentation implies that you can simply enable these features without any configuring of the network card.  Would be good to have this information more visible.

    Thanks for your help.  Onwards with testing the fancy new features!



    Wednesday, March 27, 2013 8:33 AM

All replies

  • Hi,

    Thank you for your question.

    I am currently looking into this issue and will give you an update as soon as possible.

    Thank you for your understanding and support.


    Lawrence

    TechNet Community Support

    Wednesday, March 27, 2013 5:05 AM
  • Hi,

    Check whether your Hyper-V server has installed update kb2693205. This KB mentioned such issue:

    Hyper-V virtual machines have no network connectivity when VLAN and QoS are enabled in Windows Server 8 Beta
    http://support.microsoft.com/kb/2693205

    Also check below file version:

    File name

    File version

    File size

    Date

    Time

    Vmsif.dll

    6.2.8250.121

    45,056

    22-Mar-2012

    02:00

    Vmsntfy.dll

    6.2.8250.121

    84,992

    22-Mar-2012

    02:00

    Vmswitch.sys

    6.2.8250.121

    522,752

    22-Mar-2012

    01:30

    Vmsif.dll

    6.2.8250.121

    45,056

    22-Mar-2012

    02:00

    Vmsntfy.dll

    6.2.8250.121

    84,992

    22-Mar-2012

    02:00

    Vmswitch.sys

    6.2.8250.121

    522,752

    22-Mar-2012

    01:30

    Check that and give us feedback for further troubleshooting, for more information please refer to following MS articles:

    Hyper-V Virtual Switch Overview
    http://technet.microsoft.com/en-us/library/hh831823.aspx
    Hyper-V: Configure VLANs and VLAN Tagging
    http://social.technet.microsoft.com/wiki/contents/articles/1306.hyper-v-configure-vlans-and-vlan-tagging.aspx

    Hope this helps!

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Lawrence

    TechNet Community Support

    Wednesday, March 27, 2013 7:29 AM
  • Hi Lawrence

    Thanks for the update info, I can confirm that the update is already installed on the server.  Additionally although simalar to our problem, in our case VM's and the management vEthernet adapters do not get any network connectivity at any point when using vlans.

    I have however managed to get things working on the broadcom cards.  It would appear that each physical network card has to have certain settings configured in order for it to correctly pass vlan tags from the virtual switch.  (even though it will pass vlan traffic tagged via virtual interface on a team which is odd!) 

    Quoted from the following article: http://social.msdn.microsoft.com/Forums/de-DE/winserverhyperv/thread/cb771a3a-870d-4771-8658-97f0dcc47672 the post by MikeLascha - 

    "The "real" issue was that 802.1Q tagging was not enabled on the host NIC drivers.  Having "VLAN and Priority" set to "ENABLED" IS NOT ENOUGH!
     
    In my case I was unlucky in that the NIC's I use (Broadcom BCM5708C NetXtreme II GigE, and Intel(R) PRO/1000 PT Dual Port Server Adapter) both have what I would call "non standard" names for this setting. 
     
    For the Broadcom's, changing the VLAN ID property from 0 to 1 enables VLAN tagging and everything works as expected.  Thanks for the help on that setting.
     
    The Intel's were a tougher nut to crack as the settting is not exposed through the NIC's Advanced Properties, but only through the registry .  Changing the HKLM\SYSTEM\CurrentControlSet\Control\Class\{GUID}\XXXX\VlanFiltering registry key (where {GUID} is the GUID containing the network adapter configuration and XXXX is the NIC to be confgured) from 1 to 0 and rebooting corrects the issue.  The easiest way to find the proper key in your system is to use the find command in regedit with enough of the network adapter name (i.e. for the Intel's, find "1000 PT")."


    It's a shame this isn't better documented as it took a lot of searching around to find the answer, i'm sure a lot of other people will be falling foul of this.  All the hyper-V documentation implies that you can simply enable these features without any configuring of the network card.  Would be good to have this information more visible.

    Thanks for your help.  Onwards with testing the fancy new features!



    Wednesday, March 27, 2013 8:33 AM