none
The computer did not resync because no time data was available

    Question

  • Hi,

    I hava a very big problem with w32tm. I cant sync time with external source. Funny thing is that when I run this command w32tm /config /manualpeerlist:time.windows.com,0x1 /syncfromflags:manual /reliable:yes /update and after /resync it is working for 3-4 sec and after it swich back to that wrong time. This computer is DC and it has PDC role.

    When i run command net time /domain:mydomain i get this DC time s it doens't take time from another computer. Something is blocking changes. Even if I try to manually change time it is working for 3 sec and after is wrong again. 

    I have tried with net start/stop w32time and unregister service but nothing helped. I tried even with Neutron but without success.


    • Edited by kaktak Tuesday, May 21, 2013 2:09 PM
    Tuesday, May 21, 2013 1:54 PM

Answers

  • Hi,

    Is your DC a VM. If it is so that means that you don't have right time on your hyper-v. You can disable time sync in integration services for that VM and fix time on DC.

    After that run this commands on Hyper-V and you are ready to go: 

    w32tm /config /syncfromflags:domhier /update

    net stop w32time 
    net start w32time

    • Marked as answer by kaktak Tuesday, May 21, 2013 2:56 PM
    Tuesday, May 21, 2013 2:47 PM

All replies

  • Hi,

    Is your DC a VM. If it is so that means that you don't have right time on your hyper-v. You can disable time sync in integration services for that VM and fix time on DC.

    After that run this commands on Hyper-V and you are ready to go: 

    w32tm /config /syncfromflags:domhier /update

    net stop w32time 
    net start w32time

    • Marked as answer by kaktak Tuesday, May 21, 2013 2:56 PM
    Tuesday, May 21, 2013 2:47 PM
  • Thank You very much, that did the trick. 
    Tuesday, May 21, 2013 2:57 PM
  • Hi,

    Is your DC a VM. If it is so that means that you don't have right time on your hyper-v. You can disable time sync in integration services for that VM and fix time on DC.

    After that run this commands on Hyper-V and you are ready to go: 

    w32tm /config /syncfromflags:domhier /update

    net stop w32time 
    net start w32time

    This response is much too high-level. For those of you who need more details, the most useful information is buried at these 2 pages:

    • http://riceball.com/d/content/w32tm-sucks-computer-did-not-resync-because-no-time-data-was-available
    • http://blogs.msdn.com/b/virtual_pc_guy/archive/2010/11/19/time-synchronization-in-hyper-v.aspx (Question #6, plus some comments)
    Or, for those tired of digging through all the 'Net, the steps I took are below. (I'm presently using Hyper-V 2012 r2, and my AD PDC is Win2012 r2)

    The main problem is the circular reference for time sync. If your Hyper-V host is in a domain, it gets its time from the DC. But when your DC is a VM (on a host in the domain), its time is either set by, or heavily influenced the host. Unfortunately, you can't break the cycle directly from the VM.

    1. Disable Hyper-V time-sync in the VM (your AD PDC), so it doesn't use the host for "moment-to-moment" sync. (I rebooted after this, but I hadn't figured out the fix yet, so it's not likely to be necessary.)
      • reg add HKLM\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\VMICTimeProvider /v Enabled /t reg_dword /d 0
    2. Point your VM to a reliable, external NTP time source; I'm in the USA, so that explains my example. You do not need to restart the time service for this to take effect.
      • w32tm /config /update /syncfromflags:manual /manualpeerlist:"0.us.pool.ntp.org 1.us.pool.ntp.org 2.us.pool.ntp.org" /reliable:yes
    3. Force the VM to sync now. (this may give the error from up above)
      • w32tm /resync /force
    4. If the time changes, but then changes right back (or you get that error)
      1. Login to the VM's host.
      2. Force the host to sync now; it'll use the DC since it's joined to the domain.
        • w32tm /resync /force

    Your host and VM will update as expected. It appears that the host can use the VM's setup to get the correct time from the external source, even though the VM won't use it itself. Once the host is fixed, it allows the VM to also use the correct time.

    • Edited by GrangerATS Tuesday, January 21, 2014 6:40 PM fixed html formatting corruption
    Tuesday, January 21, 2014 6:38 PM
  • I'd just like to add, I followed your process GrangerATS and unfortunately was unable to stop the PDC VM from acquiring time from the Hyper-V host (which, being a domain member, was acquiring its time from the PDC VM, a circular reference error). Forcing resync on the PDC did reset to correct time for about two seconds before it reverted. I spent about an hour checking and rechecking, editing, rebooting the VM and even the host with no success. So I gave up and disabled time sync in integration services for that VM and suddenly the PDC is getting time from the external source fine and the whole domain is now at the correct time (finally).

    I don't know how it sits with best practice guidelines, turning off time sync in integration services, but I'd prefer to make a simple change like that rather than set the Hyper-V host to override domain time acquisition and use an external time source - either are 'hacks' but switching off that one integration service seems like the most logical, easiest to follow and document one to me.

    Thanks for taking the time to explain it, though :-)

    EDIT: According to this blog post (scroll to the bottom for the 'Virtualized DC' section) it appears that simply turning off the Time Synchronization Integration Service is indeed the recommended practice (although that assumes you've ignored the guideline to run the PDC as a physical server, of course).



    Tuesday, May 27, 2014 2:01 PM