none
Connect to Hyper-V (local )server from laptop (domain)

    Question

  • Hi!

    This might not be possible, but anyway, I have the following setup:

    Server 2012 (anmosrv) not connected to a domain
    Windows 8 laptop (MALLxxxx) connected to domain

    What I'm trying to do is to connect to the Hyper-V running on the server from my Windows 8 clients Hyper-V manager.
    When I enter the name of the server to connect to I get an access denied error, I'm using my domain account to connect to the server.

    Is it possible to add my domain account to the groups required on the server? (Shouldn't be possible since it has no contact with the domain)
    Or is there another way of doing this?

    Best regards
    Andreas Molin

    Thursday, November 29, 2012 8:28 AM

Answers

  • Check this: http://technet.microsoft.com/en-us/library/jj647785.aspx

    To manage a Hyper-V Server that is not a domain member with an MMC snap-in

    1. If the Hyper-V Server is not a member of a domain, establish alternate credentials to use to connect to the Hyper-V server by typing the following command at a command prompt on the remote computer:

      cmdkey /add:<ServerName> /user:<UserName> /pass:<password>

      Where:

      ServerName is the name of the Hyper-V server

      UserName is the name of an administrator account

      To be prompted for a password, omit the /pass option.

    2. When prompted, type the password for the user name that is specified in the previous step.

    3. If the firewall on the Hyper-V Server is not already configured to allow MMC snap-ins to connect, follow the steps in "To configure Windows Firewall to allow MMC snap-in(s) to connect." Then return to this procedure.

    4. On a different computer, start an MMC snap-in, such as Computer Management.

    5. In the left pane, right-click the top of the tree and click Connect to another computer. (In the Computer Management example, you would right-click Computer Management (Local).)

    6. In Another computer, type the computer name of the Hyper-V Server and click OK. You can now use the MMC snap-in to manage the Hyper-V Server as you would any other computer running a Windows Server operating system.

    • Marked as answer by Andreas Molin Tuesday, January 22, 2013 8:27 AM
    Thursday, November 29, 2012 9:44 AM

All replies

  • Check this: http://technet.microsoft.com/en-us/library/jj647785.aspx

    To manage a Hyper-V Server that is not a domain member with an MMC snap-in

    1. If the Hyper-V Server is not a member of a domain, establish alternate credentials to use to connect to the Hyper-V server by typing the following command at a command prompt on the remote computer:

      cmdkey /add:<ServerName> /user:<UserName> /pass:<password>

      Where:

      ServerName is the name of the Hyper-V server

      UserName is the name of an administrator account

      To be prompted for a password, omit the /pass option.

    2. When prompted, type the password for the user name that is specified in the previous step.

    3. If the firewall on the Hyper-V Server is not already configured to allow MMC snap-ins to connect, follow the steps in "To configure Windows Firewall to allow MMC snap-in(s) to connect." Then return to this procedure.

    4. On a different computer, start an MMC snap-in, such as Computer Management.

    5. In the left pane, right-click the top of the tree and click Connect to another computer. (In the Computer Management example, you would right-click Computer Management (Local).)

    6. In Another computer, type the computer name of the Hyper-V Server and click OK. You can now use the MMC snap-in to manage the Hyper-V Server as you would any other computer running a Windows Server operating system.

    • Marked as answer by Andreas Molin Tuesday, January 22, 2013 8:27 AM
    Thursday, November 29, 2012 9:44 AM
  • I had this exact same problem, which I managed to fix and I blogged: http://www.remilner.co.uk/?p=215.

    Hope that helps you out.


    Robert Milner | Website: http://www.remilner.co.uk | Twitter: @robm82

    Thursday, November 29, 2012 6:59 PM
  • Hi!

    I managed to complete most of the steps you mentioned above, but for some reason I can't configure the firewall to allow my mmc snap-ins...
    I'm currently logged on as local administrator on the server (through RDP), but when executing the command in a PowerShell I get the following error:

    Enable-NetFirewallRule : No MSFT_NetFirewallRule objects found with property 'DisplayName' eq
    rify the value of the property and retry.
    At line:1 char:1
    + Enable-NetFirewallRule -DisplayName "Event Viewer"
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (Event Viewer:String) [Enable-NetFirewallRule],
        + FullyQualifiedErrorId : CmdletizationQuery_NotFound_DisplayName,Enable-NetFirewallRule

    I also tried to use netsh.exe to configure the firewall by the following command:
    "netsh.exe advfirewall firewall set rule group="remote administration" new enable=yes"

    But then I get the following error:
    "No rules match the specified criteria."

    Any idea what could be wrong?

    Best regards
    Andreas Molin

    Tuesday, December 04, 2012 7:55 AM
  • This technet article: http://technet.microsoft.com/en-us/library/jj574205#BKMK_1_5 states:

    To allow all MMC snap-ins to connect, run

    Enable-NetFirewallRule -DisplayGroup "Remote Administration"

    This results in the following:

    PS C:\Users\Administrator> Enable-NetFirewallRule -DisplayGroup "Remote Administ
    ration"
    Enable-NetFirewallRule : No MSFT_NetFirewallRule objects found with property
    'DisplayGroup' equal to 'Remote Administration'.  Verify the value of the
    property and retry.
    At line:1 char:1
    + Enable-NetFirewallRule -DisplayGroup "Remote Administration"
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (Remote Administration:String) [
       Enable-NetFirewallRule], CimJobException
        + FullyQualifiedErrorId : CmdletizationQuery_NotFound_DisplayGroup,Enable-
       NetFirewallRule

    I would also like to know how to enable remote management from MMC apps as this suggestion does not work.

    Wednesday, December 05, 2012 6:06 PM
  • Same problem as Paul Pecullan and Andreas Molin:

    Enable-NetFirewallRule : No MSFT_NetFirewallRule objects found with property
    'DisplayGroup' equal to 'Remote Administration'.  Verify the value of the
    property and retry.

    Seems this is a common problem, but no answers are forthcoming.  FYI I am giving up on Server Core for now, it is just too painful.  I hope, someday soon, MS or some third-party will explain in cookbook-style, step-by-step instructions, how to manage a 2012 Server Core. All I can find are incomplete and/or blatantly wrong instructions so far.

    Where I'm coming from:  Small-biz oriented IT generalist.  If I need to take a series of college courses to enable me to install a Server Core, I will just have to stick with the GUI.

    Thanks in advance for any advice.

    -Mark

    Sunday, January 20, 2013 10:04 PM
  • on my hypervisor added my windows 8 useraccount to local administrators
        (sconfig.cmd)

    using corefig to manage firewall
        (downloaded from http://corefig.codeplex.com)

    on my workstation added alternate credentials using
        cmdkey /add:Hypervisor /user:Hypervisor\windowsuser /pass:windowspass

    on my workstation used dcomcnfg.exe to allow remote access

        (http://pei.com/2013/05/hyper-v-manager-access-denied/

    I am working on a server core cookbook :)

    http://bd.net.co


    • Edited by FredeH Thursday, February 20, 2014 10:26 AM clarified step 4 dcomcnfg
    Thursday, February 20, 2014 10:23 AM