none
Start -> Run -> mstsc ERROR "unable to open connection file Default.rdp"

    Question

  • Windows Server 2008 Datacenter 64bit.

    I created a custom remote desktop file earlier this week and ever since when I launch remote desktop using the run command I get an error saying

    Unable to open connection file - C:\Users\Administrator\Documents\Default.rdp

    The connection file exists in the path specified, it isn't hidden or read only, I'm logged in as administrator and I have full control permissions to the file and so does SYSTEM. If I browse to the Default.rdp and double click it I get the same error message.

    To create the custom remote desktop file I did as follows;

    Start -> Run -> mstsc -> clicked the Options button ->changed the settings under all the tabs the way I want them -> clicked Save As -> pointed to my desktop

    This is more of a nuisance than anything else but I'd like to fix it. Anyone have an idea why I'm getting thise error?
    Teenage angst has paid of well, now I'm bored and old.
    Thursday, September 04, 2008 10:10 PM

Answers

  • Hello,

     

    Can you remotely connect to another computer, without this saved RDP file, using the Remote Desktop connection?

     

    Would you please try the following steps to see if the problem remains?

     

    1. Create another user, and then log on to the computer with this newly created user account. This is to check whether the problem is caused by user profile corruptions.

     

    2. Click Start, click Run and type mstsc in the dialog box and click OK.

     

    3. Click Options to expand the RDC interface. Type the Computer name that you want to connect to and then click the button "Save As…" to save the RDP file to a different location (D:\, for example). Do not make any other changes to the RDP settings at this time.

     

    4. Click Start and click Computer. Then navigate to the location that you saved the RDP file (D:\, for example). Double click this RDP file to see if the problem remains.

     

    If the RDP can work this way, well, you can try typing the following command in the Run dialog box to see if it can work either:

     

    Mstsc.exe D:\Test.rdp              (I am assuming that the RDP file is saved in this location)

     

    Besides, have you ever signed the RDP file (e.g. by using rdpsign)?

     

    Best regards,

    Chang Yin

    • Marked as answer by Chang Yin Monday, September 15, 2008 12:36 PM
    Monday, September 08, 2008 12:10 PM

All replies

  • Hello,

     

    Can you remotely connect to another computer, without this saved RDP file, using the Remote Desktop connection?

     

    Would you please try the following steps to see if the problem remains?

     

    1. Create another user, and then log on to the computer with this newly created user account. This is to check whether the problem is caused by user profile corruptions.

     

    2. Click Start, click Run and type mstsc in the dialog box and click OK.

     

    3. Click Options to expand the RDC interface. Type the Computer name that you want to connect to and then click the button "Save As…" to save the RDP file to a different location (D:\, for example). Do not make any other changes to the RDP settings at this time.

     

    4. Click Start and click Computer. Then navigate to the location that you saved the RDP file (D:\, for example). Double click this RDP file to see if the problem remains.

     

    If the RDP can work this way, well, you can try typing the following command in the Run dialog box to see if it can work either:

     

    Mstsc.exe D:\Test.rdp              (I am assuming that the RDP file is saved in this location)

     

    Besides, have you ever signed the RDP file (e.g. by using rdpsign)?

     

    Best regards,

    Chang Yin

    • Marked as answer by Chang Yin Monday, September 15, 2008 12:36 PM
    Monday, September 08, 2008 12:10 PM
  • I was receiving the same error.  Its possible the file may be corrupted.
    Try to:
    1) Unhide the file (Default.RDP) in that directory specified by the error.
    2) Rename it to something else as a backup.
    3) Open Remote Desktop and hopefully it should no longer complain.
    4) You may then save your settings and it should save it back as Default.RDP
    5) You may then remove the file you renamed if working.

    • Proposed as answer by sukh77 Tuesday, June 16, 2009 5:16 PM
    Friday, June 05, 2009 2:37 PM
  • I have had a same problem and just tried to delete Default.rdp, whose file size was 0kb for some reason, using command mode. It worked out~!! Good luck
    Friday, August 28, 2009 3:49 AM
  • cdarkman:  Thank you, this info worked perfectly for me as well.
    Sunday, January 24, 2010 9:02 PM
  • Also, I found if you create an empty file with the same name then the error goes away:

    • cd C:\Users\<Username>\Documents
    • echo > Default.RDP

    Hope that helps someone

    ----------------------------

    Windows 7 Ultimate x64

    • Proposed as answer by RobInmon Thursday, September 29, 2011 1:04 PM
    Saturday, May 08, 2010 2:40 PM
  • Hi, cdarkman.

    I have followed your suggestion and it works well.

    Actually, the reason of this error is as you said "the Default.RDP file is corrupted". So it is very easy to resolve it using your suggestion. Have a good day.

    Friday, February 18, 2011 3:14 AM
  • Thanks Dear. It worked for me as well.

     

     

    Regards

     

    Abdul Rahuman.M

    Tuesday, March 15, 2011 9:11 AM
  • Hi,

    Thanx for solution.

    I renamed Default.RDP to other name then type MSTSC in RUN and press enter which creates new Default.RDP file and now everything works fine. :)

    Thanx once again.

    Saturday, March 19, 2011 3:35 PM
  • Delete the RDP connection mostly in would be in C:\Users\user\Documents and run the mstsc command once again this would resolve the issue

     

    Thanks and Regards

    Saturday, April 30, 2011 5:54 AM
  • Hi Nilesh,

    Thanks. It did a trick.

     

     

    Thursday, July 07, 2011 5:43 PM
  • Thanks!! it worked from me also. it created new Default.rdp.
    Thursday, August 04, 2011 1:14 PM
  • Do following can sole this issue

     

    1.Unhide files settings.

    2. Find that path the error refer to U.

    3. Delete the "Default.rdp" file.

     

    Done.              Good Luck!

    Any problem further send me a mail:   philix_jiang@hotmail.com

     

    Regards,

    Phoenix

    • Proposed as answer by adammendoza Friday, February 24, 2012 5:32 AM
    Friday, September 23, 2011 9:27 AM
  • Post was very helpful. Thanks a lot!
    Thursday, December 08, 2011 3:06 PM
  • I agree! this was very helpful.
    Saturday, February 11, 2012 9:23 PM
  • cdarkman's answer worked for me; thanks.
    • Edited by md_florida Wednesday, April 04, 2012 1:17 PM
    Wednesday, April 04, 2012 1:17 PM
  • I had this problem.  The simple solution that I used:

    1) Start Internet Explorer

    2) Go to Organize->Folder and search Options->View and click Show hidden files, folders and drives

    3) Click OK

    4) Navigate to the folder Remote Desktop Connection is complaining about. For example, C:\Users\Administrator\Documents\

    5) Find the file Default.rdp and delete it

    6) Turn off hidden files: Go to Organize->Folder and search Options->View and click Don't show hidden files, folders and drives

    7) Click OK

    8) Close Internet Explorer

    9) Run Remote Desktop Connection

    My best guess is the default.rdp became corrupt at some point.  By deleting the file forces Remote Desktop to recreate it.  Problem solved.


    • Edited by agundrum Monday, September 24, 2012 2:52 AM
    Monday, September 24, 2012 2:51 AM
  • I don't get it.  I thought if a post had 14 votes it would be at the very top of the list?  I posted this same solution as a reply to the original post.  Sorry to have repeated.

    Why is the useless answer at the top?


    • Edited by agundrum Monday, September 24, 2012 2:55 AM
    Monday, September 24, 2012 2:55 AM
  • I am running W7 SP1 and this happened quite recently. Could be MS updates, could be CCleaner ate something.

    I renamed Default.rdp to Default.rdp.broken, and RDP works fine and has no error message.

    Curious it complains about C:\Users\<my name>\Documents\ directory.

    Windows File manager shows me no such directroy. But I can cd into it from a command prompt.

    Do we NEED Deafult.rdp? Right now, I'm pretty happy without it.

    Friday, September 28, 2012 1:28 PM
  • Thank you It was very usefull
    Sunday, October 28, 2012 2:28 PM
  • Thank You very Much.

    This solution worked brilliantly.

    Thursday, July 11, 2013 8:44 AM
  • The above solution worked for me.

    Thank you.

    Sunday, July 14, 2013 4:34 PM
  • You can delete it and run again remote program. I did it so and success. Happy lucky.
    Saturday, July 27, 2013 3:49 AM
  • I have had a same problem and just tried  Unhide and Re-named the Default.rdp.. All started working... Thanks
    Tuesday, August 13, 2013 10:09 AM
  • Simple way is Delete the c:\Users\xxxxxx\Documents\Default.rdp

    and try Start -> Run -> mstsc  It works 100%


    Ravishankar Maduri MCTS,MCPD,MCP

    Wednesday, July 02, 2014 2:13 AM