none
Ping HostName on Client returens IPv6 address

    Question

  • Logging onto the client machine (gula) and entering:

    ping gula
    

    returns reply from the IPv6 address instead of the IPv4 address.  All other client machines return IPv4 address.  Furthermore, I cannot ping gula by IPv4 address or Name from any other machine (although Pinging 192.168.1.4 (gula) from gula works fine.  I can connect to 192.168.1.4 via remote desktop.

    The DNS Forward lookup zone on the DNS server reports:

    GULA     Host (A)    192.168.1.4

    Similarly the DHCP server reports that 192.168.1.4 is leased to gula.domain.local.

    Any ideas?

    Thursday, May 26, 2011 11:09 AM

Answers

  • Nevermind. Somehow file and printsharing became disabled. Problem is solved.
    • Marked as answer by Tiger Li Wednesday, June 01, 2011 10:48 AM
    Thursday, May 26, 2011 12:24 PM
  • Hi QuinRiva,

     

    Thanks for posting here.

     

    Please try the hotfix in the article below:

     

    Resolving Internet connectivity issues on World IPv6 Day (June 8, 2011)

    http://support.microsoft.com/kb/2533454

     

    Thanks.

     

    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Tiger Li Wednesday, June 01, 2011 10:48 AM
    Friday, May 27, 2011 5:41 AM

All replies

  • Disable IPv6 on gula and you will only get IPv4 answer.

     


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Microsoft Student Partner
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration

    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration

    Thursday, May 26, 2011 11:17 AM
  • Hello,

    what you see is expected behavior. As IPv6 is the future protocol IPv6 is, if configured, it will be used first when pinging a machine. If it is not configured then IPv4 will reply.

    Do NOT disable IPv6, instead start learning to handle it. Also Microsoft recommends to leave it enabled.

    http://technet.microsoft.com/en-us/magazine/2009.07.cableguy.aspx


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Thursday, May 26, 2011 11:41 AM
  • Right, but that doesn't solve the issue of not being able to resolve the client name?
    Thursday, May 26, 2011 12:05 PM
  • Nevermind. Somehow file and printsharing became disabled. Problem is solved.
    • Marked as answer by Tiger Li Wednesday, June 01, 2011 10:48 AM
    Thursday, May 26, 2011 12:24 PM
  • Hi QuinRiva,

     

    Thanks for posting here.

     

    Please try the hotfix in the article below:

     

    Resolving Internet connectivity issues on World IPv6 Day (June 8, 2011)

    http://support.microsoft.com/kb/2533454

     

    Thanks.

     

    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Tiger Li Wednesday, June 01, 2011 10:48 AM
    Friday, May 27, 2011 5:41 AM