none
IE Proxy settings won't remove when I disable the Policy

    Question

  • We use a proxy server, and so I have a GPO configured  to set the setting for the proxy server.  This works fine, and all clients seem to receive this policy.

    However, now I need to take the server down for maintenance, I want to change the client's proxy server settings back to "Do not use a proxy server".  They should connect directly to the default gateway.

    So I disabled the link between my GPO and the OU, as well as the GPO that hides the "Connections" tab in IE.  The result of this, after rebooting a client, is that the "Connections" tab is available, and it shows the same proxy server settings that were applied when the link to the Proxy GPO was enabled.

    I ran gpresult /R /V, and here is the relevant part of the report:

      Internet Explorer Connection
            ----------------------------
                HTTP Proxy Server:   N/A
                Secure Proxy Server: N/A
                FTP Proxy Server:    N/A
                Gopher Proxy Server: N/A
                Socks Proxy Server:  N/A
                Auto Config Enable:  No
                Enable Proxy:        No
                Use same Proxy:      No

    So it seems like the policy I disabled is in fact not being applied.  It is not listed in the applied policies:

    Applied Group Policy Objects
        -----------------------------
            Windows SBS User Policy
            Windows SBS CSE Policy
            Small Business Server Folder Redirection Policy
            CG Shortcuts
            CG Screensaver Lock
            CG RemoveShutdownButton

    So why does my client still have the proxy settings?  I can change them, now that I have enabled access to the "Connections" tab, but I can't do this for every client machine (practically speaking).  How can I get my client machines to "untick" the "Use proxy server" option?


    Grant Ward, a.k.a. Bigteddy

    What's new in Powershell 3.0 (Technet Wiki)

    Sunday, February 19, 2012 11:28 AM

Answers

All replies

  • I have now created another GPO, with internet settings imported from a machine that had the proxy checkbox unticked.  According to gpresult, this policy is being applied.  However, I get a strange result now:

    Internet Explorer Connection
            ----------------------------
                HTTP Proxy Server:   server2:8080
                Secure Proxy Server: N/A
                FTP Proxy Server:    N/A
                Gopher Proxy Server: N/A
                Socks Proxy Server:  N/A
                Auto Config Enable:  No
                Enable Proxy:        No
                Use same Proxy:      Yes

                HTTP Proxy Server:   N/A
                Secure Proxy Server: N/A
                FTP Proxy Server:    N/A
                Gopher Proxy Server: N/A
                Socks Proxy Server:  N/A
                Auto Config Enable:  No
                Enable Proxy:        No
                Use same Proxy:      No

    So it seems like there are two sets of proxy settings, and the first one is being applied.  But I am absolutely sure that there are no other GPO's that have this setting.  I am stumped.


    Grant Ward, a.k.a. Bigteddy

    What's new in Powershell 3.0 (Technet Wiki)


    • Edited by Bigteddy Sunday, February 19, 2012 12:23 PM
    Sunday, February 19, 2012 12:21 PM
  • I have tried actually deleting the old GPO, reboot the client, run gpresult, and it still gives me a proxy server.  Where is it getting this information from?

    Grant Ward, a.k.a. Bigteddy

    What's new in Powershell 3.0 (Technet Wiki)

    Sunday, February 19, 2012 1:51 PM
  • Hi Grant,

    After disabling the Current group policy, apply another blank group policy and link it to all the users.

    http://sgwindowsgroup.org/blogs/panda/archive/2010/05/15/clear-internet-explorer-proxy-setting-using-gpo.aspx

    After applying proxy settings to the users, this is the ideal way to revert the settings. Please check this and tell whether it helps.

    Regards,

    Tom

    • Marked as answer by Bigteddy Sunday, February 19, 2012 2:43 PM
    Sunday, February 19, 2012 2:14 PM
  • Hi Tom,

    I glad someone is working on a Sunday!  I need to take this proxy server down tomorrow, hence my frantic efforts to get this to work.  I don't know how long the server is going to be down, or even if it will come back up again, so I have to be prepared.

    I am busy testing your suggestion now, and will let you know...


    Grant Ward, a.k.a. Bigteddy

    What's new in Powershell 3.0 (Technet Wiki)

    Sunday, February 19, 2012 2:38 PM
  • Thanks, you saved my bacon!  It worked.  Although, the setting under LAN Settings still has the proxy server checkbox ticked, it is definitely bypassing the proxy server.  (The address field is blank).

    I think that's a bit bizzare:  Surely what I did should have reverted the setting?  This seems like a bit of a hack to me.


    Grant Ward, a.k.a. Bigteddy

    What's new in Powershell 3.0 (Technet Wiki)

    Sunday, February 19, 2012 2:43 PM
  • Hi Grant,

    Happy to hear that helped... Cheers man. Have a great day...

    Regards,
    Tom

    Sunday, February 19, 2012 3:08 PM