none
Deleting User Profiles in Windows 7 Professional

    Question

  • I am trying to figure out how to delete user profiles on a Windows 7 computer. The built-in user profile manager is not an option since this is a school environment and I can't delete the anticipated 200 or so user profiles per machine one by one using Windows User Profile Manager. Group policy in Server 2008 R2 has the following policy:

    Computer Configuration -> Policies -> Administrative Templates -> System -> User Profiles -> Delete User profiles older than a specified number of days on system restart

    However, like several other people have reported on different forms, this is not working. Has anyone ever gotten this policy to work. If so, could you please share your secret. It would be much appreciated.

     

     


    Sean Kenny
    Wednesday, January 26, 2011 8:16 PM

Answers

  • @ Arjun: The steps you provided may not available as Sean mentioned he cannot do the steps on each computer.

    @ Sean: Try to install the following hotfix and test the group policy again:

    The "Modified time" file attribute of a registry hive file is updated when an application loads and then unloads the registry hive file without making any changes on a computer that is running Windows Server 2008 R2 or Windows 7

    http://support.microsoft.com/kb/983544

    And as Meinolf mentioned in another article, it should be a Windows 7 related issue so that it is recommanded to post on Windows 7 forum instead.


    Shaon Shan |TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tngfb@microsoft.com
    Monday, January 31, 2011 11:34 AM

All replies

  • You can try to use mandatory profile instead of standard local profiles and configure users to use it.

    "Delete User profiles older than a specified number of days on system restart" - gpo setting seems to work for me, so maybe you will try to configure it and if you will have error try to troubleshoot it


    With kind regards
    Krystian Zieja
    http://www.projectnenvision.com
    Follow me on twitter
    My Blog
    Wednesday, January 26, 2011 8:38 PM
  • Mandatory profiles make for an extremely slow logon. 45 seconds in my testing. Not really a great sell with new computers and new server.

    After I applied this policy I ran the group policy results wizard. The wizard shows that this policy applied and no errors were present. However, profiles older than 1 day were still not deleted. Any thoughts on what to do from here?

    Thanks for you input.


    Sean Kenny
    Wednesday, January 26, 2011 8:45 PM
  • did you link the GPO to the OU holding users or the OU holding computers?
    tesgroup
    Wednesday, January 26, 2011 10:17 PM
  • I created an OU for student users and placed the users in this OU. I placed the computer I was testing in the same OU with the students. The GPO has been linked to the OU.
    Sean Kenny
    Wednesday, January 26, 2011 10:57 PM
  • Thursday, January 27, 2011 8:20 PM
  • @ Arjun: The steps you provided may not available as Sean mentioned he cannot do the steps on each computer.

    @ Sean: Try to install the following hotfix and test the group policy again:

    The "Modified time" file attribute of a registry hive file is updated when an application loads and then unloads the registry hive file without making any changes on a computer that is running Windows Server 2008 R2 or Windows 7

    http://support.microsoft.com/kb/983544

    And as Meinolf mentioned in another article, it should be a Windows 7 related issue so that it is recommanded to post on Windows 7 forum instead.


    Shaon Shan |TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tngfb@microsoft.com
    Monday, January 31, 2011 11:34 AM