none
gppmig.exe

    Question

  • I am attmpting to run the gppmig tool on a windows 2008 x64 server in the same subnet as the pdc emulator but i get this error message. I have tried uninstalling and re-installing the tool in the 32 and 64 versions, but I get the same error. any help out there?

    C:\Program Files (x86)\Microsoft\GppMig>gppmig -whatif

    Unhandled Exception: System.IO.FileLoadException: Could not load file or assembl
    y 'gppmig, Version=1.0.250.50, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
     or one of its dependencies. Strong name validation failed. (Exception from HRES
    ULT: 0x8013141A)
    File name: 'gppmig, Version=1.0.250.50, Culture=neutral, PublicKeyToken=31bf3856
    ad364e35' ---> System.Security.SecurityException: Strong name validation failed.
     (Exception from HRESULT: 0x8013141A)
    The Zone of the assembly that failed was:
    MyComputer

    Tuesday, July 27, 2010 3:17 PM

Answers

  • Hey there Chodafish,

    As it turns out, this is a known issue with GPPMig.  The developers that own the tool are still trying to figure out exactly why it happens, but in the meantime we have a workaround you can use:

    1. Get sn.exe.  If the computer has installed Visual Studio IDE, this tool can be found in %Program Files%\Microsoft SDKs\Windows\v6.0A\bin . Otherwise, download the .net framework SDK and install to get this tool.  Note the tool has two versions for x86 and x64, so choose the tool accordingly.

    x86 - http://www.microsoft.com/downloads/details.aspx?FamilyID=fe6f2099-b7b4-4f47-a244-c96d69c35dec&displaylang=en

    x64 - http://www.microsoft.com/downloads/details.aspx?familyid=1AEF6FCE-6E06-4B66-AFE4-9AAD3C835D3D&displaylang=en

    2. Run this command to register the target dll for skip strong name validation.
    Sn.exe –Vr {the_assembly_path} 

      
    Then run this command to verify if the command had taken effect on the assembly:
    Sn.exe –Vl


    3. Step 2 should add a key to the registry table. If it fails, you can check the registry and manually enter it. On a x86 machine,  make sure that you have/create this value in the registry.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\StrongName\Verification\gppmig, 31bf3856ad364e35

    If it is a x64 machine, the registry entry depends on the process that loads the gppmig.dll. If the process runs 64bit (for example, if you call gppmig directly), the registry key should be:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\StrongName\Verification\gppmig, 31bf3856ad364e35

    Iff the process runs 32 bit mode for some reason, the value would be:

    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\StrongName\Verification\gppmig, 31bf3856ad364e35

    We've used this method in several occurrences so far to work around the problem, so please let us know if it works for you.


    David Beach - Microsoft Online Community Support
    • Marked as answer by Chodafish Wednesday, July 28, 2010 5:29 PM
    Wednesday, July 28, 2010 1:27 PM
  • There is a problem with .NET strong name validation with the computer in question and/or the current user profile.

     

    The work around David suggested gets by the strong name issue; however, build 50 has an issue with nested filters.  The installation includes a readme file with an email address where you can request the latest version of GPPMIG.  The latest build (build 52) removes strong name validation and contains a fix for nested filters. There were a few requests that went out today, so if you requested a new version check your Inbox and the ever popular Junk Mail folder.

     

    Mike Stephens

    Microsoft

    http://blogs.technet.com/b/askds/

    • Marked as answer by Chodafish Wednesday, July 28, 2010 5:28 PM
    Wednesday, July 28, 2010 2:53 PM

All replies

  • Have you seen this thread?

    http://social.technet.microsoft.com/Forums/en-US/winserverGP/thread/d817321d-525c-4cff-a83b-866a1418cac0

     


    Santhosh Sivarajan | MCTS, MCSE (W2K3/W2K/NT4), MCSA (W2K3/W2K/MSG), CCNA, Network+ Houston, TX http://blogs.sivarajan.com/ http://publications.sivarajan.com/ This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, July 27, 2010 5:06 PM
  • Thanks for the info, I tried that but I still get the error message. Are there any other solutions out there?
    Tuesday, July 27, 2010 10:30 PM
  • Hey there Chodafish,

    As it turns out, this is a known issue with GPPMig.  The developers that own the tool are still trying to figure out exactly why it happens, but in the meantime we have a workaround you can use:

    1. Get sn.exe.  If the computer has installed Visual Studio IDE, this tool can be found in %Program Files%\Microsoft SDKs\Windows\v6.0A\bin . Otherwise, download the .net framework SDK and install to get this tool.  Note the tool has two versions for x86 and x64, so choose the tool accordingly.

    x86 - http://www.microsoft.com/downloads/details.aspx?FamilyID=fe6f2099-b7b4-4f47-a244-c96d69c35dec&displaylang=en

    x64 - http://www.microsoft.com/downloads/details.aspx?familyid=1AEF6FCE-6E06-4B66-AFE4-9AAD3C835D3D&displaylang=en

    2. Run this command to register the target dll for skip strong name validation.
    Sn.exe –Vr {the_assembly_path} 

      
    Then run this command to verify if the command had taken effect on the assembly:
    Sn.exe –Vl


    3. Step 2 should add a key to the registry table. If it fails, you can check the registry and manually enter it. On a x86 machine,  make sure that you have/create this value in the registry.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\StrongName\Verification\gppmig, 31bf3856ad364e35

    If it is a x64 machine, the registry entry depends on the process that loads the gppmig.dll. If the process runs 64bit (for example, if you call gppmig directly), the registry key should be:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\StrongName\Verification\gppmig, 31bf3856ad364e35

    Iff the process runs 32 bit mode for some reason, the value would be:

    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\StrongName\Verification\gppmig, 31bf3856ad364e35

    We've used this method in several occurrences so far to work around the problem, so please let us know if it works for you.


    David Beach - Microsoft Online Community Support
    • Marked as answer by Chodafish Wednesday, July 28, 2010 5:29 PM
    Wednesday, July 28, 2010 1:27 PM
  • There is a problem with .NET strong name validation with the computer in question and/or the current user profile.

     

    The work around David suggested gets by the strong name issue; however, build 50 has an issue with nested filters.  The installation includes a readme file with an email address where you can request the latest version of GPPMIG.  The latest build (build 52) removes strong name validation and contains a fix for nested filters. There were a few requests that went out today, so if you requested a new version check your Inbox and the ever popular Junk Mail folder.

     

    Mike Stephens

    Microsoft

    http://blogs.technet.com/b/askds/

    • Marked as answer by Chodafish Wednesday, July 28, 2010 5:28 PM
    Wednesday, July 28, 2010 2:53 PM
  • Great information Mr. David, but it still fails...

    I did verify that both of these entries are in the registry under HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\StrongName\Verification\ which is kinda wierd since it is a x64 Hyper-V 2008 server and I installed the x64 gppmig.msi. 

    Here is the sn.exe info.    Any help is much appreciated!

    C:\Program Files\Microsoft\GppMig>sn -Vl

    Microsoft (R) .NET Framework Strong Name Utility  Version 3.5.21022.8
    Copyright (c) Microsoft Corporation.  All rights reserved.

    Assembly/Strong Name                  Users
    ===========================================
    *,31bf3856ad364e35                    All users
    gppmig,31BF3856AD364E35               All users

    C:\Program Files\Microsoft\GppMig>gppmig -whatif

    Unhandled Exception: System.IO.FileLoadException: Could not load file or assembl
    y 'gppmig, Version=1.0.250.50, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
     or one of its dependencies. Strong name validation failed. (Exception from HRES
    ULT: 0x8013141A)
    File name: 'gppmig, Version=1.0.250.50, Culture=neutral, PublicKeyToken=31bf3856
    ad364e35' ---> System.Security.SecurityException: Strong name validation failed.
     (Exception from HRESULT: 0x8013141A)
    The Zone of the assembly that failed was:
    MyComputer

    Wednesday, July 28, 2010 3:10 PM
  • Hi Mr. Mike,

     Thanks for the information, I just sent an e-mail request for the latest build. I have my fingers crossed.

    Wednesday, July 28, 2010 3:33 PM
  • It works!

    I sent the request to Direct questions regarding GPPMIG to gppmsup@microsoft.com and they sent me the latest build and now gppmig is running like a top.

     

    Thank you:

    David Beach and Mike Stephens at gppmig support!

    Wednesday, July 28, 2010 5:32 PM
  • do I really have to write to gppmsup@microsoft.com to get the fixed version of GPPMIG or is it available for public download?

    Thanks

    Edith

    Monday, January 03, 2011 4:27 PM
  • Hi Edith,

    Unfortunately we don't have it posted for a download yet, so you do need to send an email to that address requesting the updated version. 


    David Beach - Microsoft Online Community Support
    Friday, January 07, 2011 2:33 PM