none
BPA Error: The DNS client is not configured to point only to the internal IP address of the server. Server 2012 essentials

    Question

  • The DNS client is not configured to point only to the internal IP address of the server.

    I currently have two client pc's connected to the server - all appears fine except this error when I run BPA.  Both clients are being backed up and both can access shared folders and the internet.

    My server is connected to client through a switch from where both machines are also connected to a broadband router.

    I have followed the guidance from the server and checked that the DNS addresses of the clients point to the server, which they do.

    I have tried both LAN ports on the server and have disabled one of them.

    Below is the connections from my pc:

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

    C:\Users\Roger>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : OFFICE
       Primary Dns Suffix  . . . . . . . : LAUHAN.local
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : LAUHAN.local
                                           Home

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . : Home
       Description . . . . . . . . . . . : Intel(R) 82579V Gigabit Network Connectio
    n
       Physical Address. . . . . . . . . : 54-04-A6-48-AE-E9
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::6878:6fb:e4f8:9eda%10(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.0.17(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : 27 December 2012 10:19:44
       Lease Expires . . . . . . . . . . : 28 December 2012 20:46:40
       Default Gateway . . . . . . . . . : 192.168.0.1
       DHCP Server . . . . . . . . . . . : 192.168.0.1
       DHCPv6 IAID . . . . . . . . . . . : 240387238
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-5D-6A-16-54-04-A6-48-AE-E9

       DNS Servers . . . . . . . . . . . : 192.168.0.19
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.Home:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : Home
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    C:\Users\Roger>

    And my server connections:

    Windows PowerShell
    Copyright (C) 2012 Microsoft Corporation. All rights reserved.

    PS C:\Users\roger> ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Peter
       Primary Dns Suffix  . . . . . . . : LAUHAN.local
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : LAUHAN.local
                                           Home

    Ethernet adapter Ethernet 2:

       Connection-specific DNS Suffix  . : Home
       Description . . . . . . . . . . . : Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Controller #2
       Physical Address. . . . . . . . . : 00-23-54-27-02-0A
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::6099:ef1e:372c:ea43%13(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.0.19(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : 27 December 2012 20:30:37
       Lease Expires . . . . . . . . . . : 28 December 2012 20:30:36
       Default Gateway . . . . . . . . . : 192.168.0.1
       DHCP Server . . . . . . . . . . . : 192.168.0.1
       DHCPv6 IAID . . . . . . . . . . . : 218112852
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-65-6C-6E-00-23-54-27-02-09
       DNS Servers . . . . . . . . . . . : 192.168.0.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.Home:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : Home
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    PS C:\Users\roger>

    Could someone please have a look and point me in the right direction, as I want to turn off my Home Server and start to use server 2012.

    Many thanks in advance

    roger

    Friday, December 28, 2012 2:16 AM

Answers

  • Your server is not configured properly. Out of the box, the DNS setting on the server is set to manual, not automatic, and is pointed to 127.0.0.1.

    Yours is pointed at 1929168.0.1, so the default has been changed. It is either manually configured and configured wrong, or someone set it to automatic (dhcp) which is also wrong. The BPA os picking up on that.

    • Marked as answer by rcp2k Friday, December 28, 2012 6:16 PM
    Friday, December 28, 2012 2:57 AM

All replies

  • Your server is not configured properly. Out of the box, the DNS setting on the server is set to manual, not automatic, and is pointed to 127.0.0.1.

    Yours is pointed at 1929168.0.1, so the default has been changed. It is either manually configured and configured wrong, or someone set it to automatic (dhcp) which is also wrong. The BPA os picking up on that.

    • Marked as answer by rcp2k Friday, December 28, 2012 6:16 PM
    Friday, December 28, 2012 2:57 AM
  • Thank you Cliff,

    Now I have no more red advisories.

    Much appreciated.

    Roger

    Friday, December 28, 2012 6:18 PM