none
2008 Terminal Server Beep

    Question

  • We recently migrated to 2008 for alot of our production servers, and now when users connect to them thru RDP dialog boxes generat a system board beep. I know you can stop the beep service on the client end, but this is far from ideal. Is there a way to stop it on the server end so clients don;t get the beeps?
    Thursday, September 18, 2008 9:57 PM

Answers

  • Fixed it. This is what worked incase someone else runs into this.

    1.     Click Start, click Run, type regedit, and then click OK.
    2.    Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server
    3.    On the Edit menu, point to New, and then click DWORD Value.
    4.    Type DisableBeep, and then press ENTER.
    5.    Right-click DisableBeep, and then click Modify.
    6.    In the Value data box, type 0, and then click OK.

    Note You can disable the MessageBeep function by changing the value to 1.
    7.    Quit Registry Editor.
    Wednesday, September 24, 2008 7:54 PM

All replies

  • Hi,


    I think you should enable sound mapping and then it will be fine.
    Citrix Technology Professional, PubForum Founder http://www.pubforum.net
    Friday, September 19, 2008 9:18 AM
    Moderator
  • Not 100% sure what you are referring to here, but In Terminal Services Configuration, In the properties of the Connection, in the Client Settings tab there is a box to check to disable Audio. I would assume to Enable it you would leave it unchecked which it is, but It looks like it's forced unchecked in our configuration anyways since it is greyed out. I'm wondering if it might be because the server doesn't even have a sound card so the audio it sends is system beep sound? Sorry I'm just starting out with server OS's so I'm not that familiar with how everything works yet.
    Wednesday, September 24, 2008 7:27 PM
  • Fixed it. This is what worked incase someone else runs into this.

    1. Click Start, click Run, type regedit, and then click OK.
    2.Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server
    3.On the Edit menu, point to New, and then click DWORD Value.
    4.Type DisableBeep, and then press ENTER.
    5.Right-click DisableBeep, and then click Modify.
    6.In the Value data box, type 0, and then click OK.

    Note You can disable the MessageBeep function by changing the value to 1.
    7. Quit Registry Editor.

    Wednesday, September 24, 2008 7:54 PM
  • Fixed it. This is what worked incase someone else runs into this.

    1.     Click Start, click Run, type regedit, and then click OK.
    2.    Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server
    3.    On the Edit menu, point to New, and then click DWORD Value.
    4.    Type DisableBeep, and then press ENTER.
    5.    Right-click DisableBeep, and then click Modify.
    6.    In the Value data box, type 0, and then click OK.

    Note You can disable the MessageBeep function by changing the value to 1.
    7.    Quit Registry Editor.
    Wednesday, September 24, 2008 7:54 PM
  • Very good Jerry, glad you found an answer.
    Citrix Technology Professional, PubForum Founder http://www.pubforum.net
    Wednesday, September 24, 2008 9:35 PM
    Moderator
  • Hi there,

    I just applied the registry fix. But it does not work for me. Do I have to restart the server?

    /hajo
    Tuesday, November 04, 2008 11:00 AM
  • You just need to restart terminal services service ( note: it will drop all your connected users, but they will reconnect to same session)


    Make IT bether
    Thursday, December 25, 2008 4:10 PM
  • Thank you.  This does work.
    Appreciate it.
    Tuesday, November 24, 2009 6:46 PM
  • Jerry,

    I tried the fix you proposed, but I found that the registry values are actually mixed up.

    To TURN OFF system beep, set the DisableBeep value to 1.

    To TURN ON system beep, set the DisableBeep value to 0.

    The MS KB article referring to this issue, http://support.microsoft.com/kb/901115, has it backwards as well.

    NOTE: you still need to at least restart the TS service in order for the changes to take effect.

    Hope this helps.

    • Proposed as answer by TSNick Friday, December 17, 2010 4:19 PM
    Friday, December 17, 2010 4:17 PM