none
Delete cached copies of roaming profiles is not working

    Question

  • I've searched these forums and others up and down to find a solution to this, but no luck. 

    File Server and Domain Server: Windows 2008 R2

    Machines in question: Windows XP SP3

    Here is my problem:

    I have the GPO enabled "Delete cached copies of roaming profiles is not working". It seems like it is trying to work. When a user logs off, it deletes everything but just three folders.

    "Cookies"

    "IETldCache"

    "Local Settings"

    Within each folder is a locked file, "index.dat". It can't be deleted until I reboot the machine. Once I do that, I can delete the files.

    Because it is unable to delete these three files, the cached profile is not deleted on log off. If the same user logs in, they get a corrupted cache profile. "user.domain", "user.domain001", etc.

    Please tell me how to fix this problem. I even tried making a log off script to delete these files, it does not work. I even tried enabling the GPO to exclude these three folders, it does not work. I have User profile hive cleanup installed and running as well.


    • Edited by wausti1 Tuesday, May 22, 2012 6:15 PM
    Tuesday, May 22, 2012 6:13 PM

All replies

  • You cannot delete items that are holded by process that had not been finished yet. In restart procedure you end all processes and the remaining files can be deleted. As the workstations are expected to be shutdowned from time to time, this phenomenon does not do any harm to your system.

    Regards

    Milos

    Tuesday, May 22, 2012 9:08 PM
  • That can't be right. The GPO specifically says it deletes the roaming profile cache. You can tell it is trying because it deletes everything else in the user profile. It only gets held up by the three folders I listed above. There has to be a way to delete those folders on log out without restarting. 
    Tuesday, May 22, 2012 9:15 PM
  • usually a lock on index.dat could be keep by the AV -  try with a AV exclusion on those file.


    MCP | MCTS 70-236: Exchange Server 2007, Configuring



    • Edited by Yagmoth555MVP, Moderator Wednesday, May 23, 2012 1:26 AM removing my comment about user hive cleanup servcie, just seen it was already tested.
    Wednesday, May 23, 2012 1:19 AM
  • Hello,


    There could be something locking to the Index.dat files block the Index.dat files to be deleted.


    Please restart the Windows XP client in Clean Boot and narrow down the cause of this problem. In most cases, it’s the Antivirus software.


    How to configure Windows XP to start in a "clean boot" state
    http://support.microsoft.com/kb/310353


    If this problem does not exist in Clean Boot. Then, re-enable 3-party services and startup applications one after one until the problem reoccurs.


    Thanks
    Zhang

    Wednesday, May 23, 2012 5:09 AM
  • I uninstalled the Anti-virus we are using (sophos). It still is not deleting the roaming profile cache. I did a clean boot, and it still occurs. It is happening on all 180 XP machines as well, so it's not just this machine. The only thing I have noticed that is strange is that if you log in with the same username twice and it creates the "username.domain" profile, it is able to delete that roaming cache. It is just unable to delete the very first roaming profile cache. Why would it lock these index.dat files for just the first time a user logs in, but no other consecutive time after that. Very, very strange problem. Again, I've been searching for a solution for weeks now and in every related thread no one has ever been able to provide a working solution. If you search these forums and others, this appears to be a common problem.
    • Edited by wausti1 Wednesday, May 23, 2012 3:11 PM
    Wednesday, May 23, 2012 3:11 PM
  • How big your profiles are?

    If you have big profiles usually it can not be synchronized to server

    one more tip is that use GPO to redirect MyDocuments folder to users home folder on server (if you didn't done ti yet)


    Best regards
    Dubravko Marak
    MCP
    Blog: Windows Server Administration
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, May 23, 2012 3:44 PM
  • Then if it's not the AV, try to narrow down the process that keep the lock open with process explorer. With process explorer you could see what lock the file, just run it on the computer before a logoff. A link that kinda show some printscreen http://blogs.technet.com/b/markrussinovich/archive/2005/04/24/the-case-of-the-mysterious-locked-file.aspx

    Let us know after what process keep the index.dat open even if IE is close.


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Friday, May 25, 2012 3:21 AM
  • Sorry it took me so long to reply. To answer both questions above:

    1. Even if the profile is small, it doesn't delete the index.dat file. I also already redirect the My Documents folder.

    2. Winlogon is locking the file even with IE closed. 

    Any ideas?

    Again, I've found numerous Technet threads about this same issue and yet no one has ever given an answer that worked in any of those threads.

    Tuesday, June 05, 2012 2:24 PM
  • I assume that problem lies in windows XP itself.

    I had similar problem long time ago.

    Just as idea, put delete directory command in script on local machine. Script must run before user logs on


    Best regards
    Dubravko Marak
    MCP
    Blog: Windows Server Administration
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, June 05, 2012 3:41 PM
  • Dubravko:
    Will the delete directory command allow it to delete the roaming cached profile the next time the user logs on? As soon as the user logs out it will leave the files I listed in my original post locked until I reboot the machine. I want a permanent fix that will allow the users to log off and on multiple times without rebooting.

    I just can't figure out why it deletes everything but the "index.dat" files when the user logs out. It's very odd.
    Tuesday, June 05, 2012 8:17 PM
  • Maybe you can find the answer here: http://support.microsoft.com/default.aspx?scid=kb;EN-US;974277  and here in dutch: http://academy.open-groupe.nl/index.php/blog/view/84-local-cached-copies-of-a-roaming-profile-are-not-deleted-on-log-off-or-shutdown
    Wednesday, June 13, 2012 6:53 PM
  • disable slow link detection in GPO, excluding folders that roam in GPO, installing User Profile Hive Cleanup Service (http://www.microsoft.com/en-us/download/details.aspx?id=6676) via GPO Software deployment seems to help us.

    We still have cached roaming profile issues but these things help reduce the frequency.

    btw...Windows 7 (we skipped Vista) seems to have solved this issue by syncing only the changes instead of the entire profile.

    Monday, July 16, 2012 4:27 PM
  • disable slow link detection in GPO, excluding folders that roam in GPO, installing User Profile Hive Cleanup Service (http://www.microsoft.com/en-us/download/details.aspx?id=6676) via GPO Software deployment seems to help us.

    We still have cached roaming profile issues but these things help reduce the frequency.

    btw...Windows 7 (we skipped Vista) seems to have solved this issue by syncing only the changes instead of the entire profile.

    According to Microsoft you shouldn't have "Delete cached copies of roaming profiles" enabled and "Do not detect slow network connections" disabled(or not configured because it enables detection of slow network connections).

    In our set up "Do not detect slow network connections" was not configured; therefore detection was enabled by default. None of the GPOs hitting the affected machines were configured with this so I tested by configuring it in Local Policy by enabling "Do not detect slow network connections" (Computer Configuration\Administrative Templates\System\User Profile). So far it's been working but I'll update if I see further issues.


    • Edited by abelr15 Monday, August 06, 2012 1:04 PM
    Monday, August 06, 2012 12:59 PM