none
Stuck at "Please wait for the Group Policy client..." on Windows 2008 R2

    Question

  • hi,

    This is a freshly built Windows 2008 R2 machine. I assigned IP to the server, added to the domain and rebooted. when I try ot log on through remote desktop, I am Stuck at "Please wait for the Group Policy client...I tried rebooting server  2 -3 times but no use. How do I over come this situation ? I do not want to rebuild this machine :( 


    Thanks !


    • Edited by Jayawardhane Saturday, May 05, 2012 12:12 AM screen shot added
    Saturday, May 05, 2012 12:11 AM

Answers

  • How many policies are applied to the OU in which the problematic machine account resides ?

    Have blocked policy inheritance ? Have you enforced any policy ? 

    Disable block inheritance (if applicable) and do not enforce any policy  (if applicable), see the results.

    If nothing works, dis-join and re-join the server in question back to the domain, which might fix this issue. 


    A UNIVERSE without WINDOWS is CHAOS !

    This posting is provided "AS IS" with no warranties or guarantees and confers no rights.

    About Me ?

    • Marked as answer by Jayawardhane Tuesday, May 08, 2012 12:50 PM
    Tuesday, May 08, 2012 9:01 AM
  • How many policies are applied to the OU in which the problematic machine account resides ?

    Have blocked policy inheritance ? Have you enforced any policy ? 

    Disable block inheritance (if applicable) and do not enforce any policy  (if applicable), see the results.

    If nothing works, dis-join and re-join the server in question back to the domain, which might fix this issue. 


    A UNIVERSE without WINDOWS is CHAOS !

    This posting is provided "AS IS" with no warranties or guarantees and confers no rights.

    About Me ?

    There are 2 policies assigned to the OU, Default domain policy and hardening policy specific to 2008 Servers. Yes, inheritance was blocked which I have disabled, no policies are enforced.

    However, dis-joining and re-adding server to domain seems to have fixed the issue. I have rebooted this server 2-3 times to verify the results and have not found any issues.


    Thanks !

    Tuesday, May 08, 2012 12:49 PM

All replies

  • Hi,

    Do you try to log on the server through console?

    Do you try to disconnect the network cable when the server stick "Please wait for the Group Policy client"?

    Regards, Terry | My Blog: http://terrytlslau.tls1.cc

    Saturday, May 05, 2012 5:23 AM
  • Hello, 

    1. Is this the message you getting before pressing Ctrl+Alt+Delete or after you Logged into system?

    2. Is this server is member server or another Domain controller ?


    Regards, Ravikumar P


    Saturday, May 05, 2012 2:24 PM
  • Just a few initial thoughts... 

    • When you set the IP address, what DNS did you point to?  Odds are, you have one or more DC's running DNS that you need to be pointing to.  If you're not using the correct DNS, you can have Group Policy Problems.
    • Are you able to log into the console of the server with the Administrator account?  If you are, you can check the Event Log to see what is going on. 
    • What happens if you just sit and wait?  At some point, things like scripts and other items that can cause Group Policy to hang will time out. 
    Sunday, May 06, 2012 3:16 AM
  • Hi,

    Do you try to log on the server through console?

    Do you try to disconnect the network cable when the server stick "Please wait for the Group Policy client"?

    Regards, Terry | My Blog: http://terrytlslau.tls1.cc

    Yes, I tried to log on  to this server through console.

    The server in question is a VM running on ESXi 4.1, I disconnected virtual NIC assigned to this server and immediately, I got ctrl-alt-del screen.


    Thanks !

    Monday, May 07, 2012 4:28 AM
  • Hello, 

    1. Is this the message you getting before pressing Ctrl+Alt+Delete or after you Logged into system?

    2. Is this server is member server or another Domain controller ?


    Regards, Ravikumar P


    1. before ctrl-al-del

    2. member server.


    Thanks !

    Monday, May 07, 2012 4:29 AM
  • Just a few initial thoughts... 

    • When you set the IP address, what DNS did you point to?  Odds are, you have one or more DC's running DNS that you need to be pointing to.  If you're not using the correct DNS, you can have Group Policy Problems.
    • Are you able to log into the console of the server with the Administrator account?  If you are, you can check the Event Log to see what is going on. 
    • What happens if you just sit and wait?  At some point, things like scripts and other items that can cause Group Policy to hang will time out. 

    1. I verified DNS IPs they are correct.

    2. I didnt get ctrl-alt-del screen to log on.

    3. I only see the above mentioned message if I sit and wait ;)


    Thanks !

    Monday, May 07, 2012 4:31 AM
  • Disconnecting virtual NIC has fixed the problem for time being howerver that's not a permanent solution. I reconnected virtual NIC once I got ctrl-alt-del window and I could log on. But I reboot this server again, issue reoccurs.

    Thanks !

    Monday, May 07, 2012 4:33 AM
  • Hi,

    After logging on the member server, do you perform "gpudpate" and Resultant Set of Policy "rsop.msc" to verify your GPO settings in your member server?

    Do you get any event log error which relates to GPO?

    Regards, Terry | My Blog: http://terrytlslau.tls1.cc

    Monday, May 07, 2012 7:28 AM
  • Hi,

    check gp with "gpresult" or check where the server is located in ADUC.

    It could be that are some Policies applied failing... if you using Authenticated Users and the server is located in the wrong OU.


    Kind regards,

    Tim
    MCITP, MCTS
    http://directoryadmin.blogspot.com

    This posting is provided 'AS IS' with no warranties or guarantees and confers no rights.


    • Edited by butim Monday, May 07, 2012 7:56 AM
    Monday, May 07, 2012 7:56 AM
  • Hi,

    After logging on the member server, do you perform "gpudpate" and Resultant Set of Policy "rsop.msc" to verify your GPO settings in your member server?

    Do you get any event log error which relates to GPO?

    Regards, Terry | My Blog: http://terrytlslau.tls1.cc

    I get a warning in event log... could this be the issue ?


    Thanks !

    Monday, May 07, 2012 9:27 AM
  • Hello,

    Check for start up/shutdown scripts (Computer policies ) if you have any?

    Use GPMC for better understanding of computer policies


    Regards, Ravikumar P

    Monday, May 07, 2012 9:33 AM
  • Hello,

    Check for start up/shutdown scripts (Computer policies ) if you have any?

    Use GPMC for better understanding of computer policies


    Regards, Ravikumar P

    1. There are no startup or shutdown scripts defined.

    2. I always use GPMC ;-)


    Thanks !

    Monday, May 07, 2012 9:48 AM
  • Hello, 

    1. Is this the message you getting before pressing Ctrl+Alt+Delete or after you Logged into system?

    2. Is this server is member server or another Domain controller ?


    Regards, Ravikumar P


    1. before ctrl-al-del

    2. member server.


    Thanks !

    Since it is before Ctrl+Alt+Del and Since no startup/shutdown scripts defined, hope the screen is not suppose to show "please wait for the GP Client" 

    Regards, Ravikumar P

    Monday, May 07, 2012 9:59 AM
  • Since it is before Ctrl+Alt+Del and Since no startup/shutdown scripts defined, hope the screen is not suppose to show "please wait for the GP Client" 


    Regards, Ravikumar P

    Its not suppose to show but its showing. that's the fact !

    Thanks !


    Monday, May 07, 2012 10:48 AM
  •  
    > I get a warning in event log... could this be the issue ?
     Check the Group Policy Event Log for any messages or long durations
    during the last "network connected" boot...
     
    regards, Martin
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Monday, May 07, 2012 11:31 AM
  •  
    > I get a warning in event log... could this be the issue ?
     Check the Group Policy Event Log for any messages or long durations
    during the last "network connected" boot...
     
    regards, Martin
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!

    I also noticed following warning events along with event 4098.

    Event Id: 6006, Source: Winlogon - The winlogon notification subscriber <GPClient> took 96 second(s) to handle the notification event (CreateSession). 

    Event Id: 6005, Source: Winlogon - The winlogon notification subscriber <GPClient> is taking long time to handle the notification event (CreateSession).

    Event Id:1530, source:User Profile Service - Windows detected your registry file is still in use by other applications or services. The file will be unloaded now. The applications or services that hold your registry file may not function properly afterwards.  


    Thanks !

    Monday, May 07, 2012 11:49 AM
  • Hello KS, 

    Any printers connected to this member server?


    Regards, Ravikumar P

    Monday, May 07, 2012 12:37 PM
  • Hi Ravikumar,

    No printers are connected to this server.


    Thanks !

    Monday, May 07, 2012 1:52 PM
  • Hi,

    As I guess, you would like to create or update a setting which is about "LocalizedString" in "Computer Configuration > Preference > Windows Settings > Registry". However, the setting cannot be applied because "Access is denied".

    Could you provide more information for this setting?

    Regards, Terry | My Blog: http://terrytlslau.tls1.cc

    Monday, May 07, 2012 3:46 PM
  • Hi Terry,

    I had applied a policy through GPP which will enable Quick Edit Mode in cmd and Disable IE ESC on servers. IE ESC is working fine however, Quick Edit mode still has problems. Perhaps thats the reason I am seeing access denied msg. I even checked few of my other servers where I see the same warnings in event logs however, those servers do not have "waiting for group policy client..." issue.


    Thanks !

    Tuesday, May 08, 2012 5:56 AM
  • How many policies are applied to the OU in which the problematic machine account resides ?

    Have blocked policy inheritance ? Have you enforced any policy ? 

    Disable block inheritance (if applicable) and do not enforce any policy  (if applicable), see the results.

    If nothing works, dis-join and re-join the server in question back to the domain, which might fix this issue. 


    A UNIVERSE without WINDOWS is CHAOS !

    This posting is provided "AS IS" with no warranties or guarantees and confers no rights.

    About Me ?

    • Marked as answer by Jayawardhane Tuesday, May 08, 2012 12:50 PM
    Tuesday, May 08, 2012 9:01 AM
  • Hi,

    I'm not sure how to you use GPP to assign "Quick Edit Mode in cmd". However, the Quick Edit Mode in cmd should not be applied to "Computer Configuration". This setting should be applied to "User Configuration". This setting is related to Users. It's not related to computer. You should assign "Quick Edit Mode in cmd" to the Users OU with the GPO.

    I found 1 of the methods which is provided by Technet.

    For more information:

    QuickEdit

    http://technet.microsoft.com/en-us/library/cc978582.aspx

    Regards, Terry | My Blog: http://terrytlslau.tls1.cc

    Tuesday, May 08, 2012 12:23 PM
  • Hi,

    I'm not sure how to you use GPP to assign "Quick Edit Mode in cmd". However, the Quick Edit Mode in cmd should not be applied to "Computer Configuration". This setting should be applied to "User Configuration". This setting is related to Users. It's not related to computer. You should assign "Quick Edit Mode in cmd" to the Users OU with the GPO.

    I found 1 of the methods which is provided by Technet.

    For more information:

    QuickEdit

    http://technet.microsoft.com/en-us/library/cc978582.aspx

    Regards, Terry | My Blog: http://terrytlslau.tls1.cc

    Thanks for your input. I removed QuickEdit mode policies from the GPO applied. in fact re-adding server to domain fixed the problem.

    Thanks !


    • Edited by Jayawardhane Tuesday, May 08, 2012 12:53 PM edit
    Tuesday, May 08, 2012 12:45 PM
  • How many policies are applied to the OU in which the problematic machine account resides ?

    Have blocked policy inheritance ? Have you enforced any policy ? 

    Disable block inheritance (if applicable) and do not enforce any policy  (if applicable), see the results.

    If nothing works, dis-join and re-join the server in question back to the domain, which might fix this issue. 


    A UNIVERSE without WINDOWS is CHAOS !

    This posting is provided "AS IS" with no warranties or guarantees and confers no rights.

    About Me ?

    There are 2 policies assigned to the OU, Default domain policy and hardening policy specific to 2008 Servers. Yes, inheritance was blocked which I have disabled, no policies are enforced.

    However, dis-joining and re-adding server to domain seems to have fixed the issue. I have rebooted this server 2-3 times to verify the results and have not found any issues.


    Thanks !

    Tuesday, May 08, 2012 12:49 PM