none
Port 80 Setup Or How can I connect my server from Internet (ex LAN)

    Question

  • Hi Team,

    Please accept my apologies for any silly questions as I am a complete Server Setup newbie.

    I have got a Windows Server 2012 - Standard up and running in my place.

    It is also connected to the internet via my broadband connection.

    Now I am intending to host my web application. However, I cannot connect to my server outside my network. I got my ipaddress using checkip.org and I cannot connect it.

    Whilst googling I found that port 80 has to be open or some other steps have to be taken.

    Can any of you Pandits point me in right direction as to how can I get my server to be contactable from outside. (I can't even do a remote desktop connection)

    Thank you.

    Kind regards

    Sap


    • Edited by SapHelp Friday, March 08, 2013 10:33 AM
    Friday, March 08, 2013 10:30 AM

Answers

  • Each application on your server answers requests on a separate port.  When you browse to a website, port 80 is the default.  You will need to configure your ROUTER/FIREWALL to forward all port 80 traffic to the internal IP address of the server.  For remote desktop connection, you have to forward port 3389 (by default).  If you tell us what brand and model router you have, we may can help you.

    BTW, if you are opening up services to the outside world, make SURE your system is patched, has secure passwords and is otherwise secure!!!


    C Shane Cribbs
    http://www.georgiatechnologies.com

    Friday, March 08, 2013 6:05 PM
  • in your scenario

    the default gateway is the broadband router..and by default it'll take port 80 for internet access..

    in this scenario if you want to access the server from out side .. you must do the port forwarding ... from the broad band router/modem

    broad band router gets the public ip...and the port forwarding will make a natting to your server private ip..

    if you want to host a web server then you have to host server with alternate ip 8080 , if want to access RDP then port 3389

    for example  create port forwarding for RDP:

    in modem/router select port forwarding then server name then port 3389 

    ... configure firewall exception rule or disable firewall if ti's testing ..

    all the best



    Sunday, March 10, 2013 8:37 PM

All replies

  • Each application on your server answers requests on a separate port.  When you browse to a website, port 80 is the default.  You will need to configure your ROUTER/FIREWALL to forward all port 80 traffic to the internal IP address of the server.  For remote desktop connection, you have to forward port 3389 (by default).  If you tell us what brand and model router you have, we may can help you.

    BTW, if you are opening up services to the outside world, make SURE your system is patched, has secure passwords and is otherwise secure!!!


    C Shane Cribbs
    http://www.georgiatechnologies.com

    Friday, March 08, 2013 6:05 PM
  • in your scenario

    the default gateway is the broadband router..and by default it'll take port 80 for internet access..

    in this scenario if you want to access the server from out side .. you must do the port forwarding ... from the broad band router/modem

    broad band router gets the public ip...and the port forwarding will make a natting to your server private ip..

    if you want to host a web server then you have to host server with alternate ip 8080 , if want to access RDP then port 3389

    for example  create port forwarding for RDP:

    in modem/router select port forwarding then server name then port 3389 

    ... configure firewall exception rule or disable firewall if ti's testing ..

    all the best



    Sunday, March 10, 2013 8:37 PM