none
VPN - Error 812

    General discussion

  • In thread titled "VPN error 812 and error 629 - testing VPN setup on internal LAN and getting this error", Glasgow suggested "allowed access in AD via the dial-in tab" to solve this issue.

    I think it isn't a good solution because doing that prevents NPS to apply Network Access Conditions to the User Connection Request (unless option box "Ignore User Account Dial-in Properties" is selected).
    The 812 error seems appearing for several reasons:
    -
    when Server Network Policy and Client Connection Profile don't match on the Authentication Protocol. It is easy to fix;
    - when NPS does not update (in memory I guess) value added to "Tunnel Type" Condition in Network Policy. That is more tricky.

    Let's give an example for the second situation:
    - a new Network Policy is set with "Day and time restrictions", "Operating system", "Windows group" and "Tunnel type" Conditions;
    - "Tunnel Type" is valued with "PPTP" only;
    When trying to connect VPN client, 812 error may appears.

    How to fix that ?
    - select additionnal value to "Tunnel type" Condition, like "L2TP" to obtain value "L2TP OR PPTP";
    - apply and close the Network Policy;
    - connect VPN client, it works !
    - revert the Network Policy to the good value for "Tunnel type" Condition, here it is "PPTP" only;
    - apply and close the Network Policy;
    - connect VPN client, it works and your Network Policy is now well set up !

    Hope this workaround will help some of you,

    Nacime Amimar & Axel Limousin
    ITSI - IT Training School
    93500 Pantin, France

    • Changed type Tiger Li Wednesday, July 20, 2011 3:07 AM
    Tuesday, July 19, 2011 4:41 PM

All replies

  • Hi Nacime Amimar & Axel Limousin,

     

    Thanks for your excellent sharing , this will must benefit someone who also encounter this situation in future.

     

    Regards,

     

    Tiger Li

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact  tnmff@microsoft.com.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, July 20, 2011 3:06 AM
  • I have been struggling with this issue for weeks - this little gem sorted it for me!

    Specifically, when configuring RRAS to forward Authenticatioon requests to a seperate NPS server, it would simply stop working, regardless of how I configured the various conditions.  Setting local authentication would work again.

    As soon as I did as Nucime & Axel suggested, forwarding of Authentication requests burst into life!

    Thanks!

    Tuesday, November 19, 2013 2:48 PM
  • Hi,

         I have the same above problem but dont know where to make the below changes

    How to fix that ?
    - select additionnal value to "Tunnel type" Condition, like "L2TP" to obtain value "L2TP OR PPTP";
    - apply and close the Network Policy;
    - connect VPN client, it works !
    - revert the Network Policy to the good value for "Tunnel type" Condition, here it is "PPTP" only;
    - apply and close the Network Policy;
    - connect VPN client, it works and your Network Policy is now well set up !


    Monday, March 10, 2014 3:11 PM