none
Group Policy Preferences Drive Maps Not Working in Windows 8 RTM When "Reconnect" Option is Active

    Question

  • I started testing Windows 8 RTM in our domain environment and have found that the drive maps via Group Policy Preferences are not functioning if the "Reconnect" option is ticked.  The drives are not mapped and there are no errors in the Event Log.  If I untick the option, the drives map properly.  These group policies function correctly with our Windows 7, Windows Vista and Windows XP clients.

    This behavior occurs even when UAC is off. 

    Normally, when a drive map is applied via group policy preferences, event 1112 is generated in the System event log indicating that the drive map was successful, but that it won't be available until the next login.  That is not happening here.  It is as if the extension is just ignoring the directive.

    Monday, August 20, 2012 8:50 PM

Answers

  • Oh my.  The drive maps do work if the user is not an Administrator.  It is troubling to see that there has been discussion about this issue since June and Microsoft did not bother to fix it in the RTM.

    In regards to the other question:  Some of the drives map to DFS shares and others do not.  They all fail to map.

    I must also correct my original post.  Even though I have UAC set to "Never Notify", it appears to be on in some fashion as programs still open in Medium integrity level.

    Thursday, August 23, 2012 12:33 PM

All replies

  • Thanks for that. It was bugging me a couple of hours ago with the Director's new laptop. It's funny something as basic as this wasn't tested or picked up earlier.
    • Edited by OzVic Tuesday, August 21, 2012 2:53 AM
    Tuesday, August 21, 2012 2:52 AM
  • I can confirm the exact same issue. Thanks for the info about un-ticking 'Reconnect'.

    Group Policy Results shows the drive map preferences as being applicable but they appear to be ignored by the client.

    Tuesday, August 21, 2012 11:41 AM
  • Good catch, I've been looking at this for 2 days. If you log onto the workstation with the domain administrator account (not a good idea)  it will map the drives though with the reconnect option ticked? I am now trying to figure out how to get the printers to work from the policy works fine in 64bit win 7.

    I am not sure why they removed the ability to set the home page in IE either,  I suspect that you need to set these in the "control panel settings" in the extensions but for the moment I have only the ability to add up IE8 here. (w2k8 domain)

    I have other issues to do with permissions as well, and it all worked so well in win7 sad really.

    I am a luddite I guess but I am still trying to work out why anyone would want this os without a touch screen ... but I am the desktop engineer and we persevere.

    Wednesday, August 22, 2012 1:51 AM
  • Thanks Mark un-ticking fixed the problem.

    This worked correctly in Win8 RP, but not in CP, apparently MS fixed it in RP but then somehow broke it again.

    Sean

    Wednesday, August 22, 2012 12:49 PM
  • Hello,

    please checkout if you have the same issue as here:

    http://social.technet.microsoft.com/Forums/en-US/winserverGP/thread/54721cb2-7f59-467f-856a-2a2d799ed953

    Is the user member of the local Administrators group on that PC?
    What happens when you remove the user from the Administrators group?

    Is the share located on a DFS share?


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: Let's go, use GPO!

    Wednesday, August 22, 2012 4:17 PM
  • I can confirm this is only a problem when UAC is enabled and you are local admin on the computer.

    In any other case this works with reconnect.


    -- G Johansson http://gjohansson.com/blog/

    Thursday, August 23, 2012 7:36 AM
  • Oh my.  The drive maps do work if the user is not an Administrator.  It is troubling to see that there has been discussion about this issue since June and Microsoft did not bother to fix it in the RTM.

    In regards to the other question:  Some of the drives map to DFS shares and others do not.  They all fail to map.

    I must also correct my original post.  Even though I have UAC set to "Never Notify", it appears to be on in some fashion as programs still open in Medium integrity level.

    Thursday, August 23, 2012 12:33 PM
  • Oh my.  The drive maps do work if the user is not an Administrator.  It is troubling to see that there has been discussion about this issue since June and Microsoft did not bother to fix it in the RTM.

    Windows 8: Enterprise Ready!
    Thursday, August 23, 2012 5:30 PM
  • I was using a VM for Windows 8, no mapped network drives.  I then installed it on a laptop, still no network drives.   Then I read these posts. 

    I can confirm logging in as a generic user, I get all my mapped network drives.   I'm a little happier, but very strange behavior.

    A feature of the preview version of Windows 8?

    Friday, August 24, 2012 3:34 PM
  • Hi,

    Thanks for sharing your experience with us, you help other community members who facing similar problems.

    We can’t mark first posting as “Answer”, so I marked you second posing as “Answer”.

    Thanks for your contribution for the forum.

    Have a nice day.


    Lawrence

    TechNet Community Support

    Wednesday, August 29, 2012 2:31 AM
    Moderator
  • As a side-effect to unchecking "reconnect" for the GPP, the mapped drives will not get connected if the network is unavailable during Group Policy application.  For instance, home users who are connecting via DirectAccess.  I've seen a few times now where I have zero drives mapped.  However, if I do a gpupdate /force after logging in, I do see the drives after logging off and logging on again.

    Wednesday, September 05, 2012 4:17 AM
  • Same here: I need to use the "reconnect" options and disabling it is causing more trouble than anything else, especially with laptops. Microsoft, could you fix this please?

    Thanks.


    Benjilafouine

    Wednesday, September 26, 2012 2:17 PM
  • Yes unchecking reconnect is not a great option for me as I need the drives to be persistent. Most of my user are on laptops and use vpn a lot.
    Wednesday, October 17, 2012 3:28 PM
  • When you log in away from the domain you use cached credentials and from my experience the drives are still reconnected. Attempted anyway.
    Friday, October 19, 2012 1:37 AM
  • For DirectAccess or VPN users, try enabling the policy at Computer Configuration\Policies\Administrative Templates\System\Logon\Always wait for the network at computer startup and logon. That forces synchronous forces GP processing all the time. The reason your drives mappings don't run straightaway is that GPP Drive Maps need to run synchronously. Enabling that policy *should* solve the problem.

    Darren


    Darren Mar-Elia MS-MVP, Group Policy
    www.gpoguy.com
    www.sdmsoftware.com - "The Group Policy Experts"

    Friday, October 19, 2012 2:17 AM
  • Same problem.... The description fixed the situation for us at the moment. Hopefully there is a coming a really hotfix if we migrate more PC to Windows 8...

    regards, Reisenhofer Andreas

    Friday, November 02, 2012 1:59 PM
  • Microsoft has been aware of this issue for over 2 months and hasn't commented on it. I don't see it getting fixed any time soon.
    Friday, November 02, 2012 4:13 PM
  • The answer is to do the following:

    Set explorer windows to open in a new process.

    Do this by:

    1. Open windows explorer.

    2. Click View tab, click Options (right hand side of ribbon)

    3. Click View tab in options window

    4. Scroll down in the "Advanced settings" area and check "Launch folder windows in a separate process"

    5. Click Apply. Then click Apply to Folders.

    Close your explorer window(s), then reopen and you should see your mapped drives. (unless you opted for the "un-check reconnect option" previously mentioned --- go re-check that!)

    The reason this is happening is because, when group policies are applied to the user account, if the user has admin privileges (ie: they are a member of some domain admin group and/or they are a member of the local administrators group) the group polices are applied with administrative privileges.

    So, when you log in, open an explorer window and you see no mapped drives, this is because by default, windows explorer does not run/open with admin privileges. Thus, you do not see any mapped drives. So, the "fix" (if you will) is to always open explorer windows with your user's admin privileges. (Launching in a separate process will do this.)

    So, I believe it is working by design. One of the problems is that it's not documented. Also, it used to work in all previous windows versions. :)

    Maybe Microsoft will patch it, I don't know.

    For the record, un-checking the "Reconnect" option in the group policy mapped drive settings is NOT a good option. The reason I say this is because if you start your laptop unconnected to your network, you're drives will not show up AND if you use offline files, you have to do some fancy searching to find them.

    Spread the news.



    • Edited by Bee Ray Tuesday, November 06, 2012 7:16 PM
    • Proposed as answer by orbitaladmin Tuesday, December 11, 2012 12:24 AM
    Tuesday, November 06, 2012 7:12 PM
  •  
    > The reason this is happening is because, when group policies are
    > applied to the user account, if the user has admin privileges (ie:
    > they are a member of some domain admin group and/or they are a member
    > of the local administrators group) the group polices are applied with
    > administrative privileges.
     
    IF that really is the reason, setting EnableLinkedConnections should fix
    it immediately, and it should happen everywhere. In my lab, it works
    flawlessly, and I believe lots of us admins have EnableLinkedConnections
    set...
     
    Anyway, you're right in that GPP gets applied with the full user token.
     
    regards, Martin
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Tuesday, November 06, 2012 8:21 PM
  • Martin, I agree with you, EnableLinkedConnections should solve the issue here.

    However, on my Windows 8 Pro x64 RTM (fully patched) machines it does not.

    The only way I get GPO mapped drives to show is by doing what I mentioned earlier (open explorer windows in a new process).

    So, are you saying that you can simply set EnableLinkedConnections = 1 in the registry and your Windows 8 machines show GPO mapped drives when the user is an admin?

    Thanks for the reply.

    Wednesday, November 07, 2012 3:43 PM

  • So, are you saying that you can simply set EnableLinkedConnections = 1 in the registry and your Windows 8 machines show GPO mapped drives when the user is an admin?

    I didn't even do that in my lab - it just worked. I have no clue why it sometimes works, sometimes not... But I agree with you and everybody else: Something is screwed up in Drive Maps...

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Wednesday, November 07, 2012 8:02 PM
  • Uh - where does one vote to say "are you kidding" that MS didn't figure this one out?  GP what?  What's that?  Who uses that anyway....
    Monday, November 19, 2012 3:13 PM
  • I can't believe this is still and issue.

    Seriously.

    I have just spent 1 hour reading people who have the exact same issue, mine is SBS 2011 with Windows 8 and no drive maps being applied via Group Policy.

    Thank goodness I am not alone.

    #frustrated

    Thursday, November 22, 2012 4:51 AM
  • I can confirm we have encountered the same issue. We recently purchased new computers with Windows 8 Pro, mostly because we were unable to find the best value equipment unless we moved to Windows 8. We thought we would eventually be forced since the MS downgrade to Win7 looked troublesome and not available for all manufacturers.

    When the new Win 8 pc is added to the domain as a local Admin account, the GPO drive Mappings are not present.  If we change the user to a Standard User, then restart, the pc does display the Network Drive Mappings.

    If Microsoft is expecting users to move to Windows 8, they had better address the important issues quickly, or expect sales to decline. We are re-evaluating the the OS choice for our workstations on our Domains.

    Tuesday, November 27, 2012 5:54 AM
  • Same here, SBS 2011 and mapped drives on our first Windows 8 Ultrabook / Hybrid device with the user as local admin.

    So, I took the last 30 minutes to root around my office-wide common mapping GPO, I'm not about to take off the reconnect switch. What's the common concensus, push EnableLinkedConnections or "Launch folder windows in a separate process" registry settings through the same GPO? Something else? I don't see a MS fix happening, since this seems to be desired behavior, however, I too would like to see better documentation of the actual change from how Win 7 did it.

    this is going to be a real pain when I have entire sales depts. requesting these "neat" laptops and I have to remember to manually edit these settings - that's so 1998.


    Jae

    Tuesday, December 11, 2012 12:24 AM
  • Hi all

    I just wanted to let you know that i have been running a case with Microsoft for the past 20 days and yesterday i finally got the answer i wanted.

    Here is what Microsoft support wrote:

    Unfortunately we have found a BUG and it will be fixed as soon as possible.
    Windows SE 419875 (ETA for fix is 12th February 2012)


    Regards,
    Thomas

    • Proposed as answer by Tjay42 Wednesday, December 19, 2012 7:35 AM
    Wednesday, December 19, 2012 7:34 AM
  • Here is what Microsoft support wrote:

    Unfortunately we have found a BUG and it will be fixed as soon as possible.

    That would be great, but I still do not believe this
    as long I don't see that with my own eyes :-)


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: Let's go, use GPO!


    Wednesday, December 19, 2012 8:24 AM
  • Lets hope you see it in February at some point :-)
    Wednesday, December 19, 2012 8:35 AM
  • So your post should have been

    Windows SE 419875 (ETA for fix is 12th February 2013)

    ?


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: Let's go, use GPO!

    Wednesday, December 19, 2012 8:43 AM
  • Yeah i'm pretty sure that's a typo.
    Wednesday, December 19, 2012 8:50 AM
  • Hi Thomas

    It's the 12th February here in Australia, can you please let us know if the 419875 bug fix has been released in your location? (assume the US will be a day behind for us here)

    We are experiencing the same problems with mapped drives on Windows 8 devices and would prefer to wait for the Microsoft fix to sort the issue out rather than working on workarounds.

    Regards,

    Adam.

    Tuesday, February 12, 2013 1:28 AM
  • Hi Adam,

    I just wrote to the Microsoft supporter if he have any new information regarding this hotfix. When i have something new or the hotfix i will post it here asap.

    Regards
    Thomas

    Tuesday, February 12, 2013 7:34 AM
  • Thanks for keeping us updated, Thomas. I assume that I'm one of many who are watching this or your other two threads. They are the only hope seen anywhere of a fix for a blatantly obvious issue (identified long ago by beta users) with Windows 8. I'll keep my fingers crossed again next Tuesday.
    Tuesday, February 12, 2013 4:47 PM
  • http://support.microsoft.com/kb/2795944

    Seems as it solved it for me but I haven't yet been able to confirm in full but my mappings stays put now even after changing and disconnecting from corp network. I can see they are persistent so looks promising...

    gpprefcl.dll is replaced by that KB (but of course no mention about fixing this problem on the kb page)...


    -- G Johansson
    http://gjohansson.com/blog
    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    • Proposed as answer by Tjay42 Wednesday, February 13, 2013 9:40 AM
    Tuesday, February 12, 2013 9:31 PM
  • That sounds interesting and i will test that update tomorrow. I still haven't got any official answer from Microsoft support.

    Tuesday, February 12, 2013 9:48 PM
  • I can confirm that updating to the latest update in Windows Update fixes the issue. Still waiting for official answer from Microsoft support.
    Wednesday, February 13, 2013 9:40 AM
  • Hello Thomas

    I have just installed the update on my desktop but this doesn't seem to have fixed the issue. The 2 mapping are correctly appearing if I run "Net use" in a command prompt run as administrator, but aren't appearing in the Explorer. Is there any other configuration needed on the desktop?

    Thanks in advance

    Yann

    Wednesday, February 13, 2013 10:44 AM
  • Finally there is an Update...

    nice!!!!

    Thank you for the info.


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: Let's go, use GPO!

    Wednesday, February 13, 2013 11:01 AM
  • Hi Yann,

    You should just install all the updates from Microsoft and if your GPO drive mapping is configured correctly it should work.

    Regards
    Thomas

    Wednesday, February 13, 2013 12:19 PM
  • This fixes it for me.  Thanks to those who forced the issue by opening support cases with MS.
    Wednesday, February 13, 2013 1:42 PM
  • Hello Thomas

    I have just installed the update on my desktop but this doesn't seem to have fixed the issue. The 2 mapping are correctly appearing if I run "Net use" in a command prompt run as administrator, but aren't appearing in the Explorer. Is there any other configuration needed on the desktop?

    Thanks in advance

    Yann

    I have the exact same problem as you Yann even after the update.  Our GPO drive mapping has worked flawlessly for years on both XP and Windows 7.  Works fine on Windows 8 too as long as it is not an administrator logging in.  If I run a "Net use" statement in a command prompt run as administrator, I can see the drives and access them through the command prompt without issue but they do not appear in explorer.  

    Trevor

    Wednesday, February 13, 2013 3:55 PM
  • Hi All

    Just confirming, performing Windows updates worked for us. As Thomas mentioned, make sure your GPO drive mapping settings has the 'reconnect' option ticked, we had it unticked as part of the workaround, which failed after the updates were applied. Ticking reconnect fixed it for us after the update was applied.

    Glad the solution has been found!

    Regards,

    Adam.

    Thursday, February 14, 2013 12:52 AM
  • Hi all,

    After the last updates from February 2013 it seems to work for us. So the hotfix is installed through normal Windows Update / WSUS.

    All network drives appear in explorer. However, after login every user see a "network drives not available" message, but the network drives are available through explorer. I don't know, but maybe we have wrong GPO network drive settings? Do you activate "Run in logged-on user's security context (user policy option)"?

    ...or is that error message something other?


    regards, Reisenhofer Andreas

    Thursday, February 14, 2013 10:40 AM
  • This is huge I haven't been able to upgrade or recommend windows 8 at the office.  This will allow me to start a limited deployment and order a few new machines people wanted!

    Thursday, February 14, 2013 7:18 PM
  • Hello Thomas

    You are right. It was just missing the "Reconnect" parameter. With it, it works perfectly.

    Thanks for your help

    Best regards

    Yann

    Monday, February 18, 2013 3:07 PM
  • The update worked.  However, Windows Update did not see it as being required, so I had to download it manually and install.
    Tuesday, May 21, 2013 9:15 PM
  • Bee Ray,

    You're my hero!

    I've struggled all day with GPO on a Windows 8.1 workstation that i run with a domain account user.

    Now it works perfectly!

    Many thanks from a IT administrator in Paris, France ;-)

    Wednesday, November 13, 2013 5:36 PM