none
Workgroup machines printing to domain print server

    Question

  • I posted this thread a while back, but somehow it got marked read-only.

    http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/310d9888-120d-49cf-b32a-b7b12a63e1df/?prof=required

    I need to have machines in a workgroup be able to authenticate to a domain file server and a print server using AD accounts.

    Anyways, I wrote a visual basic application that runs a net use command, i.e. net use \\servername /user:domain\username password basically. It runs two of these commands, the first to the file server, and second to the print server.

    The variables are being passed correctly, and it allows students to authenticate to our servers without even mapping a drive letter. It works 100% on Windows XP.

    Here is the issue... On windows 7 about 20-30% of the time this fails. The net use command returns error 1219, which is a multiple connections error. The server security event logs show a login attempt from the machine with the local account instead of the domain account. I am 100% positive the variables are being passed right, AND the net use command is passing the correct syntax.


    Any thoughts on why this is happening or a better way to authenticate?

    Tuesday, September 21, 2010 8:01 PM

Answers

  • Hi,

     

    According to the description of Event 1219, I suggest you add a command in your script to disconnect the previous connection(s) to the server first. Then use the command to connect the server with proper credential. You may use the command net use /delete.

     

    Hope it helps.

     

    Regards,

    Bruce

    • Marked as answer by Bruce-Liu Wednesday, September 29, 2010 1:22 PM
    Friday, September 24, 2010 8:36 AM