none
undetect USB Drive on Windows 2008 R2 Server

    Question

  • Dear ,

    I was attached the Ext. USB 2.0-300GB Drive long time ago. It is functionable e: letter before.

    Nowaday, I find that this USB Drive no longer exist,

    1- Disk Management CANNOT detect this USB. so, this NO conflict letter drive problem.!

    2- I tested the H/W all USB Ports, both workable. so, NO H/W ports failure problem.!

    3 - I tested this USB 2.0 HDD already., I attach it to a WIN7 PC. the USB is work. so, NO H/W USB HDD failure problem.!

    4- I checked the Win08R2 registry, HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\usbstor , it Dword is "3" already.

    and I do the following Steps still NOT work:

    5. I reboot the Server so many time and detect in Device manager again and again, NO Work!

    6. I try uninstall ALL the USB Universal Host Controller already , and reboot. It auto re-install the Host Ctrl Drive again. I find this no work. It still undect my USB drive.

    What can i do now?


    GERMAN LAM @HK

    Monday, November 19, 2012 5:12 AM

Answers

All replies

  • Hi,

    Try below link.

    http://support.microsoft.com/kb/817900

    OR

    Fixing  external USB drives
    The same sort of damage, or interference, can also happen with external USB drives. The solution is to delete the damaged or malformed keys and allow the devices to be redetected normally. Here are the steps to follow:

    1. Open the Registry on the offending computer and navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E980-E325-11CE-BFC1-08002BE10318}.

    2. Delete any values with the name UpperFilters or LowerFilters within this key.

    3. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}.

    Regards,


    MD


    Monday, November 19, 2012 7:30 AM
  • Dear Mubasshir Dadarkar,.

    Ugrent, after I edited these registry, and reboot, It cannot reboot again!!!! HELP!!!!!

    I found that  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E980-E325-11CE-BFC1-08002BE10318}. NO any UpperFilters and LowerFilter items. I ingore this.

    and,

    I found that HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}. has the UpperFilters Values only, I delete the Value in side the UpperFilters.

    Then, I reboot, I cannot normal start now?

    How can I recover it at the Windows Boot up Recover Mode? and change back the registry at this mode?


    GERMAN LAM @HK

    Tuesday, November 20, 2012 3:49 AM
  • Dear German,

    You always take a backup of registry before editing.

    Note: You have to delete the "UpperFilters" String not the value of "UpperFilters"

    =================

    Start your server in safe mode and re-create "UpperFilters" string and enter the correct value, it will fix your booting issue.

    If you need any further help, let me know.

    Regards,


    MD


    Tuesday, November 20, 2012 6:23 AM
  • Dear Mubasshir Dadarkar,

    I still problem aR!!! I following the proceduers:

    Boot -> F8 (BOOT OPTION)

    1. Safe mode,

    2. Safe mode (with Network),

    3. Safe mode (Command Prompt),

    Both 1,2,3 option I try many times, it still loading error "bfad_up.sys", and the Hard reboot again .....

    What can I do now?


    GERMAN LAM @HK

    Tuesday, November 20, 2012 6:52 AM
  • futher,

    after F8(on boot option), it just suggest "Recovery System..." it auto jump to the Recovery Command Prompt only"

    What can I do at the Recovery Mode too?


    GERMAN LAM @HK

    Tuesday, November 20, 2012 6:56 AM
  • Hi German,

    We don’t need to reboot the server after editing in registry.

    You did following mistakes:

    1. Not taken registry backup before editing
    2. Reboot Server after editing (which not required 98%)

    After editing in registry, did you connect your hard disk to the server?

    ++++++++++++++++++++++++++++++++++++++++

    refer below link

    http://support.microsoft.com/kb/326215?wa=wsignin1.0

    Please let me know if you have any further issues.

    Regards,


    MD


    Tuesday, November 20, 2012 8:12 AM
  • Hi Mubasshir Dadarkar,

    I have recovered the system now. it OK now.!

    However, I just finished boot up recovery. And, I haven't try the USB Registry editing.

    OK. thank for you reminder:

    - I NO NEED reboot the server.

    But, I have 2 question:

    1. How can I backup the registry before editing? Where I should save the hive file? and which location (Store path) should easy recover the hive when the problem occur again?

    2.  You say no need to reboot>? right? if i after edit, i Just attach the USB to the Server is ok? How long to be safe the reboot the server again?



    GERMAN LAM @HK

    Tuesday, November 20, 2012 1:59 PM
  • Hi German,

    It is a great news that your system has been recovered sucessfully.

    Answer:

    1. Click on File =} Export and save the registry (refer below image)

    2. You don't need to restart the server till next updates release by Microsoft (one month).

    Regards,


    MD

    Wednesday, November 21, 2012 7:47 AM
  • Dear MUbasshir,

    I have try again to do the registry again (No boot this time). but still cannot detect the USB too.

    What can I do right now?


    GERMAN LAM @HK

    Monday, December 10, 2012 7:46 AM
  • Hi,

    Please remove safely attached USBs.

    **********Please double check in your registry may be you are missing something. please follow the above steps again.

    Regards


    MD

    Wednesday, December 12, 2012 6:16 AM