none
Disabling the Initalize Disk prompt in disk management

    Question

  • Hi,

    I'm in the process of setting up a new 2008 R2 server (standard edition) server, which is replacing an existing 2003 backup server.

    The 2008 server will be connected to our FC SAN, of which the SAN hosts a number of VMFS luns. 

    Some years back, when I installed the 2003 server, I had to disable the drive automounter functionality in order to prevent the 2003 server from attempting to mount the VMFS volumes (as ntfs). Having originally dealt with the feature back then, I was aware to keep an eye out for it with this new 2008 server. I have tried disabling the automounter as per this FAQ;

        <http://social.technet.microsoft.com/Forums/en-US/winserverfiles/thread/98ff4526-e0e7-4e91-9412-c407cd958d84>

    Alas each time the server reboots, and I open disk management, I receive a prompt "you must initalize a disk...". My fear is some day down the line, someone is not going to remember about that prompt, and will hit that OK button (nerfing my VMFS volumes).

    Can anyone advise is there a means to disabling this automatic prompt from appearing.

    Many thanks for your time and assistance,

    PD

    For reference the settings on the server are as follows; 

    (the server is running all of the latest SPs and patches as of today)

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoActiveDesktop"=dword:00000001
    "NoActiveDesktopChanges"=dword:00000001
    "ForceActiveDesktopOn"=dword:00000000
    "ShowSuperHidden"=dword:00000001
    "NoDriveTypeAutoRun"=dword:000000ff
    "NoAutorun"=dword:00000001
    "DontSetAutoplayCheckbox"=dword:00000001

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\mountmgr]
    "DisplayName"="@%SystemRoot%\\system32\\drivers\\mountmgr.sys,-100"
    "Group"="System Bus Extender"
    "ImagePath"=hex(2):53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,64,00,\
      72,00,69,00,76,00,65,00,72,00,73,00,5c,00,6d,00,6f,00,75,00,6e,00,74,00,6d,\
      00,67,00,72,00,2e,00,73,00,79,00,73,00,00,00
    "Description"="@%SystemRoot%\\system32\\drivers\\mountmgr.sys,-101"
    "ErrorControl"=dword:00000003
    "Start"=dword:00000000
    "Type"=dword:00000001
    "NoAutoMount"=dword:00000001

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\mountmgr\Enum]
    "0"="Root\\LEGACY_MOUNTMGR\\0000"
    "Count"=dword:00000001
    "NextInstance"=dword:00000001

    Friday, March 23, 2012 3:46 PM

All replies

  •  

    It seems this kind of prompt cannot be disabled. I rried to search for a solution but no result.

    Tuesday, March 27, 2012 9:23 AM
    Moderator
  • can you change your san policy? this would make sure disk is offline and this pop-up will never appear,

    diskpart> SAN POLICY=OfflineAll

    Do let me know if it helps,

    Regards

    Satish

    Friday, March 30, 2012 1:15 PM
  • Hi,

    Thanks all for the feedback!

    Satish: I did set this "SAN POLICY" setting to Offline All as one of my first attemps to rectify the prompt. Unfortunately this doesn't clear the prompt.

    This setting is coded somewhere deep in the depths of the registry, me thinks.

    I'm assuming that there's a registry fix somewhere for this, as I recall back to when I had this promblem with WIN2003, MS support did tweak settings on my server to prevent this prompt from appearing.

    Any suggestions would be welcome, as I really don't want this persistent risk that someday someone will hit the OK prompt and nerf my SAN

    Monday, April 02, 2012 10:10 AM