none
SBS 2008 Remote Web - Connect to a computer, but none are available

    Question

  • After deploying SBS 2008, we have been unable to get Remote Web to allow RDP connections to the desktops for end users.
    The admin account that was created has access to control all machines, but the end user accounts do not.  We have granted
    them membership into the Windows SBS Remote Web Workplace Users group, as well as the Link users.
    The error that is seen on the RWW session states under "Connect to a Computer" is "No computers are available".
    Any help in this would be much appreciated since this functionality has been lost since changing to 2008 from 2003.
    Friday, January 02, 2009 2:43 PM

Answers

  •  

    Hi,

     

    As this issue is related to Small Business Server, I suggest discussing it in our Small Business Server newsgroup.

     

    http://www.microsoft.com/smallbusiness/community/newsgroups/dgbrowser/default.mspx?dg=microsoft.public.backoffice.smallbiz&lang=en&cr=US&r=627fae54-a95e-45ba-b054-e423964b47fa

     

    I hope your issue can be resolved soon.

     

    Tim Quan - MSFT

    Monday, January 05, 2009 2:57 AM
    Moderator
  • oops - sorry about that, I thought you were replying to a post I made about Active Directory MMC not working.
    For your issue, yes the resolution is in another area, in another POST.  Apparently some members feel that this is not "Deployment Related" so here is the answer.

    Your computers that need to be available in Remote Web workplace need to have the SBS "Wizard" ran on them.
    You either need to be logged in as administrator, or as the current user, will need to save the file and run as administrator.
    Choose START, Run, and type in http://connect - this will direct your web browser to the SBS "Wizard".
    You should choose the link that opens the "Launcher" executable and will allow you to either Run, or Save.
    Make the appropriate decision depending on rights.  This Launcher wizard will take you through some settings that
    need to be set for RWW to work.  You will have to choose which users have remote access to that particular computer.

    Let me know if you are unable to figure it out after this.

    Justin
    • Marked as answer by JustinEdward Wednesday, January 14, 2009 6:22 PM
    Wednesday, January 14, 2009 6:22 PM

All replies

  •  

    Hi,

     

    As this issue is related to Small Business Server, I suggest discussing it in our Small Business Server newsgroup.

     

    http://www.microsoft.com/smallbusiness/community/newsgroups/dgbrowser/default.mspx?dg=microsoft.public.backoffice.smallbiz&lang=en&cr=US&r=627fae54-a95e-45ba-b054-e423964b47fa

     

    I hope your issue can be resolved soon.

     

    Tim Quan - MSFT

    Monday, January 05, 2009 2:57 AM
    Moderator
  • Justin -  Were you able to get this resolved? I have the same problem after a virgin install of SBS 2008. My regular users are unable to see the remote computer over the web interface but my admin users are fine. Seems like a group policy problem...

    Please let me know.

    Thanks

    Steven
    Tuesday, January 13, 2009 10:34 PM
  • oops - sorry about that, I thought you were replying to a post I made about Active Directory MMC not working.
    For your issue, yes the resolution is in another area, in another POST.  Apparently some members feel that this is not "Deployment Related" so here is the answer.

    Your computers that need to be available in Remote Web workplace need to have the SBS "Wizard" ran on them.
    You either need to be logged in as administrator, or as the current user, will need to save the file and run as administrator.
    Choose START, Run, and type in http://connect - this will direct your web browser to the SBS "Wizard".
    You should choose the link that opens the "Launcher" executable and will allow you to either Run, or Save.
    Make the appropriate decision depending on rights.  This Launcher wizard will take you through some settings that
    need to be set for RWW to work.  You will have to choose which users have remote access to that particular computer.

    Let me know if you are unable to figure it out after this.

    Justin
    • Marked as answer by JustinEdward Wednesday, January 14, 2009 6:22 PM
    Wednesday, January 14, 2009 6:22 PM
  • What if the user lives out of state and he needs to connect to a computer at the office in another state, an office he's never been to. In other words he's on a laptop and he goes to https://mail.domainname.com for the first time and there isn't any computers showing up in the "Connect to a Computer" window. How do I run http://connect or make it where he can view computers?

    What do I do now?
    Wednesday, November 25, 2009 7:16 PM
  • The computer has to be connected to the domain controller using this connect method, and as the user that needs remote access.
    The only other option for you that might work would be to modify the hosts, and lmhosts file to see if you can contact the server
    just as you were onsite.  Then run the connect wizard, and this should show up as an available computer.

    Good luck!
    Wednesday, November 25, 2009 7:19 PM
  • Actually the problem is because the user doesn't show up in the Windows SBS Console under Users. When the server was setup I added some users straight from Active Directory and didn't go threw the "add New User Account" in the Windows SBS Console, users that are not showing in the Windows SBS Console but that are in Active Directory cannot see computer accounts.

    How do I get users in Active Directory to show up in the Windows SBS Console?
    Wednesday, November 25, 2009 7:42 PM
  • You need to add the users by clicking on Users and Groups and tehn on the right click on Change user role for user accounts.  Then click on Add user permissions or it gets hosed up and make sure you give them the right access and then Display all user accounts in the Active Directory.


    ToddSWagner
    Tuesday, December 01, 2009 7:35 PM
  • After searching for an hour or more I found this post.  The links above do not work, so I hope you keep reading to see the posting above mine is the correct answer

    The problem lies with us old school network admins.

    we were trained to use the active directory user & computers plugin, and I have never been a big fan of wizards, so I do everythign I can granularly.  In this case it bit me.

    If you have already added the user, this is how you give them access to your remote computer, or add them to the SBS for any other reason you might need.

    1. Open Windows SBS Console
    2. Users and Groups Tab
    3. Change "User Role for User Accounts"
    4. Selct the role to assign (mine is remote user)
    5. click circle - add user permissions or settings - next
    6. check box "Display all user accounts in Active Directory"
    7. select account
    8. click add button
    9. click "Change USer Role"

     

    Monday, September 19, 2011 1:55 PM