none
Trouble with assigning a static IPv6 address

    Question

  • Hello,

     

    I'm trying to assign a static IPv6 address by going to Netowrk Connections/Local Area Connection Properties/Internet Protocol Version 6 (TCP/IP) Properties.

     

    I select the "Use the following IPv6 address" radio button, enter my IPv6 address of choice, click enter, then close. I am prompted to reboot. After rebooting, if I return to the Internet Protocol Version 6 (TCP/IP) Properties, the "Obtain an IPv6 address automatically" radio button is selected instead of what I previously configured.

     

    Ipconfig /all  shows me that the IPv6 address I want is assigned to my NIC and it's even followed by "(preffered)". But Server 2008 doesn't seem to want to statically apply the address and this is causing me problems when running dcpromo. I get an error message that I must have static IPv4 and IPv6 addresses.

     

    I'm not having any problems with configuring a static IPv4 address, just IPv6.

     

    Please help!

    Tuesday, July 17, 2007 3:48 PM

Answers

  • Can you share details about which build you are experience this with?

     

    In speaking with the engineering team, they have asked for you to run the following command and share the output:

     

    netsh interface ipv6 sh add store=persistent

    Wednesday, July 18, 2007 8:51 PM

All replies

  • If you don't need IPv6 you can just uncheck the box in the LAN-connection properties.

    Wednesday, July 18, 2007 10:15 AM
  • Can you share details about which build you are experience this with?

     

    In speaking with the engineering team, they have asked for you to run the following command and share the output:

     

    netsh interface ipv6 sh add store=persistent

    Wednesday, July 18, 2007 8:51 PM
  • I went ahead and tested the issue on Windows Longhorn Enterprise Build 6001.  Here is how to dupicate...

     

    #1 - ipconfig /all (locate the Ethernet Adapter Local Area Network) and find the link-local IPv6 address (fe80::....)

    #2 - Open the Local Area Network properties and click configure for IPv6

    #3 - Change the radio button from obtain IPv6 automatically to Use the following IPv6 address

    #4 - Enter the link-local IPv6 address from above.

     

    The server prompts for a reboot... after the reboot the selection goes back to obtain an ipv6 automatically.

     

    I tried the netsh interface ipv6 sh add store=persistent and after the reboot same thing happened.  Went back to auto..

     

    I think the real question lies in that I have searched everywhere on the net on how to setup DHCP for a IPv6 domain controller.  After a fresh install of Server 2008 if you promote to a DC the server prompts you to enter a static address.  Entering the static address of the link-local given IPv6 does not work... However if you change that to anything other than the link-local address then the IPv6 entered value will stay.

     

    If anyone could point to a setup for IPv6 (DHCP) that would be great.

     

    Thanks

    Chris

    Thursday, August 23, 2007 12:05 AM
  • I have the same problem, so an answer would be appresiated.
    Sunday, June 24, 2012 5:31 PM