locked
BOOTMGR image corrupt. The system cannot boot.

    Question

  • Hi all

    I have a bunch of HP DX2200 MT machines.  The processor is Intel Pentium 4 HT (with hyperthreading technology). 

    I was previously using WDS on a Windows 2003 SP2 server to manage my images.  All the models of machines that I stock have been fine up to now, but I get the above error on all of the machines of this model.

    My machine is being detected as x64 architecture by the WDS server, and I could see that it was using boot\x64\pxeboot.com to boot.  I have read several threads and tech documents which have advised forcing it to boot with boot\x86\pxeboot.com and also setting the command "wdsutil /set-server /architecturediscovery:yes", so I changed to this, but to no avail.  I even tried switching off the HT tech in the BIOS, but this hasn't helped either.

    I looked at the WDS set up, and it looked like some files were missing (although pxeboot & bootmgr were there), so I decided to set up a machine with Windows Server 2008 and set up the WDS role on it and start from scratch.

    I added all the necessary boot images from the Windows Vista DVDs, a 32 Bit version and 64 Bit version and re-directed my DHCP settings to the new server.  Again, the same error.  Again, I tried to force the machine to use boot\x86\pxeboot.com, but to no avail.

    I can see in the event viewer for WDS on the Windows 2008 server that it is trying to download boot\x86\bootmgr.exe, so cannot see why it won't work with either boot\x86\bootmgr.exe or boot\x64\bootmgr.exe. 

    I'm at a bit of a loss now.  I have 20 of these machines and they all need imaging.  It would be terribly time consuming to have to do that manually....

    Does anybody out there have any idea as to what I can do to resolve this?

    Kind Regards
    Lorna
    Monday, March 01, 2010 5:45 PM

Answers

  • Hi there Tim

    Thanks for responding to me.  I had already gone through the technet stuff.  I have however fixed the issue.  I simply flashed the bios on the machine and it now works a treat!

    cheers
    Lorna
    Tuesday, March 02, 2010 1:52 PM

All replies