none
Configuring 2012 Web Access server to use 2008 R2 Session Host farm

    Question

  • I was wondering if anyone knows how to configure my 2012 RDS implementation to point to my 2008 R2 Session Host farm?  I have populated the TS Web Access Security Group with the name of my web server on each of my Session Host servers.  In the 2008 R2 Web Access configuration, I had an additional tab if I logged in with admin credentials that would allow me to point to my Session Host farm.  Where is that in Server 2012 configuration?

    Thanks! Nate

    Thursday, October 04, 2012 4:11 PM

Answers

  • Hi Nate,

    On your Server 2012 RDWA server, please open IIS Manager.  In the left pane browse to and select Sites\Default Web Site\RDWeb.  In the middle pane double-click Application Settings.  Double-click on ws08r2rdserver and enter your 2008 R2 farm or server name.  Separate multiple names with semicolons.  Please note this setting is only for your 2008 R2 server(s).

    After making the above change please log on to your Server 2012 RDWeb site and test to make sure your 2008R2 and 2012 RemoteApps are working properly.

    Thanks.

    -TP

    Tuesday, October 09, 2012 3:04 AM

All replies

  • Hi,

    Thanks for your post.

    Please note that the architecture of RDS was changed between Windows Server 2012 and Windows Server 2008 R2. You can have both separated infrastructures of RDS, but we cannot mix both into one. So we cannot point Windows Server 2012 RDS component to use Server 2008 Session Host Server.  In order to taking advantage of these new features and benefits, you need to deployment a native RDS 2012 environment. With the new RDS infrastructure, any server joined must be running at least Windows Server 2012.

    Best Regards,

    Aiden

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Aiden Cao

    TechNet Community Support

    Friday, October 05, 2012 2:34 AM
  • Hi,

    How are things going? I just want to check if the information provided was helpful. If there is any update or concern, please feel free to let us know.

    Best Regards,
    Aiden

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Aiden Cao

    TechNet Community Support

    Tuesday, October 09, 2012 2:23 AM
  • Hi Nate,

    On your Server 2012 RDWA server, please open IIS Manager.  In the left pane browse to and select Sites\Default Web Site\RDWeb.  In the middle pane double-click Application Settings.  Double-click on ws08r2rdserver and enter your 2008 R2 farm or server name.  Separate multiple names with semicolons.  Please note this setting is only for your 2008 R2 server(s).

    After making the above change please log on to your Server 2012 RDWeb site and test to make sure your 2008R2 and 2012 RemoteApps are working properly.

    Thanks.

    -TP

    Tuesday, October 09, 2012 3:04 AM
  • Hi,

    Just wanted to add to this that we've used ws08r2rdserver since 2012 was released, and we have about 15 different servers added separated with semicolons. For each host we add, the login time for the rdweb interface is getting slower and slower. Right now it takes about seconds to log in. If we remove them all from that key, the login is immediately.

    None of the added servers are unreachable.

    Any suggestions on why this is or how to fix it?

    Friday, January 18, 2013 8:28 PM