none
Blank Desktop Icons in Windows 8

    Question

  • I posted this in the Microsoft Windows 8 forum and was directed to post here instead.

    We did look for answers before posting, but our specific issue is different than what others have had regarding "blank icons."

    After updating our workstations to Windows 8, icons located on a network drive (e.g., in the "W:\ICONS" folder, where drive W is mapped to a shared folder on a server) are displayed as a blank document-- a solid white rectangle with the upper right corner folded down.

    However, icons located on the workstations' local C drives are displayed correctly-- and if we copy the icons from the server to the workstation they display correctly.

    If we go to the shortcut properties and click "change icon," the correct location on the mapped network drive is already listed and the desired icon is already displayed and selected in the window, but re-selecting the icon and applying the change does nothing-- the desktop shortcut still displays with a "blank document" icon.

    We've tried the suggested solution of turning off Windows Explorer, deleting the local icon cache, and rebooting to force Windows to rebuild the icon cache, but it doesn't help either.

    The desktop shortcuts work just fine, they are just not displayed with the desired icons.

    By the way, the servers are running Windows Server 2008 R2 (if that matters).
    Tuesday, December 11, 2012 6:51 PM

All replies

  • I suggest you run sfc/scannow command and it will repair the system files automatically when its have problem with it.

    Details of sfc/scannow command is scans integrity of all protected system files and repairs files with problems when possible.Run sfc /? command to know more options of sfc command.


    Regards, Ravikumar P

    Wednesday, December 12, 2012 3:29 AM
  • Logon the Windows 2008 R2 server, check if the shortcut icons display correctly on it? As Ravikumar suggested, run sfc /scannow on the server as well.
    Wednesday, December 12, 2012 5:22 AM
    Moderator
  • sfc did not find any problems.

    I do not think this is a problem with the icons themselves-- they display correctly in Windows 7, and they display correctly on the server. They even display correctly in Windows 8, just not on the desktop.

    If I browse to the icons' location on the server in Windows Explorer (from the Windows 8 workstations), Windows Explorer displays them correctly. If I display the shortcut properties and say I want to change the icon, the icon displays correctly and is already selected. If I copy the icon file from the server to the local C drive and change the shortcut so it loads the icon from the C drive instead of the server, it displays correctly on the desktop. It just will not display on the desktop if the icon is on the server.

    If this is "the way it works" in Windows 8, then we can deal with it by copying all the icons from the server to the local C drives on Windows 8 machines. But I am trying to figure/find out if this is supposed to be "the way Windows 8 is" or if it is supposed to work but some problem is preventing it from working, because if it is a problem then it might impact other things as well.

    Wednesday, December 12, 2012 9:33 PM
  • Let me ask this a different way. Can someone try the following and tell me what result you get for Step 5?

    Given: A workstation running Windows 8, joined to a domain on a network.

    Given: A server (Active Directory Domain Controller) running Windows Server 2008 R2. (Not sure the server's OS matters; it's Windows 8 that matters.)

    Step 1: Create a dummy text file (or other dummy file) on the Windows 8 workstation.

    Step 2: Create a shortcut to the dummy text file on the Windows 8 desktop.

    Step 3: Edit the shortcut's properties and change the icon, selecting some icon file (e.g., WHATEVER.ICO) located on the Windows 8 workstation.

    My Result: The icon displays correctly on the desktop shortcut.

    Step 4: Now copy the icon file and paste it somewhere on the server.

    Step 5: Change the shortcut's properties to look for the icon on the server where you copied it to.

    My Result: The icon displays correctly in the shortcut properties window, but once I apply the change the desktop shortcut displays a "blank document" icon.

    Note: The type of file the shortcut points to is unimportant-- you can try it with a TXT, DAT, EXE, COM, or any other type of file. The issue is with the shortcut's icon, not the shortcut's target.

    Interesting Aside: If you change the shortcut so the target is the ICO file itself, the icon is displayed correctly.

    Wednesday, December 12, 2012 10:06 PM
  • I have had this problem with 8 since beta.

    To be clear, you have custom icons on a network share, as you said I:\Icons or something.

    You have customized shortcuts with the icons from the I:\Icons

    The icons are blank in windows 8 but are fine in every other windows client. They even appear in the box while customizing the icon, they just dont display.

    It is definitely a windows 8 problem, I havent found an answer, but if I do I'll post it here. I have dug through the registry with no luck.

    I am trying to avoid moving the icons to a local drive, which does fix the problem.

    Grumble Grumble

    Sunday, January 13, 2013 7:10 AM
  • Смогли исправить проблему? 
    Sunday, March 24, 2013 10:31 AM
  • I am having the same problem, and I can confirm its only with Windows 8. All other versions of Windows work correctly. Has anyone found a fix yet?
    Thursday, August 08, 2013 6:06 PM
  • This is also happening on Server 2012 R2, so it stands to reason the problem also exists on 8.1, and has not been fixed. 
    Thursday, November 21, 2013 4:06 AM
  • Right after I posted, I found this...

    Group Policy
    WindowsExplorer.admx (windows 8)
    Windows Components\File Explorer\Allow the use of remote paths in file shortcut icons  

    Regedit
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Explorer
    EnableShellShortcutIconRemotePath
    reg_dword 1

    Thursday, November 21, 2013 4:09 AM