none
Windows 7 machines can't RDP to Windows 2008 servers

    Question

  • In the last 2 or 3 weeks our ability to rdp into windows 2008 servers from windows 7 machines has broken.  We get this error:

    An authentication error has occurred.  The requested security package does not exist.

    I can't find any information logged in either the client or the server event logs.  Has anyone else come a accross this error or would you know where to look to troubleshoot this further?  Thanks in advance

    Friday, August 13, 2010 1:25 PM

Answers

  • Ok we fixed the issue.  Appaently one of the sys admins deployed an sms package that removed some settings from this key:

    HKLM\system\currentcontrolset\control\lsa\security packages

     

    It should have these values: kerberos msv1_0 schannel wdigest tspkg pku2u

     

    The tskpkg and pku2u values were missing.

    After adding them and rebooting and I can RDP to 2008 servers.

    Thanks for everyones help.

    • Proposed as answer by Aaron.ParkerMVP Wednesday, August 18, 2010 5:59 PM
    • Marked as answer by Wilson Jia Friday, August 20, 2010 7:47 AM
    Wednesday, August 18, 2010 5:37 PM

All replies

  • Are you modifying your Windows 7 build in anyway? Perhaps the CredSSP component has been removed or restricted. Try from a Windows 7 client that does not have Group Policy objects applied to it.
    Friday, August 13, 2010 1:40 PM
  • When this first happened I did a system restore and I was able to connect for a little while.  However after receiving updates and rebooting it broke again.  It could be GPO or an update or maybe a combination of both, but we have not made any GPO changes in over a month.  How do find out if this CredSSP component has been removed?

    Friday, August 13, 2010 3:41 PM
  • I'm not sure where to start to check that CredSSP is working, but moving a computer account to an OU with no GPOs would be an easier test.
    Friday, August 13, 2010 6:10 PM
  • Hi,

     

    Is other client able to RDP to Windows 2008 Server?  Which Remote Desktop option you specify on Window 2008 server? Please select the "Allow connections from computers running any version of Remote Desktop" option to see how it works.

     

    To narrow down this issue, I would also suggest you perform a clean-boot of Windows 7 system to see if it works. You can follow the steps below:

    1. Click Start, click Run, type msconfig, and then click OK.
    2. On the General tab, click Selective Startup, and then click to clear the following check boxes:
      • Process SYSTEM.INI File
      • Process WIN.INI File
      • Load Startup Items
    3. On the Services tab, click to select the Hide All Microsoft Services check box, and then click Disable All.
    4. Click OK, and then click Restart to restart your computer.

     

    Wilson Jia

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, August 16, 2010 8:53 AM
  • Sure sounds like an update is the problem. I would try uninstalling them one at a time until you find the one. Then call MS. Problems with updates are a free support call.

    Regards,
    Hank Arnold
    Microsoft MVP
    Windows Server - Directory Services
    http://it.toolbox.com/blogs/personal-pc-assistant/

    On 8/13/2010 11:41 AM, SWFPAC Information Technology Services wrote:

    When this first happened I did a system restore and I was able to connect for a little while.  However after receiving updates and rebooting it broke again.  It could be GPO or an update or maybe a combination of both, but we have not made any GPO changes in over a month.  How do find out if this CredSSP component has been removed?


    Regards, Hank Arnold (MVP - DS)
    Monday, August 16, 2010 9:13 AM
  • Already have "Allow connections from computers running any version of Remote Desktop".  And already attempted placing the computer in a block inheritance OU.  I think it is an update but I am suprised this is not happening to anyone else. When I have time I will attempt to uninstall updates.

    Monday, August 16, 2010 6:02 PM
  • Hi,

    Did you get any chance to check the update log to see if there is any clue in it?

    You can refer to the following KB article:

    How to read the Windowsupdate.log file

    http://support.microsoft.com/kb/902093

    Regards,

    Wilson Jia


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, August 17, 2010 2:51 AM
  • Ok we fixed the issue.  Appaently one of the sys admins deployed an sms package that removed some settings from this key:

    HKLM\system\currentcontrolset\control\lsa\security packages

     

    It should have these values: kerberos msv1_0 schannel wdigest tspkg pku2u

     

    The tskpkg and pku2u values were missing.

    After adding them and rebooting and I can RDP to 2008 servers.

    Thanks for everyones help.

    • Proposed as answer by Aaron.ParkerMVP Wednesday, August 18, 2010 5:59 PM
    • Marked as answer by Wilson Jia Friday, August 20, 2010 7:47 AM
    Wednesday, August 18, 2010 5:37 PM
  • I had the same issue and at first I thought your solution didn't work.  But then I noticed you had "tspkg" and "tsKpkg" in your post.  The latter of which was a typo and the one i used.

    So I finally tried the "tspkg" and it works great.  Thanks for the solution, but I hope you can edit your post.

    Tuesday, June 12, 2012 4:27 AM