none
RDP-Authentication not working for RemoteApp

    Question

  •  Hi,
    I search a way to start a RemoteApp without user authentication (No Single Sign-On, it's a different user account). Normal RDP Connection working well, but when I add the RemoteApp part, the authenticationdialog appears.

    Has anyone an idea why this not work or a workaround to solve my problem

    RDP Protocol is 6.1 on a Windows XP client and the server has the newest updates and .Net 3.5 SP1 installed.

    Thanks a lot
    Ben

    My rdp definition:

    screen mode id:i:2
    desktopwidth:i:1280
    desktopheight:i:1024
    session bpp:i:32
    winposstr:s:0,1,1280,61,2560,914
    auto connect:i:0
    compression:i:1
    keyboardhook:i:2
    audiomode:i:0
    redirectdrives:i:0
    redirectprinters:i:0
    redirectcomports:i:0
    redirectsmartcards:i:1
    displayconnectionbar:i:1
    domain:s:
    shell working directory:s:
    disable wallpaper: i: 1
    disable full window drag: i: 1
    disable menu anims: i: 1
    disable themes: i: 1
    bitmapcachepersistenable: i: 1
    redirectclipboard:i:1
    redirectposdevices:i:0
    redirectcomports:i:1
    devicestoredirect:s:*
    drivestoredirect:s:*
    redirectdrives:i:1
    span monitors:i:1
    prompt for credentials on client:i:1
    allow font smoothing:i:1
    promptcredentialonce:i:1
    authentication level:i:0
    gatewayusagemethod:i:2
    gatewayprofileusagemethod:i:0
    gatewaycredentialssource:i:0
    server port:i:3389
    full address:s:192.168.1.10
    username:s:user
    password 51:b:ABCD01234

    ########################################
    -> for RemoteApp I have added this part
    ########################################

    remoteapplicationmode:i:1
    alternate shell:s:||myapp
    remoteapplicationprogram:s:||myapp
    gatewayhostname:s:
    remoteapplicationname:s:myapp.exe
    remoteapplicationcmdline:s:

    Wednesday, December 17, 2008 2:00 PM

Answers

All replies