none
RDP and left-handed mouse users

    Question

  • Hi there,

    I'm a left-handed person. So I use the mouse with my left hand and naturally I use "Switch primary and secondary buttons" mouse control panel option.

    When it comes to RDP connections, I almost always connect to the desktops where "Switch primary and secondary buttons" is set for right handed people. When I'm inside an RDP session the mouse stops respecting my mouse settings and apply guest desktop settings which creates a lot of confusion to me.

    Is there a way to setup my RDP client so that it automatically handles right vs. left buttons translation ?


    Friday, September 07, 2012 8:34 AM

Answers

  • Hi,

    Thanks for your post.

    The mouse setting is store at user profile. You need to create a user account for you to connect to Terminal server. By default, the mouse is for right hand. But you can change it to left hand mouse, and the setting save at profile. Next time RDP to this server, the setting will reflect what you want.

    Best Regards,

    Aiden


    Aiden Cao

    TechNet Community Support

    Wednesday, September 12, 2012 2:37 AM

All replies

  • Hi,

    Thanks for your post.

    The mouse setting is store at user profile. You need to create a user account for you to connect to Terminal server. By default, the mouse is for right hand. But you can change it to left hand mouse, and the setting save at profile. Next time RDP to this server, the setting will reflect what you want.

    Best Regards,

    Aiden


    Aiden Cao

    TechNet Community Support

    Wednesday, September 12, 2012 2:37 AM
  • Hello Aiden,

    Thanks for your comment, however the solution you suggested it is not really what I'm looking for.  

    I know where the mouse settings are stored and I also know that I can create a profile on a remote server and adjust mouse settings there. The problem is that the most desktops I connect to are not only shared among other admins but also often beyond my control.  So creating profiles and changing settings is not a solution.



    Wednesday, September 12, 2012 6:20 AM
  • Hi,

    Thanks for your update.

    However, there is no mouse setting in RDC options. So we cannot change the mouse setting when the session initialized. It will use apply the current user mouse settings. You need to change it manually when connect to the remote computer.


    Best Regards,
    Aiden


    Aiden Cao

    TechNet Community Support

    Monday, September 17, 2012 1:45 AM
  • This looks like a MSTSC problem itself, most of the VNC clients makes this automatically. And some others that not require point to point communication (ShowMyPC and TeamViewer), also. Is not a problem with the server because using "rdesktop" (default RDP client in Linux systems), the mouse swap the buttons correctly. 
    Friday, May 03, 2013 8:19 PM
  • As usual Microsoft don't 'get' the problem. The mouse handedness should transfer to the server with RDP.  We shouldn't have to mess about with profiles on the server.  What if we administer tens or hundreds of servers?

    Previously I have been able to use the Logitech SetPoint mouse drivers on XP and this worked a treat.  I have recently moved to Windows 7 64bit and this doesn't appear to be a solution any more.

    Get a grip Microsoft and make this work properly.


    Richard

    Monday, November 18, 2013 1:58 PM
  • Hi Richard,

    I started using RDP on daily bases in late 2009 and was literally shocked that this feature was not there. Since that time we've seen 2 major Windows OS releases and 2 (?) service packs. But a trivial to fix (imho) issue is still there.  I also tried several ways to report the problem including their TS blog. Got no response. Taking into account what's going on in/with Microsoft right now I kind of lost the hope and don't expect the issue to be fixed any time soon.

    Monday, November 18, 2013 2:11 PM
  • I have the same problem.  Most of my tasks are in VmWare as well.  The Client there will not switch either.

    My Kensington trackball (Expert Mouse) software allows me to map the 4 keys it has.  I've made it symmetrical on both the left and right.   Seems to work for me.

    I'm re-learning how to mouse with my left as I'm getting Carpal Tunnel syndrome on my right wrist.  

    Are there no left-handed developers at MS?

    Peter

    Friday, January 31, 2014 5:06 PM
  • The actual solution is to install the Microsoft Intellipoint driver.  I had the same problem - the local mouse button mapping is not translated via rdp into any pc or server you connect to with the generic mouse driver.  Also, because that server may not have a mouse connected to it at all, you cannot update the mouse settings on the server itself.  However, if you install the Intellipoint mouse driver then the button mapping works in rdp sessions.  Go figure.

    Timing is Everything.

    Thursday, April 17, 2014 3:53 PM
  • Hi Mr. Reality...where are you installing the Intellipoint driver? On the RDP host or client (sender or viewer?)

    Thanks.

    Friday, May 23, 2014 5:48 PM
  • Client - the pc I am RDP'ing from.  This actually happened to me twice, 4 years apart.  I had figured it out 4 years ago, installed the Intellipoint mouse drivers, which fixed it.  Then got a new pc this year at work and was re-installing all my apps and when I got to Intellipoint I thought "why do I need that?" and skipped it.  Within the week when I RDP'd for the first time I was irritated that the mouse buttons didn't map, and then it dawned on me that's why I had Intellipoint installed on my old PC.

    Timing is Everything.


    Saturday, May 24, 2014 4:39 PM
  • Thanks. My issue was actually with the Logitech SetPoint drivers. If a user has the SetPoint drivers installed, they need to change mouse buttons to left handed mode from within the Logitech software itself, not from the Windows control panel.
    Monday, May 26, 2014 2:26 PM
  • The intellipoint driver exists for Windows 7 but for 8.1 there is no such driver available on the Microsoft download site. 
    5 hours 9 minutes ago