none
Windows cannot create a shortcut here - in C:\ProgramData\Microsoft\Windows\Start Menu\Programs\

    Question

  • I cannot create any shortcuts here, either as my user account, or if I run my account launching Explorer as "Run As Administrator"..

    I can only do this as the actual administrator account.

    somehow this area is protected.  I looked at the file system security and administrators have full control, but if you try to create a shortcut here (or paste one) it says

    "Windows cannot create a shortcut here.  Do you want the shortcut to be placed on the desktop instead?"

    it does this for any place under C:\ProgramData\Microsoft\Windows\Start Menu\Programs\..

    I (or any other user account) can create new folders, but cannot paste or create new shortcuts (or any other kind of object, Folder is the only option on the New menu)

    This server is in a newly created domain, with no GPOs applied other than the default domain GPO.

    Thanks
    Wednesday, June 25, 2008 3:27 PM

Answers

  • Hello,
     
    According to the discription, this issue may be caused by UAC. 
     
    It seems that the copy operation failed directly without UAC prompt. Please disable UAC to see whether you can copy file properly.
     
    How to use User Account Control (UAC) in Windows Vista
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;922708
    (This should be also applied to Windows Server 2008)
     
    Hope it helps.

    Your potential. Our passion.
    • Marked as answer by David Shen Friday, June 27, 2008 7:11 AM
    Thursday, June 26, 2008 11:07 AM
  • Rich-

    I replicated this in the GUI but if you use an elevated command prompt you can copy it over without a problem.  Not the best solution but a workaround if you dont want to mess with UAC.  I just created the test on my desktop then used the copy command in the elevated command prompt to move it over.

    Dave
    • Marked as answer by Rich.wray2 Thursday, June 26, 2008 6:21 PM
    Thursday, June 26, 2008 4:25 PM

All replies

  • Hello,
     
    According to the discription, this issue may be caused by UAC. 
     
    It seems that the copy operation failed directly without UAC prompt. Please disable UAC to see whether you can copy file properly.
     
    How to use User Account Control (UAC) in Windows Vista
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;922708
    (This should be also applied to Windows Server 2008)
     
    Hope it helps.

    Your potential. Our passion.
    • Marked as answer by David Shen Friday, June 27, 2008 7:11 AM
    Thursday, June 26, 2008 11:07 AM
  • Rich-

    I replicated this in the GUI but if you use an elevated command prompt you can copy it over without a problem.  Not the best solution but a workaround if you dont want to mess with UAC.  I just created the test on my desktop then used the copy command in the elevated command prompt to move it over.

    Dave
    • Marked as answer by Rich.wray2 Thursday, June 26, 2008 6:21 PM
    Thursday, June 26, 2008 4:25 PM
  • It's odd (dare I say it's a bug!) that an elevated command prompt works, but an elevated Explorer session does not - i got the same results as you did, and obviously via a command prompt is not the easiest way to create a shortcut that you want all users to have access to.



    Thursday, June 26, 2008 6:21 PM
  • OMG, you have got to be kidding me there has tp be a fix by now!

     

    Tuesday, May 18, 2010 8:01 PM
  • Nope, the bad behavior has been propagated to Win7. Plus new (bad) features. Every generation seems 2 steps forward, 3 back.
    Wednesday, September 08, 2010 12:20 PM