none
The ordinal 459 could not be located in the dynamic link library urlmon.dll

    Question

  • Hello,

    I use Win XP SP3 Pro.

    I have Czech language on my computer, but the error to be translated to english is:

    "The ordinal 459 could not be located in the dynamic link library urlmon.dll "

    This happens when I try to open program from the icon in panel "Snadné spuštění" in Win XP. I mean the panel just on left side of system oclock. Then this report pops up cca 10x. Then the program is run.

    I dont know how to solve this problem. Anybody help?

    Sunday, December 25, 2011 2:59 PM

All replies

  • I'd ask them here.

    http://answers.microsoft.com/en-us/windows/forum/windows_xp

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]
    Sunday, December 25, 2011 3:03 PM
  • Hello,

    As I see you have a problem with a DLL. You can consider running sfc /scannow and checking results. If this does not solve the problem, perform a repair install of your OS and check results.

    Also, see that: http://support.microsoft.com/kb/281679

    If the problem persists, contact your program developer Technical Support or ask them here: http://social.technet.microsoft.com/Forums/en-US/itproxpsp/threads



    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.   

    Microsoft Student Partner 2010 / 2011
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows 7, Configuring
    Microsoft Certified Technology Specialist: Designing and Providing Volume Licensing Solutions to Large Organizations
    Microsoft Certified IT Professional: Enterprise Administrator
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Trainer

    Sunday, December 25, 2011 3:47 PM
  • I try the first command

    sfc /scannow

    which wants to me to insert installation disc.

    There is problem, because I have the disc in CD-ROM but progrome does not recognized that I put it there. I press Repeat but does not help... Why there is not option to select folder...

    Sunday, December 25, 2011 3:53 PM
  •  

    I think that's a part of IE.

    So i would suggest to re-install or repair IE.

    http://support.microsoft.com/kb/318378

    Sunday, December 25, 2011 6:13 PM
  • I ve finished the scan and the event viewer shows some system errors:

    (translated to English)

    Event type:    error
    Source of event:    SRService
    ID:    104
    Description:

    Init. proccess of the "tool for restoring of system" not successful.

       /Proces inicializace nástroje Obnovení systému se nezdařil./

    Data:
    0000: 03 00 00 00               ....   

     

    Next error:

    Type:    Error
    Source:    Service Control Manager
    event ID :    7023
    Desc.:

    (Same restore service) Cannot find path

     

    Next error:

    Error
    Source:    DCOM
    ID:    10000
    USER:        NT AUTHORITY\NETWORK SERVICE
    Desc.

    Cannot run server server DCOM: {73E709EA-5D93-4B2E-BBB0-99B7938DA9E4}.

    Cannot find path

    Command:

    E:\windows\system32\wbem\wmiprvse.exe -Embedding

    Local Machine Register Note:

    My system is on disk D:

    register BootDir was c:\ but I changed it to d:\ before the scan started

    SystemPartition was \Device\HarddiskVolume1 but I changed it to  \Device\HarddiskVolume2 before the scan started

    I have no idea how it happens there is letter E:. I changed some devices/partitions letters after I installed the Windows. So probably E: was the "Installation Sources" which should be K:

     

    Next error:

    Is the same as the above error. Path not found. Also the file   C:\windows\system32\comdlg32.ocx could not be found because it should be on d:\

     

    I would like to fix the problem, which is probably in incorrect path somewhere. I really dont know why I have my system on d: when it looks it was installed to c:... Would it helped to change the letter of disk d: to  c: or the system would crash?




    Sunday, December 25, 2011 7:06 PM
  • Hi Igor

     

    Urlmon.dll is an system component and multiple applications require it to implement URL Moniker.

     

    This could happen if urlmon.dll is damaged or missing.

     

    Just like MrX and Brano suggested, please re-register this file and try SFC to fix it.

     

    1.Click Start, and then click Run.

    2.Type regsvr32 urlmon.dll, and then click OK.

     

    Description of Windows XP and Windows Server 2003 System File Checker (Sfc.exe)

    http://support.microsoft.com/kb/310747

     

    Please note that the XP install disc should have Server Pack 3 integrated if your system is XP SP3.

     

    If it still not working, please ask for help on Windows XP forum.

    http://social.technet.microsoft.com/Forums/en-us/itproxpsp/threads

     

    • Proposed as answer by Cyap888 Tuesday, July 24, 2012 10:16 PM
    Monday, December 26, 2011 6:53 AM
    Moderator