none
my Webiste not accessible from my own LAN

    Question

  • I have hosted my company's website in the server situated in the company premises itself.  The site is well accessible from anywhere outside the company LAN environment, but not accessible from within the LAN.  The site is getting within the LAN if we are giving the ip address, but by using the url it is not getting. Ping and nslookup commands nor working for URL, but working for ip address. I disabled all software firewall, but to no avail.  Anybody can help me to resolve this??

     

    Monday, February 21, 2011 5:34 AM

Answers

  • thanks all....

     at last i resolved the problem and now i am getting my site from the lan also.  What i did is only set the preferred dns of lan as the ip address of the dns server. now everything ok.

    thank u all very much for the responses.

     

    • Marked as answer by kurungot Tuesday, February 22, 2011 6:14 AM
    Tuesday, February 22, 2011 6:13 AM

All replies

  • Hello,

    create an A record named www pointing to the webserver ip address from the LAN.


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Monday, February 21, 2011 5:41 AM
  • Hi,

    It seems that you are experiencing a Split Zone. Please refer to:

    Split Zone or no Split Zone - Can't Access Internal Website with External Name
    http://msmvps.com/blogs/acefekay/archive/2009/09/04/split-zone-or-no-split-zone-can-t-access-internal-website-with-external-name.aspx

    Brent
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, February 21, 2011 5:59 AM
  • i have already created this A record for www. But the problem is still there.  

    thanx

    Monday, February 21, 2011 6:25 AM
  • Hi

    Say your domain name is company.org is the web address www.company.org or its different from the domain name?

    if they are the same as illustrated above then an A record should fix the problem but you dont type in the entire address because the text will be appended to the greyed out FQDN right below the name you are typing so say your domain is company.org then for the A record you just type in www if the address is www.company.org and enter the ip address associated with the address.

    Please check this and get back to us


    tech-nique
    Monday, February 21, 2011 7:34 PM
  • OK, so you've already added the DNS A record, but you say in the original post that ping and nslookup aren't working. Do you mean that if you try to ping the address it can't resolve the IP address, or do you mean that it resolves the IP but fails to get a response? If it is unable to resolve the IP address then assuming it's the local DNS that you've added the new A record to, is the machine you're pinging from using that DNS server or another one? If you're not getting a response then have you checked that the resolved IP is the correct one, eg the internal IP address rather than the external one used from outside the lan?
    Monday, February 21, 2011 9:18 PM
  • kurungot,

    I assume you created an A record called 'www' and gave it the internal IP address, correct?

    Once you've created it, did you test it by:

    If so, were the tests successful, or did you just try it in a browser without the above tests? If you tried it in a browser, it may be that the old record is still cached on the browser, and in the client side resolver. To clear this, you must:

    • Open Internet explorer, select Tools, Internet options, and delete the cache.
    • Close the browser
    • Open the DNS console, right click the server name, select Clear Cach
    • Open a command prompt and type ipconfig /flushdns
    • Now try the ping and nslookup tests above
    • If the tests work, open a browser and try again

    Also, I must add, that you must make sure the internal machines are only (ONLY), using the internal DNS server. They can't be using an ISP's DNS address, or the router as a DNS address (as some installations have tried it), or this will not work. Matter of fact, AD will have problems if using such a configuration.

    Keep in mind, with a split zone, getting to the website internally using http://company.com (without the www in it) will be a little more trickier to setup. The link Brent posted has specific info on how to configure it.

    Ace


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008 & Exchange 2007, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services

    This posting is provided AS-IS with no warranties or guarantees and confers no rights.

    Monday, February 21, 2011 9:55 PM
  • thanks all....

     at last i resolved the problem and now i am getting my site from the lan also.  What i did is only set the preferred dns of lan as the ip address of the dns server. now everything ok.

    thank u all very much for the responses.

     

    • Marked as answer by kurungot Tuesday, February 22, 2011 6:14 AM
    Tuesday, February 22, 2011 6:13 AM
  • Good to hear.

    It is always important, as I mentioned, that you only use your internal DNS server on the LAN and no others. If using any others, it will cause problems with Active Directory, as well as not resolve records from the internal DNS.

    If you have another DNS as the second entry, such as an outside DNS (your ISP's possibly?), it is recommended to remove it and only keep the internal DNS listed.

    Configure a forwarder for efficient internet name resolution. In DNS console, right-click DNS servername, choose the Forwarders tab, enter your ISP's DNS as a Forwarder. This will not affect any current records internally, rather it will make internet resolution more efficient.

    Ace


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008 & Exchange 2007, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services

    This posting is provided AS-IS with no warranties or guarantees and confers no rights.

    Tuesday, February 22, 2011 7:13 AM