none
SMB2 Disable Durable File Handles (without downgrading to SMB1)

    Question

  • We are encountering an issue with our software in Windows 7 / Windows 2008R2 environment.

    Multiple files stay open on the server.

    It appears to be due to SMB2 (when SMB2 is disabled there is no problem).

    We suspect that the "durable file handles" causes this problem.

    Is it possible to switch off this functionality?

    Many thanks in advance,

    Benjamin


    Thursday, May 16, 2013 2:37 PM

Answers

  • Thank you for your answer.

    We would prefer not to turn off SMB2 if possible. We have tried different methods for that and in fact it works.

    As we can disable FileNotFoundCacheLifetime may be there is a key to switch off durable file handles?


    From what I know there's no way to turn off this individual thing (I would double check this assumption of course). Try going other way - use SMB 3.0 to see would DFH behave the same there. At least for experiment.

    StarWind iSCSI SAN & NAS

    Friday, May 17, 2013 11:14 AM

All replies

  • We are encountering an issue with our software in Windows 7 / Windows 2008R2 environment.

    Multiple files stay open on the server.

    It appears to be due to SMB2 (when SMB2 is disabled there is no problem).

    We suspect that the "durable file handles" causes this problem.

    Is it possible to switch off this functionality?

    Many thanks in advance,

    Benjamin

    Downgrade SMB version. See how:

    http://www.networkworld.com/community/node/56529

    http://techdom.nl/microsoft/managing-windows-server-2012-smb-version-3-protocol/


    StarWind iSCSI SAN & NAS

    Thursday, May 16, 2013 4:28 PM
  • Thank you for your answer.

    We would prefer not to turn off SMB2 if possible. We have tried different methods for that and in fact it works.

    As we can disable FileNotFoundCacheLifetime may be there is a key to switch off durable file handles?


    Friday, May 17, 2013 7:22 AM
  • Thank you for your answer.

    We would prefer not to turn off SMB2 if possible. We have tried different methods for that and in fact it works.

    As we can disable FileNotFoundCacheLifetime may be there is a key to switch off durable file handles?


    From what I know there's no way to turn off this individual thing (I would double check this assumption of course). Try going other way - use SMB 3.0 to see would DFH behave the same there. At least for experiment.

    StarWind iSCSI SAN & NAS

    Friday, May 17, 2013 11:14 AM
  • As VR38DETT said it seems we do not have a setting for disabling the specific function. Or you could try to contact the software manucfacturer to see if there is any upgrade version or update for fixing the issue with SMB2.

    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Monday, May 20, 2013 8:04 AM
    Moderator
  • If there is anything further we could help please just let us know

    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Thursday, May 23, 2013 6:21 AM
    Moderator
  • Sorry for not having been here for a time. I have read your messages on my smartphone but no way to connect. Thank you for your response.

    Yes the solution is to disable SMB2 on workstations but we would have preferred a thin tuning on customers pcs.

    We are the software developers and very old code in particular situations occur these problems, not easy to replace quickly.

    In SMB3 we can set the timeout for file handles, but nothing seem having been implemented in SMB2.

    Thursday, May 23, 2013 7:36 AM