none
Setup cannot continue because one or more prerequisites required to install KB982109 failed

    Question

  • Hi,

    I am required to install KB982109 in order to update the mpio.sys to a later version in order to install a netapp client.
    On windows 2003 r2 enterprise with sp2, I get "Setup cannot continue because one or more prerequisites required to install KB982109 failed"

    Looking on the techie page for KB982109 the only prereq is Windows 2003 r2 SP2 in which the server already has.

    The full error is here:

    [KB982109.log]
    0.516: ================================================================================
    0.516: 2011/12/08 11:55:55.598 (local)
    0.516: c:\ff706f45736c81b2720e54a30d9eed82\update\update.exe (version 6.3.4.1)
    0.516: Hotfix started with following command line:
    0.516: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.563: ProductType is Present
    0.563: SYSTEM\CurrentControlSet\Control\ProductOptions\ProductType is Not Equal To Specified Value
    0.563: Condition succeeded for section Prereq.XPAMDInstallBlock.Section in Line 1 of PreRequisite
    0.563:  C:\WINDOWS\system32\DRIVERS\mpio.sys is Present
    0.563: FileVersion of C:\WINDOWS\system32\DRIVERS\mpio.sys is Less Than 1.22.3790.2358
    0.563: Second Condition in Test.MPIOInstallBlock.Section Failed
    0.563: Condition Check for Line 2 of PreRequisite returned FALSE
    0.578: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.578: KB982109 Setup encountered an error:  Setup cannot continue because one or more prerequisites required to install KB982109 failed. For More details check the Log File c:\windows\KB982109.log
    0.578: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.578: Setup cannot continue because one or more prerequisites required to install KB982109 failed. For More details check the Log File c:\windows\KB982109.log
    12.782: Message displayed to the user: Setup cannot continue because one or more prerequisites required to install KB982109 failed. For More details check the Log File c:\windows\KB982109.log
    12.782: User Input: OK
    12.782: Update.exe extended error code = 0xf0f4
    12.782: Update.exe return code was masked to 0x643 for MSI custom action compliance.

    Please advise a fix or workaround

    Thanks in advance,

    Mark.

    Wednesday, February 22, 2012 3:56 PM

Answers

All replies

  • I am experiencing the exact same error on a server running Windows 2003 R2, SP2.  Waiting anxiously for someone to post a recommended solution.
    Wednesday, February 22, 2012 6:17 PM
  • i get the error too.

    Wednesday, February 22, 2012 6:57 PM
  • Hello,


    Please note that KB982109 only applies to Windows Server 2003 with SP2 while you are running Server 2003 R2.


    Please note that Server 2003 and Server 2003 R2 are different OS.


    Check the APPLY TO sectioni
    http://support.microsoft.com/kb/982109


    Thanks
    ZHANG

    Thursday, February 23, 2012 3:29 AM
  • Hi JWGage & DGDaniel,


    Please check the KB982109.log, maybe you can see the same error as below:


    0.563: SYSTEM\CurrentControlSet\Control\ProductOptions\ProductType is Not Equal To Specified Value


    Thanks
    ZHANG

    Thursday, February 23, 2012 3:34 AM
  • Hi guys,

    Thanks for the replies.

    Just realised that the server is in fact Windows 2003 Enterprise x64 with SP2 NOT Windows 2003 R2 so the problem still applies.

    Regards,

    Mark.

    Thursday, February 23, 2012 11:58 AM
  • Hi,

    I am not MPIO expert but just looking at the install log, it looks like the mpio.sys binary file version (in order for successful installation) should be greater than or equal to 1.22.3790.2358, which is not the case here.

    Thanks,

    Girish

    Thursday, February 23, 2012 3:05 PM
  • Thanks Girish and you are correct with the version.

    Meanwhile I was searching for that particular version of the mpio.sys for download as the netapp software we required installed is to manage fibre and not iSCSI in this instance. I presumed thats all we needed.

    In fact downloading Microsoft iSCSI Initiator version 2.08 from http://www.microsoft.com/download/en/details.aspx?id=18986 has enabled me to install KB982109 and therefore the netapp mpio setup program can now install.

    JWGage/DGDaniel - do you have this installed?

    Thursday, February 23, 2012 3:48 PM
  • This solution has also worked for me.  After installing the iSCSI Initiator version 2.08, I was then able to successfully install the hotfix KB982109, and then finally also upgrade my NetApp Data ONTAP DSM for Windows MPIO software to version 3.5.  Thanks for looking into this and coming up with the answer.
    Friday, February 24, 2012 4:45 PM