none
RDC keeps crashing after connecting to srv2k8r2 remoteapp

    Question

  • We have a Win Srv 2k8 R2 server setup with the remote apps role installed. From our location we can use remote desktop to get in and use the apps, but in the remote location we cant with our Windows 7 computers. The XP Pro computers in the other location will connect, its just the Windows 7 computers that won't. The connection starts, they get logged in and after a few seconds it just quits, theres no log off or anything, and its not giving an error screen of any kind.
    Thursday, June 30, 2011 7:46 PM

All replies

  • Cna you please check the event logs on the server computer and see what it says? Check both the System event log and the TerminalServices-RemoteConnectionManager logs.

    Thanks!

    Tuesday, July 05, 2011 4:36 PM
  • Sorry about the delay.

    This is the only error from the applications event log.

    Level Date and Time Source Event ID Task Category
    Information 7/11/2011 3:50:19 PM Desktop Window Manager 9003 None The Desktop Window Manager was unable to start because a composited theme is not in use

    These are the errors from the system event log on the server.

    Level Date and Time Source Event ID Task Category
    Error 7/11/2011 3:53:06 PM Microsoft-Windows-TerminalServices-Printers 1103 None An internal communication error occurred.  Redirected printing will no longer function for a single user session.  Check the status of the Remote Desktop Device Redirector in the System folder of Device Manager.
    Error 7/11/2011 3:53:06 PM Microsoft-Windows-TerminalServices-Printers 1103 None An internal communication error occurred.  Redirected printing will no longer function for a single user session.  Check the status of the Remote Desktop Device Redirector in the System folder of Device Manager.
    Information 7/11/2011 3:52:18 PM Service Control Manager 7036 None The Shell Hardware Detection service entered the stopped state.
    Information 7/11/2011 3:50:51 PM Service Control Manager 7036 None The WinHTTP Web Proxy Auto-Discovery Service service entered the running state.
    Information 7/11/2011 3:50:23 PM Microsoft-Windows-Kernel-General 1 None The system time has changed to ‎2011‎-‎07‎-‎11T19:50:23.180000000Z from ‎2011‎-‎07‎-‎11T19:50:22.399501000Z.
    Information 7/11/2011 3:50:10 PM Microsoft-Windows-Winlogon 7001 (1101) User Logon Notification for Customer Experience Improvement Program
    Information 7/11/2011 3:50:09 PM Service Control Manager 7036 None The Shell Hardware Detection service entered the running state.

     

    The TerminalServices-RemoteConnectionManager logs would all be found under the roll for it on the server manager, correct? THere are no log files from then on there.

     

    I have also collected a log file from the client computer if that would be any help for me to post?

    Thursday, July 14, 2011 5:30 PM
  • I have the same issue....it's happening only at Windows 7 and Windows server 2008... usually 1st logon attemp will just quits..but if i try again after crushed it will open the remoteapp...

    Friday, July 27, 2012 5:50 AM