none
Setup a website with DNS and IIS 7

    Question

  • I have a sever with win 2008.

    I install IIS 7 and DNS. Also, I have domain abcd.com (for example) which point to IP : 12.34.45.6 (for example)

    I want to setup a web on my server with domain abcd.com, but failed.

    Here is what I do :

    NETWORK:

    - setup net work for my local machine, which host the web.  Select the ip as : 192.168.1.10

    DNS:

    - setup DNS with Forward Lookup Zones.

    - add New Host : FQDN=abcd.com, IP=192.168.1.100

    IIS

    - Add Web Site.. Site Name = abcd.com/blank (try both), Physical Path : C:/test

    - Bindings : Type=http, IP: All Unassigned/192.168.1.100 (try both), Port 80/8080 (try both),  Host Name = abcd.com, Start Website immediatly = checked.

    Testing result:

     1-

    cmd > nslookup abcd.com

    Server : Unknown

    Address : 12.34.45.6

    (look like something wrong is here, it should be 192.168.1.100, I think)

    2 -

    IIS

    Right click abcd.com - > browse : if host name blank, it shows the conent of http://localhost:8080/index.aspx. If host name = abcd.com,  it shows unconnected of http://abcd.com:8080/

    Note: I do this without Active Directory Service. Last time I did it and it worked, but I forget how I did it.

    Please, tell me what wrong I do this time or what steps I miss.

    Thanks

    Sunday, June 03, 2012 6:25 AM

Answers

  • If you created an internal DNS zone and a record that points to 192.168.1.100, you ALSO have to make sure that your internal computers are configured to point to your internal DNS server.  When you tried NSLOOKUP, the result seems to be for the external host, not your internal host.  That leads me to beleive that the computer you are on is not configured to point to your internal DNS server.

    With regard to IIS, run the website on port 80.  If you run it on another port, you have to specify that in the URL of your browser.  For instance, if your web runs on port 8080, then the URL will be http://abc.com:8080.  

    If this is the only website running on this web server, you do not have to bind the web site to any IP/port, and do not have to add host headers.  That is only necessary when you run more than one web site in IIS, so the webserver knows which web site to serve.

    If you want to access this site from an external host, you also have to set up your router for port forwarding and make sure the external record points to the external IP of your internet router.

    I have a few articles that may be of interest to you: http://www.itgeared.com/topic-2/web/


    Guides and tutorials, visit ITGeared.com.

    itgeared.com facebook twitter youtube

    • Proposed as answer by Tiger Li Tuesday, June 05, 2012 8:20 AM
    • Marked as answer by Tiger Li Friday, June 08, 2012 2:07 AM
    Monday, June 04, 2012 12:54 AM
  • Hi namman,


    Thanks for posting here.

    I agree with Jorge, according to your description it seems the client is using an external DNS server which was cause we get the external address we band to the domain .

    Meanwhile, it is not a good idea to set same internal and external domain name . we’d better to set either different name or sub name of current domain name :

    Creating Internal and External Domains

    http://technet.microsoft.com/en-us/library/cc755946(WS.10).aspx

    Thanks.

    Tiger Li


    Tiger Li

    TechNet Community Support

    • Marked as answer by Tiger Li Friday, June 08, 2012 2:07 AM
    Tuesday, June 05, 2012 8:23 AM

All replies

  • Hello, 

    I Suggest you post your query in concerning IIS forums: http://forums.iis.net/

    Anyways, Here is good article link for "how to configure DNS for web server": http://support.microsoft.com/kb/324260.

    Moreover this link is for Win2003 server, similar kind of settings will help to win2008 server:

    Installation of web server :http://learn.iis.net/page.aspx/26/installing-and-configuring-

    Another useful link:http://en.kioskea.net/faq/5555-setting-up-your-own-home-web-server#q=Dns+configuration+for+web+server&cur=2&url=%2F


    Regards, Ravikumar P

    Sunday, June 03, 2012 11:09 AM
  • If you created an internal DNS zone and a record that points to 192.168.1.100, you ALSO have to make sure that your internal computers are configured to point to your internal DNS server.  When you tried NSLOOKUP, the result seems to be for the external host, not your internal host.  That leads me to beleive that the computer you are on is not configured to point to your internal DNS server.

    With regard to IIS, run the website on port 80.  If you run it on another port, you have to specify that in the URL of your browser.  For instance, if your web runs on port 8080, then the URL will be http://abc.com:8080.  

    If this is the only website running on this web server, you do not have to bind the web site to any IP/port, and do not have to add host headers.  That is only necessary when you run more than one web site in IIS, so the webserver knows which web site to serve.

    If you want to access this site from an external host, you also have to set up your router for port forwarding and make sure the external record points to the external IP of your internet router.

    I have a few articles that may be of interest to you: http://www.itgeared.com/topic-2/web/


    Guides and tutorials, visit ITGeared.com.

    itgeared.com facebook twitter youtube

    • Proposed as answer by Tiger Li Tuesday, June 05, 2012 8:20 AM
    • Marked as answer by Tiger Li Friday, June 08, 2012 2:07 AM
    Monday, June 04, 2012 12:54 AM
  • Hi namman,


    Thanks for posting here.

    I agree with Jorge, according to your description it seems the client is using an external DNS server which was cause we get the external address we band to the domain .

    Meanwhile, it is not a good idea to set same internal and external domain name . we’d better to set either different name or sub name of current domain name :

    Creating Internal and External Domains

    http://technet.microsoft.com/en-us/library/cc755946(WS.10).aspx

    Thanks.

    Tiger Li


    Tiger Li

    TechNet Community Support

    • Marked as answer by Tiger Li Friday, June 08, 2012 2:07 AM
    Tuesday, June 05, 2012 8:23 AM