none
Need help to enable RDP using GP in windows server 2003

    Question

  • Greetings,

    I am newbie learning windows servers, I need to enable remote desktop connections to windows machines (Both servers and XP machines) to users who are present in my domain using GPO, I tried to enable it using the 

    1. Computer Configuration > Admin Templates > Windows Components > Terminal Services > Allow users to connect remotely using Remote Desktop Services = Enabled

    2. Also editied the  Computer Configuration, Policies, Windows Settings, Local Policies, User Rights Assignment, Allow Log on Through Terminal Services.

    But still I am not able to enable the RDP for the users in my domain. 

     Let me know how I can do it.

    With regards,

    Gopinath.


    With regards, Gopinath.


    • Edited by S.M.Gopinath Monday, January 28, 2013 12:02 PM Added details.
    Monday, January 28, 2013 11:52 AM

All replies

  • what does gpresult has to say?

    Is the policy getting applied to the machine at all or not?

    you can run gpresult to see if the GPO is getting applied or not.


    Paras

    Monday, January 28, 2013 12:02 PM
  • Thanks for the reply, I will check and let you know.

    With regards, Gopinath.

    Monday, January 28, 2013 12:04 PM

  • Microsoft (R) Windows (R) XP Operating System Group Policy Result tool v2.0
    Copyright (C) Microsoft Corp. 1981-2001

    Created On 2/2/2013 at 9:54:21 PM


    RSOP results for TEST\db2admin on EXCELLENT2 : Logging Mode
    ------------------------------------------------------------

    OS Type: Microsoft Windows XP Professional
    OS Configuration: Member Workstation
    OS Version: 5.1.2600
    Domain Name: TEST
    Domain Type: Windows 2000
    Site Name: Default-First-Site-Name
    Roaming Profile:
    Local Profile: C:\Documents and Settings\db2admin.TEST
    Connected over a slow link?: No


    COMPUTER SETTINGS
    ------------------
    CN=EXCELLENT2,CN=Computers,DC=test,DC=com
    Last time Group Policy was applied: 2/2/2013 at 9:48:38 PM
    Group Policy was applied from: excellent1.test.com
    Group Policy slow link threshold: 500 kbps

    Applied Group Policy Objects
    -----------------------------
    Default Domain Policy
    RDP_TEST1

    The following GPOs were not applied because they were filtered out
    -------------------------------------------------------------------
    Local Group Policy
    Filtering: Not Applied (Empty)

    The computer is a part of the following security groups:
    --------------------------------------------------------
    BUILTIN\Administrators
    Everyone
    BUILTIN\Users
    NT AUTHORITY\NETWORK
    NT AUTHORITY\Authenticated Users
    EXCELLENT2$
    Domain Computers


    USER SETTINGS
    --------------
    CN=db2admin,CN=Users,DC=test,DC=com
    Last time Group Policy was applied: 2/2/2013 at 9:53:37 PM
    Group Policy was applied from: excellent1.test.com
    Group Policy slow link threshold: 500 kbps

    Applied Group Policy Objects
    -----------------------------
    Default Domain Policy

    The following GPOs were not applied because they were filtered out
    -------------------------------------------------------------------
    RDP_TEST1
    Filtering: Not Applied (Empty)

    Local Group Policy
    Filtering: Not Applied (Empty)

    The user is a part of the following security groups:
    ----------------------------------------------------
    Domain Users
    Everyone
    Remote Desktop Users
    BUILTIN\Users
    BUILTIN\Administrators
    REMOTE INTERACTIVE LOGON
    NT AUTHORITY\INTERACTIVE
    NT AUTHORITY\Authenticated Users
    LOCAL
    Domain Admins
    DB2ADMNS

    With regards, Gopinath.

    Saturday, February 02, 2013 4:33 PM
  • I am able to enable the remote desktop but it works only one time after rebooting. If I login with another user after disconnecting the first user, it says the below error message:

    " You do not have access to log on to this session" 

    Let me know how to solve this issue.


    With regards, Gopinath.

    Saturday, February 02, 2013 4:46 PM
  • You have defined the policy under computer configuration so the policy is applied on the machine (for all user)

    I can see that the settings are applied. May be the other user doesnot have the rights for remote log in and that is why it is failing.

    Please make sure that other user is also a part of remote desktop user group.

    Please take a look at :

    http://social.technet.microsoft.com/Forums/da-DK/winserverTS/thread/6aa74f4e-647a-4115-a78c-ec6293688f0a

    http://social.technet.microsoft.com/Forums/hu/winserverTS/thread/2df0231e-89dd-42bc-8c4d-554064369120

    http://willbradley.name/2010/05/how-to-solve-you-do-not-have-access-to-logon-to-this-session-error-in-windows-xp-via-group-policy-gpo/

    Let me know if this doesnot solve your problem.


    Paras

    Monday, February 04, 2013 12:11 PM